my bluetooth mouse loses connection too easily

I’m facing some issues with my bluetooth mouse, JETech 0884, that worked like a charm until yesterday (for 3 years). I’m running Leap 42.3 64bit and the pc has the motherboard Gigabyte ga-f2a88xn-wifi with an integrated bluetooth chip.

Usually when I log into the DE I only need to click the mouse button a couple of times so the mouse wakes up and automatically connects with the pc. On the plasma panel I can see the dots next the bluetooth icon so i know the connection succeed.

But since yesterday if I click the mouse’s buttons the dots next the bluetooth icon appear just for a fraction of second to disappear.

To connect the mouse I have to open the terminal, run


and then

connect "mac address"

while I press the connection button on the mouse.

So finally I can use the mouse.
The annoying thing it’s that if the mouse goes in sleep mode, after a period of inactivity, i have to do the same procedure and I can’t just wake the mouse by clicking its buttons.
Today i tried to uninstall and install bluedevil5 bluedevil5-lang bluez bluez-tools pulseaudio-module-bluetooth without success.

Batteries fresh???

new battery same problem.

I wonder if TLP (Power Management Utility) might be helpful here. Although intended for laptop power management, it might be useful for bluetooth power management perhaps.


     Exclude bluetooth devices from autosuspend mode:
  • 0 – do not exclude
  • 1 – exclude
     Default when unconfigured: 0
     **Note:** this feature is intended to solve stability issues with bluetooth connections.