My alarm clock is not working

My alarm clock is not working, any way to troubleshoot using the CLI?

Again a completely unclear message here. We cannot help you unless you provide us with proper info.

I meant the alarm that comes with the default clock on 15.2 is not working, in that I have set up multiple alarms but none of them are ringing. One reason for that might be exceeding the number of possible alarm settings, but in that case it would have disallowed me by default. Is that enough info, or do you need more?

You seem to think that all other persons here are looking over your shoulder and doing the same things as you all the time. This is NOT the case.

I have an alarm clock, it is beside my bed and it works.

You say you have one and it seems to be something that is done using openSUSE. So EXPLAIN what you are doing and using. A CLI command? Any desktop environment? Where, what, how?

A question put here in only one or two lines is seldom a good, thought over question. First think, then formulate, the type that down in a document, then go for a thee/coffee, then try to re-read that text as someone that never used your system, do you still understand all steps? Then re-formulate. Maybe then start a thread and post your well thought over problem description.

Maybe have a read here: . Not all is applicable to the openSUSE forums, but the main idea as written there is very much true.

Do you mean the GNOME, as in “gnome-clocks”, alarm feature?

  • Searching with DuckDuckGo reveals that, as of 22 days ago, the thing has a problem …

The journalctl log says: gnome-clocks[189396]: utils.vala:391: Error playing sound: Invalid argument

Do you mean the KDE Plasma “KAlarm” application?

  • If that’s the case, you may well have to install the “kalarm
    ” package to get it working properly. - Despite the supporting packages which integrate into the KDE PIM (Kontact) being present by default – akonadi-plugin-kalarmcal, kalarmcal, libKF5AlarmCalendar5 …

Yes I meant the gnome-clocks alarm feature, and it has the problem mentioned, it doesn’t play the sound. I tried KAlarm as well, but couldn’t figure out how to configure the kalarm calendar files in a straightforward fashion to suit my needs, it all seems too complicated and not worth it to learn for a simple thing as this.

What I’m doing is simply opening the default clock app in gnome from the menu and trying to make it work, but the sound doesn’t seem to work. I am sorry about the apparent flippancy of my question and will try to be more careful next time.

Personally, I’m used to adding “reminders” to appointments and tasks – which can be configured to be noisy at the point in time when the reminder is triggered – provided that. the colleagues present within ear-shot of the noise, are not being disturbed by the alarm noise being produced by your system …

Wish I was as savvy as you.

If you check settings -> sound, is the correct sound output device selected (press test), is the systems sounds volume level too low?

System sounds was set to zero, I rectified that, let’s see what happens. Thanks for the tip.