My 12.1 OpenSUSE does not shut down properly

Hello,
I have upgraded my 11.4 to 12.1 via web update. I left the machine for two days without shutting down. Today I tried to shut down the machine, it closed all applications, showed the green OpenSUSE wallpaper, and stopped working.

Any ideas on how to completely shut down the machine? I tried failsafe boot, but it failed to show the login screen and stopped after 13 seconds.

Thank you for your help…

On 12/28/2011 07:56 PM, bakkurt wrote:
> Any ideas on how to completely shut down the machine?

this is a known problem!!
to shut down:
-shut down all open programs
-open terminal/konsole/xterm (your choice) and type/enter the following
commands


su -
shutdown -h now

and give the root password when requested

to reboot, change the -h to -r


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
openSUSE®, the “German Engineered Automobiles” of operating systems!

This worked for me, I ran systemsettings and then went to System Administration > Login Screen > Shutdown tab and in the halt field entered in /sbin/shutdown. Probably not the most correct way but at least my machine shuts off now.

Thank you for your help.

Right now I am using the following command to shut down:

sudo /sbin/shutdown -h now

By entering the password for root, I am able to shut down the machine. I hope that the developers see this problem.

Happy new year to all forum members.

Needs to be reported on bugzilla if you hope to have it work in the future

I need
/sbin/shutdown -h -P now
to shutdown and poer off rather than leaving my machine powered on in the halt state.

It does power off, it is just the halt field.

Under Systemd use:

halt -p