Must be missing something obvious.

Trying to get wireless working on my d600 laptop with an intel wm3a2100 minipci card. I also have a broadcom bcm94306 and a bcm94309mp if those are easier/better. I followed the guides listed for installing the firmware and I can scan and see my wirless access point but I cant get the config thorugh yast to work, and when I switch to networkmanger i can no longer see the WAP when I scan with iwlist. Information requested listed below. I know i must be overlooking something if someone could take a look. It could be the hardware on/off switch but I can scan the network so I thought I had that set up right.

1> intel wm3a2100 minipci card
2> lsmod
ipw2100 128067 0
libipw 41980 1 ipw2100
cfg80211 155663 2 ipw2100,libipw

modinfo ipw2100
filename: /lib/modules/2.6.34-12-default/kernel/drivers/net/wireless/ipw2x00/ipw2100.ko
firmware: ipw2100-1.3.fw
firmware: ipw2100-1.3-p.fw
firmware: ipw2100-1.3-i.fw
license: GPL
author: Copyright(c) 2003-2006 Intel Corporation
version: git-1.2.2
description: Intel(R) PRO/Wireless 2100 Network Driver
srcversion: E9721D068DD387EFA5AE7A0
alias: pci:v00008086d00001043sv00008086sd000025A0bcsci*
alias: pci:v00008086d00001043sv00008086sd00002598bcsci*
alias: pci:v00008086d00001043sv00008086sd00002596bcsci*
alias: pci:v00008086d00001043sv00008086sd00002593bcsci*
alias: pci:v00008086d00001043sv00008086sd00002591bcsci*
alias: pci:v00008086d00001043sv00008086sd00002592bcsci*
alias: pci:v00008086d00001043sv00008086sd00002590bcsci*
alias: pci:v00008086d00001043sv00008086sd00002587bcsci*
alias: pci:v00008086d00001043sv00008086sd00002586bcsci*
alias: pci:v00008086d00001043sv00008086sd00002585bcsci*
alias: pci:v00008086d00001043sv00008086sd00002581bcsci*
alias: pci:v00008086d00001043sv00008086sd00002583bcsci*
alias: pci:v00008086d00001043sv00008086sd00002582bcsci*
alias: pci:v00008086d00001043sv00008086sd00002580bcsci*
alias: pci:v00008086d00001043sv00008086sd00002570bcsci*
alias: pci:v00008086d00001043sv00008086sd00002567bcsci*
alias: pci:v00008086d00001043sv00008086sd00002566bcsci*
alias: pci:v00008086d00001043sv00008086sd00002565bcsci*
alias: pci:v00008086d00001043sv00008086sd00002561bcsci*
alias: pci:v00008086d00001043sv00008086sd00002563bcsci*
alias: pci:v00008086d00001043sv00008086sd00002562bcsci*
alias: pci:v00008086d00001043sv00008086sd00002560bcsci*
alias: pci:v00008086d00001043sv00008086sd00002555bcsci*
alias: pci:v00008086d00001043sv00008086sd00002554bcsci*
alias: pci:v00008086d00001043sv00008086sd00002553bcsci*
alias: pci:v00008086d00001043sv00008086sd00002551bcsci*
alias: pci:v00008086d00001043sv00008086sd00002550bcsci*
alias: pci:v00008086d00001043sv00008086sd0000252Dbcsci*
alias: pci:v00008086d00001043sv00008086sd0000252Cbcsci*
alias: pci:v00008086d00001043sv00008086sd0000252Bbcsci*
alias: pci:v00008086d00001043sv00008086sd00002529bcsci*
alias: pci:v00008086d00001043sv00008086sd00002528bcsci*
alias: pci:v00008086d00001043sv00008086sd00002527bcsci*
alias: pci:v00008086d00001043sv00008086sd00002523bcsci*
alias: pci:v00008086d00001043sv00008086sd00002522bcsci*
alias: pci:v00008086d00001043sv00008086sd00002526bcsci*
alias: pci:v00008086d00001043sv00008086sd00002525bcsci*
alias: pci:v00008086d00001043sv00008086sd00002524bcsci*
alias: pci:v00008086d00001043sv00008086sd00002521bcsci*
alias: pci:v00008086d00001043sv00008086sd00002520bcsci*
depends: libipw,cfg80211,lib80211
vermagic: 2.6.34-12-default SMP mod_unload modversions 586TSC
parm: debug:debug level (int)
parm: mode:network mode (0=BSS,1=IBSS,2=Monitor) (int)
parm: channel:channel (int)
parm: associate:auto associate when scanning (default off) (int)
parm: disable:manually disable the radio (default 0 [radio on]) (int)

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

02:03.0 Network controller: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)
Subsystem: Intel Corporation Device 2565
Flags: bus master, medium devsel, latency 32, IRQ 5
Memory at fafef000 (32-bit, non-prefetchable) [size=4]
Capabilities: [dc] Power Management version 2
Kernel driver in use: ipw2100

iwconfig I have tried setting it up through yast doesnt seem to save what I select as iwconfig remains as follows tried to set it up in networkmanager as well but i cant even see the WAP for some reason asn Im not familiar enough with iwconfig to set it up through the command line.
eth1 unassociated ESSID:off/any Nickname:“ipw2100”
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:16 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:ff
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I’ve looked at quite a few guides around the net been working last couple days on it of and on, I know i must be overlooking something stupid.[/size]

Iwlist(wap I want with wpa-personal)
Cell 02 - Address: 00:1E:58:2E:26:FD
Protocol:IEEE 802.11bg
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality:42 Signal level:0 Noise level:0
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 744ms ago

Got my wireless working, switched to the bcm94309mp yast configure still didn’t work but network manager could view the networks and using that I was able to connect. With the other card when I switched to netmanager iwlist stopped working and netmanger couldn’t see any networks. Well this card works fine so I’m satisfied spent to much time on that other card.