music disks will only play one track, not entire disk from start to finish

Hello. I tried to search for this problem but did not find it. Sorry if I am repeating what’s already been asked.

My wife has Leap 42.1 on both her laptop and desktop. When she inserts a music disk (CD) into either drive it does not matter what media player she uses, there are problems.

If she uses SMplayer, KsCD, or Dragon Player only the first track will play. After the first one completes nothing happens. She can manually click on either computer to play track 2, and then when that’s finished track 3, etc., But she can’t just put in the disk and listen to it from start to finish.

If she tries to use Clementine or Pragha nothing plays – not even the first track. We can’t figure out how to get either of these programs to respond.

We’re at a loss for a solution. We’ve looked at the settings and configuration tabs in the various players but not found anything that indicated (at least as far as we could tell) “Play first track and stop,” or “Play entire disk.” Tried multiple CDs just in case something might be encoded on a disk that Leap did not like, but nothing changes. First track only on the three players noted and nothing at all for the other two players.

It was simple with SuSE 13.2 – everything just worked. But we’re completely stumped here with Leap 42.1. We realize it’s probably something incredibly silly that we’re missing and ask for help.

Is there other information we can provide to help you identify the source of our problem and suggest a solution so she can listen to her music?


openSUSE supports mp3’s out of the box with the gstreamer-fluendo-mp3 package, most not all apps use gstreamer so for starters the question arises did you add and do a full vendor change with packman as to get multimedia workiing tell us your repos

zypper lr -d

Is that an uncompressed wave audio CD or a disk with music mp3 and aac/m4a files?
I believe auto-play depends on the Desktop used ie plasma 5 or Gnome or LXDE etc. so what desktop are you using and how is it configured?

I just did a test with a data disk containing mp3 files and plasma 5 only gave me 2 choices: open disk in dolphin and Download Photos with digiKam.
but I could start amarok select play media and chose the root of the disk, amarok plays the entire disk, this could be a plasma 5 bug not defining actions for devices with audio files.

but I am using plasma 5.6 so things might not be the same for plasma 5.5

To avoid confusion.
IMHO the OP is talking about an Audio CD. That does not contain any file system (let alone mp3 files), but has it’s own structure.

When I enter an Audio CD in my 13.1 system, it gives a lot of options:

  • open with file manager
  • rip digital audio with k3b
  • play audio CD with KsCD
  • play audio CD with Kaffeine
  • copy with k3b
  • open with VLC media player

I tried Kaffeine, at the end of a track it jumps to the next track.
I tried VLC, the same.

Thus it works here as the OP expects.

BTW, opening with file manager starts Konqueror and it offers all tracks as .wav files. It also offers directories with names like MP3 and Ogg Vorbis, which offers you the same tracks as .mp3 and .ogg files. Ready to be copied and thus ripped.

My wife is only just starting to learn Leap, and I am still using SuSE 13.2 so I have no knowledge of Leap. I will have to ask her the above regarding vendor change to packman. Also, as to what desktop she is using, how do we know for certain? (Sorry, stupid question, but we don’t know Leap.) I think she is using plasma 5 but will have to verify.

As to what type of disk, well we tried some older CDs that are whatever they are. As to aac/m4a files… now you’ve just gone over my head asking about formats I’ve never heard of. I will ask and see if she knows.

I will try to send you a listing of her repos. Stay tuned. Thanks for your help and patience while we try to muddle our way through a SuSE that is so different from what we know with 13.2.

Yes, I am talking about audio CDs. When I insert an audio CD on my 13.2 system I get:

  • open with file manager
  • extract digital audio with k3b
  • play audio CD with KsCD
  • play audio CD with Kaffeine
  • copy with k3b
  • open with VLC media player

If select Kaffeine as my player one song finishes, then the next one starts. Just as you would expect, but not as Leap 42.1 is doing.

And I get the same thing when I open file manager.

Wish we could get all of this with 42.1. I suspect it must be possible – if only we had the key. :o)

If we run zypper lr -d in the konsole do I copy and paste the output into a reply here? Is that the proper way to respond to your request to show the repos?


As to aac/m4a files… now you’ve just gone over my head asking about formats I’ve never heard of. I will ask and see if she knows.

I was asking if you wore using audio cd’s which are extremely rare these days or you wore using disks with audio files (doesn’t have to be a cd it could be a usb stick).

As she’s on LEAP and if she has done all the recent updates then the desktop is probably plasma 5.5, her issue is one of the many plasma 5 short comings, not sure how to fix them on data disks with media files maybe a bug report?
I couldn’t find an audio CD so I tested with a disk that had audio files and while the old plasma 4 offered me multiple options plasma 5 only gave me an option to open the disk with dolphin.

Yes, but you should do the paste between CODE tags. You get the CODE tags by clicking on the button with the # in the post editor.

OK, thanks. Will post that way as soon as we get the information.

OK, thanks to everyone for the suggestions. This reply will hopefully address all the issues.

I discovered that my wife had not downloaded all the various bits and pieces needed to successfully do multimedia in 42.1. So poking around I found this very helpful page:

and followed the instructions to grab all those missing bits an pieces. I then updated everything switching to the packman repository to get the best files.

This then gave us everything we needed to play music CDs from start to finish. No more stopping after the first track. :slight_smile:

The DVD player defaults to Dragon which seems fine. I also tried various players by playing individual tracks from Dolphin and they all work fine.

So thanks to all for the help.


You are welcome. And yes “switching to Packman” usualy solves multi-media problems. That is why most here only start digging in a problem offered when the OP there explains he realy (1000%) did do that switch.

that guide is a bit flaky, it recommends replacing phonon-backend-gstreamer with phonon-backend-vlc, this breaks opensuse 13.2 (it can literally crash the plasma 4 desktop) and while it works on leap imo the gstreamer backend is a bit more polished and better so if you replaced it bring it back, imo the best and fastest way to make multimedia work is with the command line and zypper no one click’s no special codec guides you just add packman and do a vendor change with it, it takes only 2 commands, and that’s why I asked for the repo list to see if you have packman and what was it’s alias so you could do a dup with it (it’s alias is different on different machines as it depends on all your repo’s)

Understood. :slight_smile:

Thank you.

Please, just for clarification…

  1. All of the changes were to my wife’s Leap 42.1 computer. No changes were made to my 13.2 system.

  2. You opine that for the Leap 42.1 computer replacing phonon-backend-gstreamer with phonon-backend-vlc as instructed in the guide is not optimal, and instead I should reinstall the phonon-backend-gstreamer package and remove the phonon-backend-vlc package? Correct?


Not if you install phonon-backend-vlc from Packman, which is available since today… :wink: (and as it is a later/higher version, YaST/zypper should prefer to install it too)
And this problem doesn’t exist in Leap 42.1, because this contains the same VLC version as Packman at the moment anyway.

phonon-backend-gstreamer (that’s installed by default) should work fine (or even better) in most regards, but especially playing Audio CDs is broken, it only can play the first track as described in the subject.
It does work with phonon-backend-vlc.

You can of course also use other players that don’t use phonon for that, like e.g. VLC itself, Kaffeine, Xine, or MPlayer.
Amarok, Dragonplayer, and K3b all use Phonon.

Regarding phonon, also note that Leap 42.1 comes with Plasma5 and many KF5 applications, in this case phonon4qt5 is used and the corresponding backends are phonon4qt5-backend-gstreamer and phonon4qt5-backend-vlc.