Multipple Harddrives - one for OPENSSUSE one for WIN8.1. booting issues

Hallo

I have multiple harddrives inside my computer.
on one Win8.1 is installed so far (/dev/sda).

one serves as storage (/dev/sdb) we dont care about this

the third harddrive (/dev/sdc) is empty so far, but i want to get opensuse on this one.

scheme looks like this:
/dev/sda
/dev/sda1 (Windows8.1, NTFS)

/dev/sdb
/dev/sdb1 (storage, NTFS)

/dev/sdbc (1 TB DEVICE)
/dev/sdc1 (/home, 300 GB)
/dev/sdc2 (/, 15 GB)
/dev/sdc3 (swap, 10.00 GB)
/dev/sdc4 (/boot/efi, FAT 250 MB)
the rest of the free space i would like to use as storage, where windows and linux can acccess the drive (this is not the priority problem here)

I installed opensuse on this /sdc partition.
now i can only start windows when i set /sda to priority boot.

how to configure the booting in order to choose with arrows between the two systems.

then how to configure the rest of the free space on /sdc, so that i can also access it from windows? partition manager?

with regards

The problem you are seeing may be a BIOS limitation.

Which version of opensuse are you using?

Is there a Windows entry in the grub boot menu for opensuse?

As I recall, with opensuse 12.3, there was a problem that the boot menu entry for Windows did not work. But that should be fixed if you have applied all available updates.

With 13.1, there is no comparable problem. If you are having this problem with 13.1, then that might be to do with your BIOS.

My advice would be to reinstall opensuse, but put “/boot/efi” on the EFI partition used by Windows. I cannot tell which that is, because you have not provided enough information.

It would help if you can post the output from


# gdisk -l /dev/sda
# gdisk -l /dev/sdb
# gdisk -l /dev/sdc
# efibootmgr -v

Use code tags to post. The “#” symbol on the edit box will generate those, then paste in the output.

“gdisk -l /dev/sda” —>

GPT fdisk (gdisk) version 0.8.7

Partition table scan:
MBR: MBR only
BSD: not present
APM: not present
GPT: not present


Found invalid GPT and valid MBR; converting MBR to GPT format
in memory.


Disk /dev/sda: 234441648 sectors, 111.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 73537702-BAF4-481B-827C-C53B51DF6787
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 234441614
Partitions will be aligned on 2048-sector boundaries
Total free space is 4973 sectors (2.4 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 234438655 111.8 GiB 0700 Microsoft basic data

“gdisk -l /dev/sdb” —>

GPT fdisk (gdisk) version 0.8.7

Caution: invalid main GPT header, but valid backup; regenerating main header
from backup!

Partition table scan:
MBR: MBR only
BSD: not present
APM: not present
GPT: damaged

Found valid MBR and corrupt GPT. Which do you want to use? (Using the
GPT MAY permit recovery of GPT data.)
1 - MBR
2 - GPT
3 - Create blank GPT

Your answer: no
Disk /dev/sdb: 1953525168 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 17E6EC98-724D-41D7-8F6A-A644E0774416
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525134
Partitions will be aligned on 2048-sector boundaries
Total free space is 1953525101 sectors (931.5 GiB)

Number Start (sector) End (sector) Size Code Name

“gdisk -l /dev/sdc” —>

PT fdisk (gdisk) version 0.8.7

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sdc: 1953525168 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): B2A2E704-A81F-42FA-9C02-029C339446FC
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525134
Partitions will be aligned on 2048-sector boundaries
Total free space is 1271438701 sectors (606.3 GiB)

Number Start (sector) End (sector) Size Code Name
1 2048 629153791 300.0 GiB 0700 primary
2 629153792 660609023 15.0 GiB 0700 primary
3 660609024 681574399 10.0 GiB 0700 primary
4 681574400 682088447 251.0 MiB 0700 primary

“efibootmgr -v” ---->

BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0003,0001,0000,0002
Boot0000 CD/DVD Drive BIOS(3,0,00)
Boot0001* Hard Drive BIOS(2,0,00)
Boot0002 Removable Drive BIOS(1,0,00)
Boot0003* opensuse HD(4,28a00000,7d800,da87ee2e-d2d4-4660-99b0-f56bb648dd97)File(\EFI\opensuse\grubx64.efi)

You put that information in a QUOTE (used QUOTE tags) instead of using CODE tags. That makes it harder to read. And it also means that it doesn’t get quote (not as important).

In any case, the information is very helpful.

Your computer has UEFI support. But it also has a backward compatible Legacy MBR mode. The two do not mix.

It looks as if you installed Windows 8 in the Legacy MBR mode, and you installed opensuse in UEFI mode. That is why you are having problems.

To get what you want, you will either need to reinstall opensuse in legacy MBR mode, or you will need to reinstall WIndows 8 in UEFI mode. Take your pick.

I’m guessing that it is easier for you to reinstall opensuse in legacy MBR mode.

If you do it that way, you have another problem. Your “/dev/sdc” is using GPT partitioning instead of MBR partitioning. This is not actually a problem for opensuse. In fact, opensuse handles GPT quite well. But Windows won’t touch it, if Windows is installed in legacy MBR mode. That’s likely going to give you problems accessing data on “/dev/sdc” from Windows.

If you want to change the partitioning, you will have to erase the partition table on “/dev/sdc”. That’s easiest to do with the “gdisk” command. If you have a live KDE or live Gnome or live Rescue disk for 13.1, then use “gdisk” from there. You could use “gdisk” from within your installed opensuse, but that might crash opensuse since you are messing with the running system.

The way to erase a GPT partition table with “gdisk” is:


# gdisk /dev/sdc

Then use the “x” command (type the single letter “x” without the quotes). That puts you into expert mode.
Then use the “z” command to zap the partition table.

Feel free to continue the discussion here and ask questions about this, before you do that zapping.

It is easier to reinstall opensuse. That means first i have to delete the /sdc Partition from a USB-Live-Linux-Distribution?
this i do via terminal with the order:

gdisk /dev/sdc

after deleting it, i will have unallocated space on this hard drive. At this point i will not know how to proceed, how to install opensuse in MBR mode.
And if this is done, i will have Troubles to Access data on sdc from Windows?

My Win 8.1 is still fresh. i could still wipe both hard drives, and install in UEFI mode. Yet i would not know how to do that. since 2 days ago both hard drives were OS free, i installed Win8.1 first, but i never saw that i could choose wether to install Win8 in MBR mode or UEFI.

Does it make more sense to have Windows in UEFI mode?

well the Terms UEFI and MBR are anyway new to me

Let me start with code tags.

If I QUOTE text, it looks like this.

If I use CODE tags, it looks like this.

Notice the difference.

The way I used the CODE tags was to select the text (with mouse), then click on that # symbol. If I hold my mouse over the # symbol, I see “Wrap CODE around selected text”.

I’m stressing this, because it is easier to read. In particular, CODE tags leaves the text is single-spaced characters, such as you see in a command line terminal, and it honors spaces so keeps text lined up in columns.

Here’s the output from “ls /”. First, with QUOTE tags:

% ls /
altsys croot home lost+found opt run shared tmp windows
bin dev lib media proc sbin srv usr
boot etc lib64 mnt root selinux sys var

% ls /
altsys  croot  home   lost+found  opt   run      shared  tmp  windows
bin     dev    lib    media       proc  sbin     srv     usr
boot    etc    lib64  mnt         root  selinux  sys     var

I hope you can see the difference.

Now, getting back to your issues.

My own Windows 8 (which I don’t much use) is installed in UEFI mode. That’s typical. I think Microsoft requires UEFI mode for new installations at the factory (their agreement with vendors).

You might have purchased a 32-bit version of Windows 8. In that case, then you can only install in legacy MBR mode.

Let me explain the differences.

Legacy MBR mode: this is the way things have been done since the first PCs from the early 1980s. It was designed for a disk drive with a max of 32M of capacity. There have been numerous extensions to allow bigger disk drives to be used. But the old method is running out of steam. The replacement is UEFI - a different firmware (replaces the old traditional BIOS). UEFI is the acronym for Unified Extensible Firmware Initiative. All newer 64-bit computers support it.

Recent computers have a BIOS setting to switch between legacy mode and the newer UEFI mode. Most have a CSM (compatibility support module) which allows easy switching between the two. But the switching is done at boot time. Once you start booting in UEFI mode (which you are doing with opensuse), you cannot boot a legacy system which depends on different BIOS calls. And, vice versa.

You presumably have a DVD, or perhaps an install USB for Windows. If it is for the 64-bit version of Windows 8, then your computer can probably boot it in either UEFI mode or in Legacy MBR mode. If it is a 32-bit Windows version, they you can only boot in legacy MBR mode. It will be the same for your opensuse install DVD (or perhaps USB). You can boot that in either UEFI mode or legacy MBR mode. How you boot it will determine how it is installed.

Whether to reinstall Windows – that’s your decision. If you have 32-bit Windows, then you have no choice. It will be legacy MBR mode anyway. The same would be true of 32-bit opensuse.

Two years ago, many people were frustrated with UEFI, and recommending that you reinstall in legacy MBR mode. I haven’t seen much of that lately. Personally, I like UEFI, though current implementations have some quirks.

Which way to go is your decision.

Assuming that you want to reinstall opensuse in MBR mode, then start by zapping the partition table on “/dev/sdc” as previously described.

Next, I suggest that you create a Windows partition on that drive from within Windows. That will guarantee that you have something there that Windows can see.

And then boot your opensuse install DVD into legacy MBR mode, and install from there. It should preserve the Windows partition that you have already created on “/dev/sdc” (unless you made it so big that there is no room for opensuse).

I hope that helps to explain the situation. Again, feel free to raise more questions. I do understand that you will be hesitant about what to do at this stage.

indeed i see now the difference between Quote and Wrap_code :D, thx.

well i’ve decided put Windows and opensuse on UEFI. It seems anyway that it will be unavodidable in the future to know how to do that.

the question would be now how to proceed.

i’m aiming for:

win8 on /sda
opensuse on /sdc
storage drive (other harddsik) /sdb (this allready works)

should i wipe /sda and /sdc completly?

still by doing this i dont really know how to proceed, weather i should install first open suse or win8?
or i can leave the actual opensuse on /sdc and reinstall only win8?

I have a 64bit msdnaa-usb-win8 Version, still it installed in MBR mode. is there during the Installation an Option with which i can choose to install Win8 in uefi mode?

If they are fresh installs, and you have done no setup or have no items you need to keep, then – yes – I personally would clear the drives before redoing. However, that point is not crucial (unless UEFI makes it necessary, none of my systems are UEFI, so I can not say for certain.).

still by doing this i dont really know how to proceed, weather i should install first open suse or win8?
or i can leave the actual opensuse on /sdc and reinstall only win8?

Always install Windows first, before installing openSUSE. It saves tons of headaches.

I have a 64bit msdnaa-usb-win8 Version, still it installed in MBR mode. is there during the Installation an Option with which i can choose to install Win8 in uefi mode?

Maybe nrickert can answer that one for you.

I suggest you start by booting the Windows 8 installer in UEFI mode. The main point is to make sure you can do that, before you erase the existing system.

My guess is that if you then try to install, Windows 8 will insist on erasing “/dev/sda” anyway, and repartitioning it in the way it wants for a UEFI install.

Start with that. We can look into opensuse, once you have Windows installed in UEFI mode. It is possible that your already installed opensuse will still be fine, and just need its boot menu updated.

On 2014-06-06 18:26, carborane wrote:
> storage drive (other harddsik) /sdb (this allready works)

No, your sdb has a corrupted partition table. Sooner or later, you risk
losing the data as well.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

i reinstalled windows on the /sda HD. (sda is set in BIOS as the First/priority HD)

and yet:

gdisk -l /dev/sda

gives


GPT fdisk (gdisk) version 0.8.7

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present


***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. 
***************************************************************

Disk /dev/sda: 234441648 sectors, 111.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 32CF1439-8FB7-442A-B095-E67434172E39
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 234441614
Partitions will be aligned on 2048-sector boundaries
Total free space is 4973 sectors (2.4 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          718847   350.0 MiB   0700  Microsoft basic data
   2          718848       234438655   111.4 GiB   0700  Microsoft basic data

it seems that windows was installed again in MBR.

im installing msdnaa version from live usb, but copied the .iso now to DVD.
Would installing from DVD change something?

You installed opensuse in UEFI mode, so your computer is capable of booting the install media that way. Yet you seem to be booting the Windows install media in legacy MBR mode.

Are you sure you have a 64-bit Windows 8? I would expect 32-bit Windows 8 to behave that way (only use legacy MBR), but not 64-bit.

On 2014-06-07 11:56, carborane wrote:


>   ***************************************************************
>   Found invalid GPT and valid MBR; converting MBR to GPT format
>   in memory.
>   ***************************************************************

This is what I mean, and it is dangerous. You apparently have both MBR
and GPT tables, and they do not match. It may happen that a system uses
one method, and another would use the other method, causing disk
destruction.

You have to repair that. And now you have two disks in that situation.

Notice that gdisk did no repair. It just did a conversion in memory,
which is not written to disk.

If you use “fdisk -l” on that same disk it would produce another set of
interesting info.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

now i updated BIOS. Then there was an option: booting from EFI compatible devices or similar.

then i installed win8.1.
obviously the previosuly installed opensuse doesnt boot, it doesnt matter, i wiped that partition now.

and still the win8.1 installed itself in legacy mode. its 64bit. i mean it is also written in the properties of the system :smiley:

opensuse13.1 does not support to run a live demo from usb stick like ubuntu?

Yes, it does. But it may be a different download from the one that you have.

The download page offers:

  • Install DVD
  • live KDE
  • live Gnome
  • live Rescue CD

The live Rescue CD is actually a live XFCE system, but does not include an installer. The live KDE and live Gnome downloads are live systems – a bit too big for a CD but can be used from a DVD or USB, and do include an installer. The live DVD download can be used from a USB but does not include a live boot.

Apart from that, I’m not sure what is happening. Perhaps your Windows installer is for legacy MBR only. I did not know that there were such things for 64-bit. So this is a new situation.

I guess you could try the other alternative - install opensuse in legacy MBR mode.

it Looks like i finally managed to install win8.1 in uefi mode:

http://s27.postimg.org/qa9nhtzer/uefi_mode_finally.png

How i did it?
first of all i updated BIOS (Motherboard: Asus P8P67 Rev 3.1), but might have been not necessary
then it was important to make a bootable Win8.1 live usb, by using it as a FAT32 drive. (so i formatted to FAT32 the usb drive)
then i decompressed the .iso and put everything on that usb.
then via prompt i made it bootable with: (F: was the usb drive)

F:

then

cd boot

then

bootsect /nt60 F:

now the question how to proceed with opensuse

the aim:

on disk 2 (as seen in the Picture) i would like to install opensuse.
To this purpose i’aiming to:

15 GB for root: /
16 GB for swap
300 GB for home /home

the rest 600 GB for storage, where win8.1 and opensuse can acess (but i dont know how to Partition this space. i could partioon it with a partion tool, so that it gets letter assigned like C:\ ??)

then how to configure the /boot for opensuse?

The 15GB looks a tad small to me. It is big enough. But, if you want to keep the same partitioning for future versions of opensuse, then you need to allow space for growth (sometimes known as software bloat). I’d suggest 20G if you plan to use “ext4” and 40G if you plan to use “btrfs”.

You can partition in Windows, as you suggest. But then you will have to tell Windows to not assign a drive letter.

You can partition during the opensuse install.

You can partition separately – boot a live image, and run “gdisk”.

If you want help with one of those, tell us which one.

The installer will also want a partition for “/boot/efi”, and will probably want that on “/dev/sdb”. But you will have less problems if you just use the EFI partition on the first disk.

That leaves the following as my suggestion


Device name        File system      Mount as      Notes

/dev/sda2          FAT (EFI)        /boot/efi     The Windows EFI partition

/dev/sdb1          ext4             /             20G
/dev/sdb2          swap             swap          16G
/dev/sdb3          ext4             /home         300G
/dev/sdb4          NTFS             /windows/D    format this in Windows

You do not need a separate “/boot”.

This is how the partitioning looks like:

http://s29.postimg.org/wg6owzhxz/partitioning.jpg

if i want to proceed with the installation like this, an error message appears: that opensuse will be not able to boot, because theres no /boot/efi partition,

dont know how to resolve, i guess it is needed to assign opensuse somewhere in the EFI partition made by windows.

That looks good. I am presuming that you want to install on “/dev/sdc”. And I am assuming that “/dev/sdd” is the USB from which you booted to get that information (probably the DVD installer image).

if i want to proceed with the installation like this, an error message appears: that opensuse will be not able to boot, because theres no /boot/efi partition,

dont know how to resolve, i guess it is needed to assign opensuse somewhere in the EFI partition made by windows.

When you get to the partitioner section of install, click “Create Partitioning”.

The next screen has a list of disks to use. Ignore that, and instead click “Custom (expert)” (or however it is worded).

That should show your list of partitions. For any partition shown, you can right-click on that line and select “edit” to change what will happen for that partition.

First, right-click on the line for “/dev/sda1”. Leave it as “do not format” (that should be the default). Check the “Mount” box, and set the mount point to “/boot/efi”. That should be available to just select from the list.

Next, do the same for “/dev/sdc1”, “/dev/sdc2” and “/dev/sdc3”, as needed, to make sure that they show up as in your image. The “F” in the third column indicates to format.

When you are done, the final screen should look similar to what you have in the image, except that the line for “/dev/sda2” should have a mount point of “/boot/efi”.

Accept the results.

It is possible that you will still get a message warning about possible boot problems. I got that message in my most recent install (of a beta release of 13.2). As long as you are sure that you have configured “/dev/sda2” to be mounted as “/boot/efi”, you can ignore the warning and continue. You should finish up with a bootable system.

If you have problems, you can post about those to this thread.

I hope that helps.