multiple problems with sound only

Hi all
I’ve been tracking down some sound problems lately, but hit a block.
It started off I had no sound, but on most sites and video apps, no problems with video. Eventually figured out that on each boot, the sound volume on master and front speakers was being set to zero (showing on the applet as “mute”), so to get sound at all I have to reset this on each boot. This got the test sounds to work.
Then went through various programs - Audacity, Audacious, VLC - to set them up for sound. Each has different settings, and it didn’t seem that defaults worked, but on each I could find settings that worked. So for those, once the boot defaults are reset, I’ve got sound. I can’t get Amarok to work, but maybe it doesn’t work on xfce desktop. My main problem now is that I can’t get sound on Firefox, and it has no settings that I can see that might help.
I read the other thread about 13.2, which looked familiar, but I’ve fixed the permissions and I note that no one else is reporting this problem on Leap 42.1. How do I go about fixing this? I presume that a config file needs fixing at least, but not sure how this would help Firefox.
Hardware is telling me I have:
Sunrise Point-H HD audio
Nvidia audio device
but in the sound configuration, I can only get the nvdia device to pass the test sounds, so it’s the default.

OK, I appear to have fixed this.
I installed the pulseaudio volume control (suggested in another thread) and using that I found that the volume was set at zero. When I increased it, both amarok and firefox were able to produce sounds. Apparently the other apps don’t use pulseaudio. The pulseaudio settings don’t appear to be accessible or even visible in a normal Xfce install, but they are accessible in KDE through the speaker applet in the panel. In Xfce, the speaker applet is unhelpful and you seem to need to install the pulseaudio volume control. On a reboot, the new settings were maintained, so very happy now (had been using Windows 10 - ugggh!).