Multiple issues (mostly no ethernet)

Motherboard: ASUS STRIX X99
CPU: i7-6800k
Graphics: Gigabyte GeForce® GTX 1050

I at first noticed that the update repos could not be configured. Then I got the attached error message, but I do not know its significance.[FONT=Helvetica]
Once I was up, I could see that the ethernet device was configured, but there was no IP address. Since the motherboard has a wifi built in, I did configure that. It saw my home network and I gave it the correct group and password to use. Still no usable network. I cannot show “ifconfig” output because that command is not found. (!?!?!?!? WHY ???) Actually, I can’t copy and past much 'cuz it’s not connected to the internet. :slight_smile:

SO, is there something about the Intel network chip (i218) that makes SUSE unhappy?

That picture seems to relate to UEFI booting (secure boot) and needs the shim - sorry I cannot help you there

ipconfig is deprecated use the command “ip address” (or ip addr) instead.

I figured somebody had deprecated the thing. You have no control over this, but how hard is this:

cat > /usr/bin/ifconfig <<_EOF_
echo use '"ip address"' instead
sleep 2
ip address ${1+"$@"}
chmod +x /usr/bin/ifconfig

grumble, grumble. Anyway, I copied over a working ifconfig and discovered I could ping someone else on the same switch, I had an ip address given out by my router, but I was not able to ping my router. Cabling around the switch, everything worked. Um, my guess is a switch problem. Weird. My wife (whose machine I pinged) has internet access through the switch. I do not.

SUMMARY: “Never mind.”

Is this possibly a problem with “/etc/resolv.conf”.

For “ifconfig” you can install “net-tools-deprecated”.

As noted above it is still installable (with it’s friends). Easy to find when you search which YaST > Software > Software Management and "provides: switched on.

Reading this it is a bit confusing what you are testing. And you do not show anyting thus we have to guess what you are doing and getting. Apart from the advice above (that covers the most occurring problem we see here), the general approach as I have made notes of is:

You check from bottom to top:

  1. Is the NIC up with an IP address?
ip addr
  1. Can you connect to another system on your LAN?
ping -c1 <IP-address of your router>

(I hope you know that address)

  1. Do you have a default route to the Internet?
ip route
  1. Can you connect to a system on the internet?
ping -c1
  1. Can you resolve host/domain names?
ping -c1

Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

So start with 1. and do not hesitate to post the output here to get help on the interpretation.

Thank all of you for taking time to think on the problem. It is now solved.

Responses to the questions:

  1. (after grabbing an ifconfig from a live image), yes the nic was up with an assigned IP. Thus, the machine clearly talked to the router via DHCP to get the address.

  2. pinging the router failed

  3. pinging my wife’s PC succeeded.

Therefore, my “pings” got to the switch but I was not getting routing to the router or anything outside the switch (that would go through the router). Consequently, DNS services were not available.

the physical connections: my PC and wife’s PC connected to switch and switch connected to router.

wife’s PC had full, working internet connection.
my PC could only talk to my wife’s PC and a DVD player.

THEREFORE: something is weird in the switch. Patching around the switch worked, as did replacing the switch. The old switch is now out for electronic recycle.

I will word nrickert’s and my suggestion a bit stronger.
Remove that one and install the package net-tools-deprecated from the standard OSS repo.