Multiple desktop selection not working

This is on a Thinkpad with 11.1. Hopefully I’ll get te terminology right. The graphical side of Linux is confusing,
Recently reinstalled, (from 11.0) with Gnome, then added kde3, kde4 and xfce. Can’t seem to make the selection on the login screen work consistently. Click on the account, select the DM I want, then enter pwd. Should be that simple, right?

And I’d like to reset my default, but I can’t find where to do that either.

Your login will default to the last one you used, unless you change it at the login. Yes it should be that simple.

It certainly didn’t work like that reliably when I was trying out Xfce a few weeks ago. Was offered Gnome a few times on reboot and had to manually select Xfce. I’ve stopped the Xfce experiment now so that’s all from memory.

For default WM, go to yast2-/etc/sysconfig editor, it’s under desktop-window manager-default_WM and choose your wm option.
Note: if you want xfce to be the default just in case (a remote possibility) it might not be included in the lists of options so you have to manually add ‘startxfce4’

As an aside, I think it should boot to the last one you use. I think it will boot to the default if you are coming from the text login and fire startx.