Multiple DEs, but one [GNOME] is acting strangely.

As noted elsewhere, very recently i migrated my Tower to TW from a non-openSUSE distro. In May i had my first – thrilling – taste of oS TW via several VMs on my Tower [pre-migration], & then in Lappy [which i also back then changed to TW once i found how good it is].

In all of those, i installed only the KDE DE during the Ruby installer process *. Immediately prior to my recent Tower migration, i created one more new TW VM to test something else, & only then discovered that if i chose “Custom” rather than either “KDE” or “GNOME” for my DE then a terrific new range of options opened up to me. That was the first time i realised that in fact i could install multiple DEs; i simply was ignorant of that before. On that basis i installed Plasma [my default], Gnome, Xfce, Mate, & Enlightenment desktops… + was also able to fine-tune programs to be installed. How cool is this!!! [sorry, amateur geekette here, i get easily excited]. I thought that was so cool that when i soon after migrated my Tower for real to TW, i also installed multiple DEs via Ruby [but not Enlightenment; it freaked me out in the VM].

Today i was playing around with that VM in my Tower [ie, [i]not* Tower’s real TW itself] to learn just how dependent or independent each DE was from each other [so now i know; independent]. However, this experimentation with me logging out of one DE to then log into the next DE, & then ditto etc, uncovered or caused a problem. Each of Plasma, Xfce, Mate behaved perfectly. Initially also so did Gnome. However i noticed that in the DE selection list on the logon screen there was something i didn’t know of, “Gnome on Xorg”. Curious, i chose to log into that, but now wish i didn’t. Trying that option just once seems to have broken the “real” Gnome [still in the VM; all this is in the VM]. Now, all subsequent log-ins to “Gnome” produce not the normal Gnome DE, but in fact only that “stripped-down” Gnome on Xorg DE, which i dislike even more than the ordinary Gnome DE. I’ve also rebooted the VM but that did not help. I have not yet tried this experiment in Tower’s real TW.

Any ideas pls on:

  1. How can i fix this so that picking the “Gnome” option at login actually gives the real Gnome DE [like it did the first time]?
  2. Why did this occur ?

It’s the same GNOME, but can use either Xorg or Wayland… so it’s not showing in the dropdown list of your login manager?

I really wish i could paste pictures here, it would be so much better than just using words.

Here is the full list from the VM’s login screen:

  • Enlightenment
  • GNOME on Xorg
  • IceWM
  • KDE Plasma Workspace
  • MATE
  • Plasma 5
  • Xfce Session

Are you suggesting that the situation now is that inadvertently i somehow have got GNOME stuck on using Wayland instead of Xorg? Can i fix that? I think i’m misunderstanding you, as this problem only begun after i used the GNOME on Xorg login choice, From that point on, regardless of if i login to that VM as GNOME on Xorg, or GNOME, the subsequent desktop is not the normal GNOME one – eg, the desktop icons do not respond, & no wallpaper shows.

Probably tied in with MATE tweaks… hard to say. Normally if something like this happens, create a (or maybe three, user_gx, user_gw, user_m) test user and login as that user with the DE that isn’t working to see if it’s in your ~/ or something system wide.

You can, using . On the right top there’s an Image option. Click that, copy the link. I will test now if this also works as a picture URL. If it does, I’ll edit the post on how I did it.

Don’t even have to edit, I immediately see the picture.

  • Right click on the uploaded image
  • Pick ‘copy image url’
  • click the “Insert Image” icon in the editor, and paste the image URL.

Rebooting will probably fix it.

I’m noticing that if I run Gnome on Wayland, and then login to KDE, I get a broken KDE session.

What’s happening, is that on logout not all processes are killed. And if some of the running processes are using Wayland, that interferes with a login using Xorg.

When I notice that, I usually logout, and go to a terminal session (CTRL-ALT-F1) to login. Then I kill all of my processes

ps -fu $USER

except the ones for the current login. The process start time helps recognize which are for the current login.

I then logout and use CTRL-ALT-F7 to get back to a desktop login.

It’s probably a bug, but I have not reported it.

To clarify this part: Wayland is default for GNOME on Tumblweed since GNOME 3.22. Xorg is just there as an alternative if you prefer to use it instead.

Well thank you… & i shall try that after this initial reply, which is… this is the reason i wrote what i wrote. It’s down the bottom of every oS Forum page i use & til now i’d taken it at face value without specifically testing it]:

Posting Permissions
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
code is On
HTML code is Off
Forum Rules

Thank you.

Fraid not… from paragraph 3 of my post 1 in this thread:

I’ve also rebooted the VM but that did not help.

Eek, that’s unpleasant! Given that [1] my original “thinking” [sic] during installation was that i’d install these various other [non-Plasma5] DEs with Ruby “just because i can, & OMZ this is so cool” [ie, i have no actual use-case for them at all], & [2] now having read your info, & [3] knowing that my memory is such that if that broken-KDE session were to arise in future for me that i’d be highly unlikely to be able to recall your command, i now think [4] the safest thing for me to do is use YaST to remove the GNOME pattern [not just in that VM, but specifically also in my [i]real TW]. I read elsewhere [an older thread] that apparently the GNOME pgms will still be retained, only the DE will go, & i’m ok with that. Essentially, if this bug exists, i don’t trust my capability to rescue myself, so proactive avoidance now though cowardly is likely prudent for me.

Thanks. Teehee, this is slightly embarrassing, but at least i’ve now learned something else new.

The problem has now gone, & maybe it wasn’t really a problem?]. Inspired by your suggestion i created one additional user, then logged into the GNOME DE with that. It was visually “normal GNOME”, not the one i was previously describing as “stripped down”. This indicated the root cause might have been local to my other user account. Before logging out again, i briefly made some “trivial” cosmetic adjustments as i’d done before. Doing this revealed the “problem”. No other desktop wallpaper choice did this, but the one i’d randomly picked that other day/night in my other user account, when applied here, instantly created the same strange effect. The “culprit” is “Green Laguna”. It confounds me how i’d not noticed this before, but anyway, now i noticed the effect immediately, & changing to pretty much any other wallpaper * made it all look normal again. That said, irrespective of wallpaper, none of the desktop icons function still.

I logged out, logged back in as my normal user, changed the wallpaper from “Green Laguna”, & lo, normality resumed. Sigh.

I apologise for wasting everyone’s time. :shame:*

Oh wow, thank you, now that explains rather a *lot!! *

Gosh, it seems my ignorance knows no bounds. :shame:

So, here’s my image pasting experiment:

Well, that’s not good, no image . Presumably this proves that per my earlier reply, i do not have the rights to post images. :’(

Well, yet another misunderstanding on my part. To test this idea i cloned that VM, then in the clone [logged in to its Plasma 5 Workspace] i launched YaST & marked the GNOME pattern to Remove, then Accepted. Sure, afterwards, the mark had gone, but after rebooting the login screen continues to offer GNOME & GNOME on Xorg as options… & the GNOME one still seems to work as normal judging by me still being able to log into it. So then [back in the VM’s Plasma5], i tried marking some of the more “significant looking” GNOME packages in that Pattern… but YaST was unhappy with this & gave me grave warnings.

I’m beginning now to suspect that having made the original decision to include this DE during installation, i simply need to accept that it’s permanent, but just not use it again. I mean, obviously in the VM none of this really matters, but that was just a guinea pig for my real TW… certainly i’m not interested in having to do another reinstallation just to eliminate it.

Well, rebooting also works. And that’s easy enough to remember.

Oh, i see. I had wrongly interpreted your earlier post as implying that KDE became permanently broken, unless “rebuilt” by those commands. Now that i see you only meant temporarily for that current session, then good, that’s fine, much less dramatic than i thought you’d meant.

And yes, i suspect that with practice & dedication, one day i might even manage to remember about the Big Red Button. :stuck_out_tongue:

I’m still interested in understanding my situation with pasting images in my future posts. As you saw, my Forum pages, at bottom of each page, tell me that:

  • You may not
    post attachments> i assume images are counted as attachments.

I read the FAQ:

Images and attachments

The best way to use images and attachments in your post is to use an external hosting site and point to your content via URL in your post. A good option is to use

That makes no mention of there being any restriction on newer [or any] users, yet MY forum pages continue to tell me i can’t attach. As i showed yesterday, my attempt to use failed … there were no error messages, just simply that no image appeared in my post after following the method. Actually, that FAQ does not indicate that images can be directly attached, only linked via url. Yet, we do have this Insert Image icon in the toolbar, & ***Knurpht ***showed that he is able to directly insert images that way.

Just now, in this post, i tried using my Imgur account [works fine in other fora of mine] here. I chose an image of mine from there, copied its url to clipboard., positioned my cursor in this draft post text field at the desired insertion point, clicked the Insert Image icon above this text input field, pasted in the url, clicked OK… & just like with, nothing happened.

Am i permanently blocked from inserting images, or after i’ve been here longer & made more posts, do i cross some permissions-threshold after which i am allowed? Or, do i already have permission but am doing something hopelessly wrong?

If you manually type in I M G ] the url / I M G ] but NO spaces for IMG (else it would think my test is an image) so it’s not an attachment…

Actual URL is

PS, these sorts of thing need to be asked in the forum help area :wink:

Oh, i asked in the wrong place - i’m sorry.