Multimedia trashed...again

24 hours ago kaffeine, vlc, smplayer and mplayer were all functional. Now after a software update only smplayer is functional. Kaffeine has been my favorite player since version 0.97 but recently only vlc would play all formats of videos so I got used to it. All packages have been installed from packman. Kaffeine now crashes with…

socket(): Address family not supported by protocol
ion@apollo:~> 1 errors in postprocess string “hb:a,vb:a,dr:a”
[mpeg4 @ 0x874d700] Invalid and inefficient vfw-avi packed B frames detected
KCrash: Application ‘kaffeine-xbu’ crashing…
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/ion/.kde4/socket-apollo/kdeinit4__0
abort: audio_alsa_out.c:853: ao_alsa_write: Aborting.
Unable to start Dr. Konqi

…vlc plays sound but no video…

VLC media player 1.1.9 The Luggage (revision exported)
Blocked: call to unsetenv(“DBUS_ACTIVATION_ADDRESS”)
Blocked: call to unsetenv(“DBUS_ACTIVATION_BUS_TYPE”)
[0x80503fc] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
Blocked: call to setlocale(6, “”)
Blocked: call to setlocale(6, “”)
Blocked: call to putenv(“LANGUAGE=”)
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
[0x81da71c] signals interface error: signal 17 overriden (0xb2a84790)
[0x81da71c] signals interface error: /usr/lib/libQtCore.so.4(?)(nil)]
[0x8410c4c] oss audio output error: cannot open audio device (/dev/dsp)
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
[0x8410c4c] jack audio output error: failed to connect to JACK server
socket(): Address family not supported by protocol
[0x81da71c] signals interface error: signal 17 overriden (0xb2a84790)
[0x81da71c] signals interface error: /usr/lib/libQtCore.so.4(?)(nil)]
[0x81da71c] signals interface error: signal 17 overriden (0xb2a84790)
[0x81da71c] signals interface error: /usr/lib/libQtCore.so.4(?)(nil)]

…and mplayer crashes as well with a report that’s too long to post. Well I can live without mplayer.

What am I doing wrong. Accepting updates perhaps?

None of those issues here
Fully updated kde4.6

ionmich, the package mplayer has a new fork called mplayer2 and a file that allows the use of mplayer2 as mplayer. I have switched to mplayer2 with no ill effects though I did read were oldcpu was sticking with the older program. I would also say that I have stuck with pulseaudio and have not changed it from the default. I have a bash script that might be helpful in trying to setup all of your multimedia properly called mmcheck. You can find the most recent version here in message #75:

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf - Page 8

It is worth a try. I also use Kaffeine though I actually use the KDE3 version you can also get from Packman and I even get the default Kaffeine from Packman. I have noticed a few changes lately like mplayer2, but so far, everything is still working. Why not check out your setup with mmcheck and tell us what you found.

Thank You,

On 05/30/2011 10:06 PM, ionmich wrote:
>
> What am I doing wrong. Accepting updates perhaps?

maybe! tell you what i do and do not:

-do not allow package kit to install anything, instead i use it to
signal me that something is waiting for update

-when signaled, i do open YaST Online Update and look at what is
offered and decide if i want that right now, or not…

like today, i see there is an update for libmodplug0, a “library based
on the ModPlug sound engine”… ah sound, and there is a guy in the
forms who had his sound system trashed by a recent update…

so, i mark the libmodplug0 update as “taboo” and let it wait for another
few days…maybe there will be lots of folks with trashed sound, maybe
not…if not then in a few weeks i’ll allow the upgrade to take place…

imo, it is necessary for the system administrator to be involved in
decision making…if Windows folks are happy with allowing Redmond to
push changes to their machines without ever looking to see what is going
on…that is fine with me…but, that does not mean that i have to so
trust someone else that i can’t take responsibility for my own
machine…at least that is how i see it: updates are offered not
mandatory.

ymmv


dd CAVEAT: http://is.gd/bpoMD
[NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

Your vlc is showing an error related to audio (oss, jack … ) so you probably should check its audio output mode.

Your konqueror is also showing an error related to audio.

Were you by chance tuning your alsa configuration ? Were you tuning your audio in YaST or in your Desktop configuration ? What was in the update you did ?

You can check your update content by running:


rpm -qa --last | less

which will give you a chronological listing of the last rpms you installed.

Also, what is useful in such cases is to give us the version of the applications you have installed. ie: output of:


rpm -qa '*xine*' '*vlc*' '*kaffeine*' '*layer*'

For example on my openSUSE-11.3 desktop where this all runs fine, I get:


oldcpu@core-i7:~> rpm -qa '*xine*' '*vlc*' '*kaffeine*' '*layer*'                                                                            
RealPlayer-11.0.2.2315-20101117.i586                                                                                                         
dragonplayer-4.4.4-1.4.x86_64                                                                                                                
kdebase4-runtime-xine-4.4.4-3.1.2.x86_64                                                                                                     
libxine1-1.1.19-2.pm.46.1.x86_64                                                                                                             
flash-player-10.3.181.14-0.2.1.i586                                                                                                          
pullin-flash-player-11.3.1-2.1.1.x86_64                                                                                                      
kaffeine-1.2.2-1.pm.1.3.x86_64
vlc-noX-1.1.9-4.pm.11.1.x86_64
libvlc5-1.1.9-4.pm.11.1.x86_64
kde3-kaffeine-0.8.8-50.pm.50.25.x86_64
xine-ui-0.99.6-1.pm.2.3.x86_64
phonon-backend-vlc-0.3.1-1.pm.2.1.x86_64
libxine1-gnome-vfs-1.1.19-2.pm.46.1.x86_64
smplayer-0.6.9+r3599-1.pm.3.3.x86_64
kde3-kaffeine-lang-0.8.8-50.pm.50.25.noarch
vlc-1.1.9-4.pm.11.1.x86_64
phonon-backend-xine-4.4.2-1.6.x86_64
libxine1-codecs-1.1.19-2.pm.46.1.x86_64
mplayerplug-in-3.55+cvs20100124-0.pm.3.6.x86_64
libxine1-pulse-1.1.19-2.pm.46.1.x86_64
kaffeine-lang-1.2.2-1.pm.1.3.noarch
vlc-qt-1.1.9-4.pm.11.1.x86_64
libvlccore4-1.1.9-4.pm.11.1.x86_64
xinetd-2.3.14-149.1.x86_64
gmplayer-1.0rc4_r33321-1.pm.1.8.x86_64
xine-skins-1.0.3-2.pm.2.1.noarch
MPlayer-1.0rc4_r33321-1.pm.1.8.x86_64

Cutting edge KDE updates are known to cause problems at times. What is in your repositories ? What is output of:


zypper lr -d

I know this is not helpful, but when I don’t have problems (with my conservative update and repository policy) and others do have problems, I can’t help but think that a blind package update whenever there is something new available is a really bad policy.

Many thanks for the assistance. I have used mmcheck before. Very user-friendly. Ran mmcheck again. Some gstreamer packages were missing, and I installed them. Ran into a problem…

Unsatisfied dependencies for gstreamer-0_10-plugins-bad-0.10.22-1.pm.119.4.i586:
libmjpegutils-1.9.so.0 is needed by gstreamer-0_10-plugins-bad-0.10.22-1.pm.119.4.i586
libmplex2-1.9.so.0 is needed by gstreamer-0_10-plugins-bad-0.10.22-1.pm.119.4.i586

but decided not to install the recommended work-around as it switched packages from packman to suse. Perhaps you might advise otherwise. I then tested with two problematic videos that used to play before. No change. One is an avi, the other is an flv.

I haven’t tried mplayer2 yet as it is my least preferred choice.

I had deleted kpackagekit, but I am taking your advice to heart, will re-install it and follow your instructions.

Thanks.

Tried to update my packman [essential] packages today on a standard 64bit installation, had that same issue and also decided not to update.

Strange, because vlc plays the sound track of the video, but not the picture.

Only to the extent of using alsamixer to set input microphone levels. This is a recent (10 days ago) installation (11.4 32bit KDE) and for the first time I did not have to disable or delete pulse audio for proper audio results.

Also, what is useful in such cases is to give us the version of the applications you have installed. ie: output of:


rpm -qa '*xine*' '*vlc*' '*kaffeine*' '*layer*'

~> rpm -qa ‘xine’ ‘vlc’ ‘kaffeine’ ‘layer
xinetd-2.3.14-152.1.i586
gecko-mediaplayer-1.0.0-1.pm.1.4.i586
kaffeine-1.2.2-1.pm.1.3.i586
kaffeine-lang-1.2.2-1.pm.1.3.noarch
libxine1-1.1.19-2.pm.46.1.i586
vlc-qt-1.1.9-4.pm.11.1.i586
phonon-backend-vlc-0.3.2-1.pm.2.6.i586
flash-player-10.3.181.14-0.2.1.i586
phonon-backend-xine-4.4.4-3.1.i586
smplayer-0.6.9+r3599-1.pm.3.1.i586
libxine1-pulse-1.1.19-2.pm.46.1.i586
libvlccore4-1.1.9-4.pm.11.1.i586
gmplayer-1.0rc4_r33321-1.pm.1.3.i586
libxine1-gnome-vfs-1.1.19-2.pm.46.1.i586
kdebase4-runtime-xine-4.6.0-4.9.1.i586
gnome-mplayer-1.0.2-1.pm.1.3.i586
libvlc5-1.1.9-4.pm.11.1.i586
vlc-1.1.9-4.pm.11.1.i586
pullin-flash-player-11.4.1-0.3.1.i586
vlc-noX-1.1.9-4.pm.11.1.i586
MPlayer-1.0rc4_r33321-1.pm.1.3.i586
xine-ui-0.99.6-1.pm.2.3.i586
gnome-mplayer-lang-1.0.2-1.pm.1.3.noarch
libxine1-codecs-1.1.19-2.pm.46.1.i586

zypper lr -d



1 | Packman Repository | Packman Repository | No | No | 99 | rpm-md | Index of /pub/mirrors/packman/suse/openSUSE_11.4/ |
2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
3 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/openSUSE_11.4 |
4 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
5 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss

Only four enabled repositories.

Thanks for the help and advice. If all else fails I still have a functioning smplayer. (Fingers crossed). |

??

Did you mention that in a previous post? My obviously incorrect assumption had been that NOTHING played. That is the sort of detail that is INCREDIBLY important to put in one’s first post.

The error messages indicate hiccups with audio, so if you provide no further information, what is one to assume when trying to help ?? < arrrgggggg > !

Note I note that I have (on openSUSE-11.3):
phonon-backend-vlc-0.3.1-1.pm.2.1.x86_64
phonon-backend-xine-4.4.2-1.6.x86_64
MPlayer-1.0rc4_r33321-1.pm.1.8.x86_64

vs your (on openSUSE-11.4):

phonon-backend-vlc-0.3.2-1.pm.2.6.i586
phonon-backend-xine-4.4.4-3.1.i586
MPlayer-1.0rc4_r33321-1.pm.1.3.i586

My guess is the problem you have encountered is likely a configuration problem.

You likely need to tell us what configuration you have setup for the output video mode in xine (which you note does not work), in vlc (which you note does not work), and in smplayer (which you say works).

And also provide more detail as to exactly what video codecs you tried to play. Note ‘avi’ is NOT a codec.

Yes I did. Please read my very first posting again. I quote from it…

…vlc plays sound but no video…

VLC media player 1.1.9 The Luggage (revision exported)
Blocked: call to unsetenv(“DBUS_ACTIVATION_ADDRESS”)
Blocked: call to unsetenv(“DBUS_ACTIVATION_BUS_TYPE”)
[0x80503fc] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
Blocked: call to setlocale(6, “”)
Blocked: call to setlocale(6, “”)
Blocked: call to putenv(“LANGUAGE=”)
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
[0x81da71c] signals interface error: signal 17 overriden (0xb2a84790)
[0x81da71c] signals interface error: /usr/lib/libQtCore.so.4(?)(nil)]
[0x8410c4c] oss audio output error: cannot open audio device (/dev/dsp)
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
[0x8410c4c] jack audio output error: failed to connect to JACK server
socket(): Address family not supported by protocol
[0x81da71c] signals interface error: signal 17 overriden (0xb2a84790)
[0x81da71c] signals interface error: /usr/lib/libQtCore.so.4(?)(nil)]
[0x81da71c] signals interface error: signal 17 overriden (0xb2a84790)
[0x81da71c] signals interface error: /usr/lib/libQtCore.so.4(?)(nil)]

I will take your advice concerning…

My guess is the problem you have encountered is likely a configuration problem.

Please do not concern yourself any further with this problem. As I said smplayer still works. I am sure you have many other more pressing problems to help with. I appreciate your assistance. IF I solve anything, I will post the solution for the benefit of anyone else.

Thanks again.

Thanks!

I missed that.

'Fraid I went off on a slight tangent then in terms of my recommendations …

In the case of video not playing, try with and without special desktop effects. Also go to the video modes of VLC and xine and try different output video modes (xvideo/xv, x11, … ) and see if any of those might help.

There is another thread going on wrt mplayer not playing video for some users where smplayer does work (this was for flv and mp4 video codecs).

There are many apps that can tell one what the video codec of a multimedia file is … for example ‘mediainfo’ which is on packman site.

ionmich, I see that several messages have went by since we spoke last. Let me tell you how I would switch to the gstreamer packages in Packman. First, I go to YaST / Software / Software Repository and select the Packman repositories and I elevate their priority (make lower) so they literally float to the top of the update pile. Then, I go into YaST / Software / Software Management and search on gstreamer. I then select each and every program, starting at the top of the list and work down the list while looking at the Versions Tab. For each application that can be obtained from Packman, it should be the very top bullet. If the top bullet for Packman is not selected, then select it and keep doing this until you have looked at all gstreamer applications and if a Packman selection exists, then it is selected. Most often, this will eliminate any conflicts by making sure all apps that can be obtained from Packman will be. Let me know if you have ever tried this method before and if it might work for you.

Thank You,

Yes, I have used this method before, but just to make sure I did it again. All gstreamer packages are from packman.

Yes, I have used this method before, but just to make sure I did it again. All gstreamer packages are from packman.
In reference to mplayer. What have you decided to do? That is, have you switched to using mplayer2 and to use mplayer2 as mplayer (the second option will remove the orginal mplayer file)? It is my suggestion to make such a change to see if it might be helpful.

Thank You,

ionmich it is my understanding that smplayer works, but vlc and xine do not. I don’t recall if you mentioned ‘mplayer’ by itself working.

In this thread Often recurring error in SMPlayer/ MPlayer I noted that the following works fine for me for mplayer (where it does not work without) … ie for mp4:

mplayer somefile.mp4 -vo xv 

or

mplayer somefile.mp4 -vo x11 

and the following for flv:

mplayer somefile.flv -vo xv 

or

mplayer somefile.flv -vo x11 

Again, if you could advise what codec the video files have that give you this problem, it might help to figure why xine and vlc are not working for you. As noted above, the program mediainfo, packaged by the Packman packagers will provide the codec of a file with a simple


mediainfo somefile.extension

My continuing frustration impedes rapid progress on this issue. I am several hours behind in applying suggestions. Nevertheless in response to…

…I investigated my vlc configuration and in Tools>Preferences>Video>Output I changed the setting from “Default” to “Simple DirectMedia Layer video output”. Vlc started working again. I have never fiddled with this setting since installing 11.4 on this computer almost two weeks ago.

Xine and Mplayer are next on the list.

Well done in getting this to work.

Its difficult for one in a thread like this to guess why the ‘default’ output video mode stopped working in VLC. If you are curious as to what applications you installed recently (so as to be able to point a finger to when this may have stopped working (assuming it was working before)) then a command to try is:


rpm -qa --last | less

and that will give you a scrollable list of all rpms installed on your PC in chronological order.

I tried your suggestion “mplayer somefile.flv -vo xv” and sure enough mplayer started to work again. So it looks like the “Default” video output in my system is at fault as vlc responded to a change as indicated in my previous post.

How do I view and change the “Default” video output system-wide? I tried looking in System Settings>Hardware>Multimedia.

I installed mediainfo and will use it to report on xine problems later, as it is still not playing video.

On a slightly different note, I re-installed Kpackagekit and it immediately notified me of many (some 30) updates available for a number of video related applications. Strange, as I have been checking and double-checking latest updates available in Yast on an almost hourly basis. Can I assume that if they are from packman I should go ahead and update?

Thanks for the hand-holding on this issue.

The mplayer configuration file for a local user is under /home/username/.mplayer/config and gui.conf . But having typed that, I do not know the exact syntax as to how to change the default so at present I can’t provide the answer to your question. Sorry.

I also can’t help here, as I don’t use Kpackagekit.

I would be leery also of Kpackagekit, as perhaps it is telling you of different application versions that would end up rolling back to the crippled SuSE-GmbH packaged versions? … In truth : I don’t know.