Multimedia problems with Suse 11.1 64 bit

Hi, my first post here as I’m a total Suse Newbie.

Been running Red Hat and friends for years, but I’m just trying to feel my way though this one.

I have bought a nice new Lenovo N500 and installed 64 bit Suse 11.1 that went on with no issues at all, really slick install, everything was detected and worked first attempt. But I cant seem to get firefox to handle any multimedia stuff, can’t play U-Tube Vids, BBC iplayer etc just dont work…

Have tried installing a few different versions of the realplayer codecs including the 64 bit ones suggested:

Re: [opensuse] [SOLVED] openSUSE 64-bit and realplay?

I tried putting the codecs into /usr/lib/codec and the mozilla plugins to /usr/lib/browser-plugins/. But no go.

Have followed instructions here:

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Though admittedly have not tried a DVD out yet just the web streaming as I’m at work.

Any suggestions how to sort multimedia via firefox? Do I just ditch the 64 but and go 32.

Would like to stay with Suse as first I’m pretty impressed with it so far.

Here is the output of firefox’s about:plugins :-

Shockwave Flash

File name: npwrapper.libflashplayer.so
Shockwave Flash 10.0 r15

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes
OpenSC Signer plugin

File name: opensc-signer.so
This plugins handles web signatures using OpenSC smart card library.

MIME Type Description Suffixes Enabled
text/x-text-to-sign Text to be signed sgn Yes
GCJ Web Browser Plugin (using IcedTea) 1.3

File name: gcjwebplugin.so
The GCJ Web Browser Plugin (using IcedTea) executes Java applets.

MIME Type Description Suffixes Enabled
application/x-java-vm IcedTea class,jar Yes
application/x-java-applet IcedTea class,jar Yes
application/x-java-applet;version=1.1 IcedTea class,jar Yes
application/x-java-applet;version=1.1.1 IcedTea class,jar Yes
application/x-java-applet;version=1.1.2 IcedTea class,jar Yes
application/x-java-applet;version=1.1.3 IcedTea class,jar Yes
application/x-java-applet;version=1.2 IcedTea class,jar Yes
application/x-java-applet;version=1.2.1 IcedTea class,jar Yes
application/x-java-applet;version=1.2.2 IcedTea class,jar Yes
application/x-java-applet;version=1.3 IcedTea class,jar Yes
application/x-java-applet;version=1.3.1 IcedTea class,jar Yes
application/x-java-applet;version=1.4 IcedTea class,jar Yes
application/x-java-applet;version=1.4.1 IcedTea class,jar Yes
application/x-java-applet;version=1.4.2 IcedTea class,jar Yes
application/x-java-applet;version=1.5 IcedTea class,jar Yes
application/x-java-applet;version=1.6 IcedTea class,jar Yes
application/x-java-applet;jpi-version=1.6.0_00 IcedTea class,jar Yes
application/x-java-bean IcedTea class,jar Yes
application/x-java-bean;version=1.1 IcedTea class,jar Yes
application/x-java-bean;version=1.1.1 IcedTea class,jar Yes
application/x-java-bean;version=1.1.2 IcedTea class,jar Yes
application/x-java-bean;version=1.1.3 IcedTea class,jar Yes
application/x-java-bean;version=1.2 IcedTea class,jar Yes
application/x-java-bean;version=1.2.1 IcedTea class,jar Yes
application/x-java-bean;version=1.2.2 IcedTea class,jar Yes
application/x-java-bean;version=1.3 IcedTea class,jar Yes
application/x-java-bean;version=1.3.1 IcedTea class,jar Yes
application/x-java-bean;version=1.4 IcedTea class,jar Yes
application/x-java-bean;version=1.4.1 IcedTea class,jar Yes
application/x-java-bean;version=1.4.2 IcedTea class,jar Yes
application/x-java-bean;version=1.5 IcedTea class,jar Yes
application/x-java-bean;version=1.6 IcedTea class,jar Yes
application/x-java-bean;jpi-version=1.6.0_00 IcedTea class,jar Yes
Totem Web Browser Plugin 2.24.2

File name: libtotem-basic-plugin.so
The Totem 2.24.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/x-ogg Ogg multimedia file ogg Yes
application/ogg Ogg multimedia file ogg Yes
audio/ogg Ogg Audio oga Yes
audio/x-ogg Ogg Audio ogg Yes
video/ogg Ogg Video ogv Yes
video/x-ogg Ogg Video ogg Yes
application/annodex application/annodex type anx Yes
audio/annodex audio/annodex type axa Yes
video/annodex video/annodex type axv Yes
video/mpeg MPEG video mpg, mpeg, mpe Yes
audio/wav WAV audio wav Yes
audio/x-wav WAV audio wav Yes
audio/mpeg MP3 audio mp3 Yes
application/x-nsv-vp3-mp3 NullSoft video nsv Yes
video/flv Flash video flv Yes
application/x-totem-plugin Totem Multimedia plugin Yes
VLC Multimedia Plugin (compatible Totem 2.24.2)

File name: libtotem-cone-plugin.so
The Totem 2.24.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/x-vlc-plugin VLC Multimedia Plugin Yes
application/vlc VLC Multimedia Plugin Yes
video/x-google-vlc-plugin VLC Multimedia Plugin Yes
Windows Media Player Plug-in 10 (compatible; Totem)

File name: libtotem-gmp-plugin.so
The Totem 2.24.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/x-mplayer2 AVI video avi, wma, wmv Yes
video/x-ms-asf-plugin ASF video asf, wmv Yes
video/x-msvideo AVI video asf, wmv Yes
video/x-ms-asf ASF video asf Yes
video/x-ms-wmv Windows Media video wmv Yes
video/x-wmv Windows Media video wmv Yes
video/x-ms-wvx Windows Media video wmv Yes
video/x-ms-wm Windows Media video wmv Yes
video/x-ms-wmp Windows Media video wmv Yes
application/x-ms-wms Windows Media video wms Yes
application/x-ms-wmp Windows Media video wmp Yes
application/asx Microsoft ASX playlist asx Yes
audio/x-ms-wma Windows Media audio wma Yes
DivX® Web Player

File name: libtotem-mully-plugin.so
DivX Web Player version 1.4.0.233

MIME Type Description Suffixes Enabled
video/divx AVI video divx Yes
QuickTime Plug-in 7.2.0

File name: libtotem-narrowspace-plugin.so
The Totem 2.24.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
video/quicktime QuickTime video mov Yes
video/mp4 MPEG-4 video mp4 Yes
image/x-macpaint MacPaint Bitmap image pntg Yes
image/x-quicktime Macintosh Quickdraw/PICT drawing pict, pict1, pict2 Yes
video/x-m4v MPEG-4 video m4v Yes
NPAPI Plugins Wrapper 1.0.0

File name: npwrapper.so
nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.
This software is available under the terms of the GNU General Public License.

MIME Type Description Suffixes Enabled
unknown/mime-type Do not open none Yes

There should be a package available through Yast’s Software Management called mplayer-plugin (or something along those lines I’m unable to check the exact name at the moment but searching on ‘mplayer’ should bring it up in the list).

After I install that I usually don’t have trouble with video or audio in firefox.

I recommend ditching the nspluginwrapper and installing the alpha 64 bit flash player (it works quite well considering it’s an alpha) confirm You got all gstreamer installed (good, bad, ugly, extra).

http://labs.adobe.com/downloads/flashplayer10.html

Here is the file , put it in /usr/lib64/browser-plugins, uninstall nspluginwrapper.

On 64 bit plugins go to /usr/lib64/browser-plugins. You put it in /usr/lib/ maybe if You have 32-bit web browser installed.

I recommend the approach suggested by yu210148.

The way in which I propose you do that (assuming your PC has internet access) is to add just 4 repositories to your software package manager: OSS, Non-OSS, Update and Packman. Just those 4. No others. None. You can add others ONLY after you understand the risks, and know how to fix dependency problems when they occur. There is guidance for adding these 4 repositories here: Repositories/11.1 - openSUSE-Community Again, just OSS, Non-OSS, Update and Packman. Do not add videolan as its many of its packaged codecs and apps are not compatible with packman players.

Now, with those 4 added, please go to YaST > Software > Software Management and change the filter to search and then add the packman packaged smplayer, mplayerplug-in

One possible area of complication is you are using a 64-bit SuSE-11.1 and you need to be mindful of your firefox version (64-bit) and your smplayer/mplayerplug-in versions. (ie you must be consistent wrt 32-bit and 64-bit apps). I don’t have a 64-bit PC, so I can not provide ‘words of wisdom’ there.

Other great multimedia applications to consider adding are the Packman packaged versions (not the Novell versions) of amarok, libxine1, xine-ui, amarok-xine, vlc, libffmpeg0 (to pick up various codec dependencies) , w32codec-all, xvidcore, libquicktime.

A good site to learn what packman packagers have to offer for openSUSE multimedia is here: http://packman.links2linux.de/ Pay close attention to the search engine tab and also the packages tab.

Hi,

Thanks for all your help. I have been following oldcpu and yu210148’s instructions and things are much better now. Media support is quite good.

Now, with those 4 added, please go to YaST > Software > Software Management and change the filter to search and then add the packman packaged smplayer, mplayerplug-in

This has solved all the video streaming issues. One remaining issue is playing the radio streams from the BBC Website.

In firefox the npwrapper plugin was dected fine and seemed to want to work when trying to listen live on the BBC Site but just was not able. I have installed the new Alpha flash player as BenderBendingRodriguez suggested, but this was not detected by firefox even after copying the library libflashplayer.so to the /usr/lib64/browser-plugins directory and removing the npwrapper.* files/links, this is where all the other plugins are.

I did not uninstall the old nslibflashplayer package as at the time I could not identify which RPM was responsible for installing it. I did not think that this would make a difference anyway.

Any suggestions on this one? One thing I have considered is uninstalling firefox 86_64 and going with the 32 bit version, or just installing 32 bit. Would like to get this last bit working 64 bit though.

Right then, I have managed to get a few hours to sit down and go thought this. All problems solved.

Above instructions worked really well the Alpha release libflashplayer.so plays BBC radio streams fine when you uninstall the npwrapper package.

DVD media playing required me to download the libdvdcss package from VLC and installed it with yast on the command line (I didn’t configure the repo, just wget the file). I also installed libdvdread 3 & 4, these with the packages listed in oldcpu’s instructions saw everything working for DVD and Vids via web browser. I did need to go in and enable groups “disk” and “cdrom” for my user account as well.

MP3 support came in when I installed:

ffmpeg
gst-fluendo-mp3
gstreamer-0_10-ffmpeg
gstreamer-0_10-plugins-bad
gstreamer-0_10-plugins-good
gstreamer-0_10-plugins-ugly

Then I can rip with Sound Juicer and play with Amarok etc, all good.

So thats pretty much full multimedia support on Suse 11.1 64 bit.

And for anyone who is interested this is on a Lenovo 3000 N500 Pentium Dual Core T3200 2GHz, Type 4233-23G. If your thinking about getting one do it. Its a good machine.

Everything else is working as well 3D graphics support, sound, Wlan with WPA2-PSK, mouse is working nicely, even the Functions keys are working (all but the brightness one so far).

I’m a happy bunny. Just a shame that I this was bought for the in laws and I have to hand it over and go back to my IBM T40…

Still thanks for all your help, great forum and for my first experience with Suse, what a great O/S everything works nicely and seems rock solid.

I know whats going on the T40 now Fedora 8 is out of support. See you around the forum.:slight_smile:

Did you test the webcam and modem? They’re listed a non-functional on the HCL (second last row in the table)

Did test the camera and yes it works fine, HCL updated. Have not tested the dial up though.

I have been following this thread,and thanks to Oldcpu, I now have sound.( see my other posts ) However, I am still having a major problem. That is all players will start briefly and play, but after a second or two they shut down. Any ideas?:\

Kenny1948, please start a new thread re: your problem … In the meantime, you could also check out this URL/guide from RedDwarf:
Check your multimedia problem in ten steps - openSUSE Forums