Multimedia Guide for openSUSE Tumbleweed

**openSUSE Tumbleweed Multimedia Guide
**
[size=4](this is a copy for the Leap 42.3 Guide by caf4926 with some new Additions).
[/size]

**Revised and Simplified manual Method****This assumes you already have the default repositories.
**

NOTE You need to become su - in a terminal
Become super user in a terminal (su -). Learn how here

STEP 1: Add Packman and libdvdcss repositories

zypper ar -f http://packman.inode.at/suse/openSUSE_Tumbleweed/ packman
zypper ar -f http://opensuse-guide.org/repo/openSUSE_Tumbleweed/ libdvdcss

Now do

zypper ref

(a) to accept always and trust the signing key

FOR GENERAL USE:

zypper install -f libxine2-codecs ffmpeg-3  dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-base  gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs vlc-codec-gstreamer ogmtools libavcodec58

If you face choices. Look carefully for the option to let the package/s switch from openSUSE > packman

When done. Close the terminal. And open Yast > Software Management and Apply the Package Switcher on Packman.

KDE: http://paste.opensuse.org/92222495
Gnome: http://paste.opensuse.org/71856337

If you encounter dependency errors: You need to accept changes that allow vendor switch to Packman If you can’t work it out. Ask in the forum.

IMPORTANT NOTES:**

  1. This multi-media install should provide the basics for all desktop environments.

  2. Please do not use the VideoLan repository!

  3. OneClick options will be available here: Restricted formats - openSUSE Community Wiki

**

I tried to follow the instruction, but I’m getting

Problem: libva.so.1()(64bit) benötigt von libxine2-codecs-1.2.8-127.7.x86_64 wird nirgends zur Verfügung gestellt

means: we need libva.so.1 but no one is providing it.

Any ideas?

Thanks

Eric

I think it’s better you open a new thread. This is just the tutorial. Installed Tumbleweed on a machine yesterday and didn’t have the problem. When do you get this error? When playing a DVD or when installing the codecs?

Hi, it doesn’t seem so removed, you suggest a zypper install command for the following packages “flash-player / flash-player-ppapi”, or did I misunderstand something?
Many thanks :)****
**

**

@ **deano_ferrari

**Thank you very much it worked without any trouble

Peace](https://forums.opensuse.org/member.php/122-deano_ferrari)