Multiboot USB cannot start new ISO (Failed to mount ISO storage)

I have USB sticks more than 8GB. So I don’t want to waste storage, so I created MULTIBOOT USB.
The ony way I managed to do that is using terminal (using NTFS as filesystem).
Here is what I did:
https://lizards.opensuse.org/2015/05/30/create-multi-liveusb-with-opensuse/

My menuentry is:

*menuentry ‘openSUSE Tumbleweed GNOME Live x86_64′ {*
*set isofile=’/iso/openSUSE-Tumbleweed-GNOME-Live-x86_64.iso’*
*loopback loop $isofile*
*linux (loop)/boot/x86_64/loader/linux isofrom_device=$imgdevpath isofrom_system=$isofile LANG=en_US.UTF-8*
*initrd (loop)/boot/x86_64/loader/initrd*
*}*

It worked before 10/10/2016 Tumbleweed version.
Now, I get the net screen (right after [sdb] Attached SCSI removable disk)

Image

Failed to mount ISO storage.

Is there a solution to that?

Hi!

I checked that at least within ‘openSUSE-Tumbleweed-DVD-x86_64-Current.iso’ as of 2016-10-17 the paths are still the same as in your GRUB menuentry you gave above.
That these paths have changed could have been one possible reason.

I noticed that in the description in
https://lizards.opensuse.org/2015/05/30/create-multi-liveusb-with-opensuse/
that you cited a “vfat” filesystem is created on the stick, while in your
Image
there is the error message "unknown filesystem type ‘ntfs’ ".
Did you change the filesystem on your USB stick/key?

Finally, is your USB stick/key still healthy?
I already encountered the failure of one after I used it daily for some time.

Mike

Here what’s happened.
I used to have a vfat USB. Then I turned it to ext4 and tried with NTFS. It worked fine for all distros, even with openSUSE.
The reason I used NTFS because I wanted to add Hirens ISO (it requires fat or ntfs). NTFS because I wanted to add Leap’s DVD too.
Well, my 32GB USB worked fine until the last upgrade of Tumbleweed ISOs.

Regarding the solution. My USB was healthy beause I tested the same configuration (NTFS) to both 32GB and 8GB (32GB is the new one). Since you said that the filesystem is the problem, there was time to test both with ext4 and fat32 (I’ll use Leap’s net install ISO). First try with ext4, it opened fine. Now I download KDE’s ISO to test that as well (I’ll reply if everything is OK and I’ll close this post).

Thank you for your help.

Both GNOME and KDE worked fine.
Thanks

Sometimes it just helps to talk about things …:wink: