Multiboot opensuse and windows 7 with windows bootloader.

I boot with the Windows boot loader. It works fine. You are doing it wrongly, as others have tried to explain.

Do you know how to edit boot.ini?
The win7 is installed in sda3 (C drive in windows). So how to make the boot.ini to load suse.bin?

I was a bit surprised of your mention of “boot.ini”. Vista and Windows 7 changed to a new boot system. You are supposed to use the Windows command “BCDEDIT” to change the boot configuration of Windows. And, in my experience, you will get errors running BCDEDIT unless you have already made Windows your active partition.

When I have to use BCDEDIT (I do it as rarely as possible), I first right click on the COMMAND PROMPT item and select “Run as Administrator”. I then use “BCDEDIT /?” to get command help.

If you google for “BCDEDIT linux” (without the quotes), that will find a number of online guides to using BCDEDIT to setup the Windows boot manager to handle linux.

In your initial post, you said you did “dd if=/dev/sda8 of=/mnt/windows/suse.bin bs=512 count=1”

I can’t be sure (not enough information), but you probably needed instead:


dd if=/dev/sda4 of=/mnt/windows/suse.bin bs=512 count=1

That’s right. I didn’t mention that possibility because I haven’t seen Grub in sda4, I just assumed it was there since it had to be somewhere and it couldn’t be anywhere else. That’s why I told you to install Grub in Linux root partition. As I already said, you can have Grub stage1 installed in several bootsectors. You can then dd either sda4 or sda9 bootsector to file. They will both use the same stage2 and display the same menu (the one located in /boot/grub/menu.lst on sda9).

You were right; though the cfdisk had shown sda9 has boot flag, fdisk -l showed star on sda4.

After installing stage1 on sda9, both the grub (stage 1 & 2) are now in sda9.
find using find /boot/grub/stage2, find /boot/grub/stage1.
so I copy it to C drive.

Actually no need of that, even though win7 don’t use boot.ini by default, it will read it if we create it manually (I read that in some link, and it works in my case).

It’s Done. :slight_smile:
Now I can boot it from windows boot loader.

Thank you all for helping me.

Great. I’m glad you have it working.