Multi-user login

Leap 15.2 KDE.

I will need to share my laptop with 2 other people.

How do I configure the greeter to ask for both username & password for login?

I do not want to show any of the usernames (though the drop down). I need to have an empty box: username and another empty box for the password.

Thank you

It already does, unless you use autologin.

I do not want to show any of the usernames (though the drop down). I need to have an empty box: username and another empty box for the password.

I think that depends on the SDDM theme.

System Settings –> Startup and Shutdown –> Login Screen (SDDM).

I think the “Maldives” theme or the “Elarun” theme will do what you want.

It may also depend on the DM used. Some of them show lists of users they think should be able to login. Some show last user loged in as default. Not all have configurations to change that behaviour. I do not know all the details of all the DMs, but I explicit changed to kdm to be able to configure to my needs (one of them: no list whatsoever shown).

If sddm if used, which I think is the default, create a file (as root) under /etc/sddm.conf.d/, e.g. /etc/sddm.conf.d/00-users, with the following contents:

[Users]
MinimumUid=60000
RememberLastUser=false

For more info: man sddm.conf

Yes, that probably works. And it shows that this product can only be configured to such an imho very normal wish with a dirty trick. List all users wth a UID > 60000 lol!

I can assure you: it does work. I just changed my 00-users file. :nerd: In fact, I always had MinimumUid=500 in my 00-users file, because I still use the same uid that was the default for the first user many many years ago: 501. That was a surprise when sddm became the latest fashion.

And why I now said MinimumUid=60000? Because the default MaximumUid is 60000.

I too was a bit surprised that you have to resort to some kind of trick to not show the users. Although there is a HideUsers= setting that takes a comma-separated list of users that shouldn’t show up in the user list. Default is empty and wildcards do not work. HideUsers=* or even HideUsers=ALL would have been too easy. :wink:

Yes, you are right. I guess there were more objections from me against SDDM, I use kdm now for a number of years already (even many years when you reckon it was the default earlier) and it works fine for me.

And about the “normal” users starting at 500, I just changed that a year or so ago to 1000. Not that it bothered me much, but only to go with the flow :wink:

Thank you. I didn’t know about that

What you also did not know, but perhaps do know by now, is that these login screens are quite horrible (IMNSHO) on anything else than a tablet. That’s because they present a virtual keyboard on the screen, which keeps on coming back.

So, just create file [FONT=monospace]/etc/sddm.conf.d/00-users as suggested earlier and your’re done. If you already changed the login screen, remove file [/FONT][FONT=monospace][FONT=monospace][FONT=monospace][FONT=monospace]/etc/sddm.conf.d/[/FONT]kde_settings.conf that was created because of that.

In that respect a better name for my file would be zz-users or something like that, to make sure it is read last, overriding any settings of other files in the /etc/sddm.conf.d directory (I have not verified that to work though).[/FONT][/FONT][/FONT]

I actually experimented with the “Elarun” them and the “Maldives” theme, and I did not get a virtual keyboard. Something else (not the theme) must be controlling that.

OK. Interesting to know.

That’s because they present a virtual keyboard on the screen, which keeps on coming back.

If you do not need it, remove it:

zypper rm libqt5-qtvirtualkeyboard