Multi Media issues in 12.1

Okay. I’ve been working on this for two days now. I’ve followed all the instructions as best I can. I’ve tried different approaches (one click). I’ve installed and ran mmcheck. Media is working - kinda. At the moment, Totem plays DVDs. VLC plays them badly (sound cuts out, choppy video).

I’d like to have it all working smoothly, however my main concern is recording video with Cheese or another recorder (had one and un-installed it during a fix-it session and can’t remember at the moment what it’s called). Cheese works but audio is now choppy. To top it all off I’d like to install Skype. I consider that lastly.

Basically I need assistance diagnosing the issues. I think I can provide answers to the questions I need to be asking myself but don’t know where to start at this point. Hopefully I can get this resolved and it will help somebody else having similar issues. I suspect 12.1 is not ironed out completely on all systems.

openSUSE 12.1
Intel Pentium 4 CPU 2.20GHz
nVidia GeForce GT 430
MemTotal: 2061820 kB
Logitech, Inc. Webcam Pro 9000
Iomega Corp. HDD/1394A
Midiman M-Audio Producer Mic

This is the latest clue I have when trying Software Update…

To be clear, I’m not looking for easy answers or somebody to hold my hand. Not that that’s a bad thing. I’m trying to understand concepts, like why different repos need to be used and which ones can’t be mixed and which ones can and why. I’ll keep on tinkering until somebody chimes in here.

Here’s the idea: the distro comes as a stable pack of packages. These can partly be obtained by downloading a CD/DVD image, but not all packages will fit on the media, so some are in the distribution repos.Then there are the parts of the distro that have their own development, like Apache, KDE, GNOME and so on, they have their own repositories, to be used if one finds reasons to install other versions than the distro’s stable release. Then there are bits and pieces of software that may not be freely distributed in all countries. For legal reasons, they are maintained by the Packman packagers.

Now, all these packages have their dependecies, i.e. they need specific versions of other packages to be installed. In practice, this can result in situations like this: pkgA has an updated version in repoA, needing a newer version of libA from repoA. pkgB is installed and requires the libA version from repoB. Result: a conflct, which, when ignored, can result in failures of pkgB. In the past I’ve seen trouble where people had a mix of KDE 4.3 and 4.4 libraries and software, resulting in a constantly crashing desktop, due to a forced install. These dependencies, btw they exist in any linux distro,. make sure that anything a software program or library needs is available on the system, in the version that it needs. If you mix up that structure there’s likely going to fail something.

I hop this explains it globally.

Now to your point mentioned in the first post, please post output of

zypper lr -d

On Skype: it’s avaiable, but IMHO it would be good to get your multimedia working properly first. On Search Results enter “skype” as a searchphrase, click the search options, and include the user homedirs. That’s where devs can put their packages in their own repos. This is the repo I installed Skype from: Index of /repositories/home:/Lord_LT/openSUSE_12.1 You can add the URL as a repo.

On 12/07/2011 10:56 PM, KEB64 wrote:
> I’ll keep on tinkering until somebody chimes in here.

i can’t answer any of your questions…but, i can make a couple of

recognize that there really are not a huge number of volunteer users
here with the expertise you need (i wouldn’t begin to be able to
help)…and, maybe the one helper that can help you is now in the
middle of her normal night’s sleep, or . . .

and, maybe all of those who did stop in already (i see 30 views as i
type) looked at your problems and decided they couldn’t help (for any of
several reasons–like, maybe their VLC is kinda broken also [by the way
VLC is all i use because it does everything GREAT, here…but, may
never work good on your machine, so]…but, none of those stopped long
enough to ask you to be patient…until the helper who can help you
drives by… we here are all other users helping…no one is getting
paid and some take a month off and never drop in. so…

by the way, as you hunt for the answer you are probably get further and
further away from the default setup, and by now it may be such a rats
nest of switch settings and . . .

openSUSE®, the “German Engineered Automobiles” of operating systems!

@Denver. I totally hear ya. I hope my posts don’t come off as otherwise. I guess I was really needing a response and I got one, you! That’s all it really takes sometimes to keep us all going sometimes. Just a “hey, I personally can’t help much - but ‘bump’ maybe somebody will chime in here”. Thank you.


kirk@linux-jft8:~> zypper lr -d
# | Alias               | Name                       | Enabled | Refresh | Priority | Type   | URI                                                             | Service
1 | |        | Yes     | Yes     |   99     | rpm-md |                        |        
2 | libdvdcss           | libdvdcss                  | Yes     | Yes     |   99     | rpm-md |                            |        
3 | packman             | packman                    | Yes     | Yes     |   99     | rpm-md |                     |        
4 | repo-debug          | openSUSE-12.1-Debug        | No      | Yes     |   99     | NONE   |  |        
5 | repo-debug-update   | openSUSE-12.1-Update-Debug | No      | Yes     |   99     | NONE   |                 |        
6 | repo-non-oss        | openSUSE-12.1-Non-Oss      | Yes     | Yes     |   99     | yast2  |    |        
7 | repo-oss            | openSUSE-12.1-Oss          | Yes     | Yes     |   99     | yast2  |        |        
8 | repo-source         | openSUSE-12.1-Source       | No      | Yes     |   99     | NONE   | |        
9 | repo-update         | openSUSE-12.1-Update       | Yes     | Yes     |   99     | rpm-md |   

These are the repos I have currently.

Thanks for going to the trouble of giving that explanation. My text in bold - quoted text from

Is this okay?

  1. Show the libdvd* Packages are Installed for DVD Movies …

Command: rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ ‘libdvd -> PackMan :: Startseite
libdvdread4-4.1.3-20.1.2-i586 -> openSUSE
libdvdplay0-1.0.1-2.4-i586 -> PackMan :: Startseite
libdvdnav4-4.1.3-16.1.2-i586 -> openSUSE

You should expect to have 4 libdvd* packages installed, 1 from Packman.
----------------> libdvdplay0 <-------------from the Packman Repository.
----------------> libdvdread4 <----------- from the openSUSE Repository.
----------------> libdvdnav4 <------------ from the openSUSE Repository.
----------------> libdvdcss? <------------ from the VideoLAN Repository.

Press <enter> to continue…

…and why do I need KDE apps? I’m not running KDE, only Gnome.

  1. Show if ffmpeg/lame/libmad0/k3b/sox Packages are Installed from Packman

Command: rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ ffmpeg lame libmad0 k3b k3b-codecs k3b-lang sox

sox-14.3.2-33.1-i586 -> PackMan :: Startseite
lame-3.98.4-7.1-i586 -> PackMan :: Startseite
k3b-codecs-2.0.2-13.6-i586 -> PackMan :: Startseite
ffmpeg-0.8.7-1.1-i586 -> PackMan :: Startseite
k3b-lang-2.0.2-13.6-noarch -> PackMan :: Startseite
k3b-2.0.2-13.6-i586 -> PackMan :: Startseite
libmad0-0.15.1b-2.5-i586 -> PackMan :: Startseite

You should expect to show seven Packages Installed here from Packman.
called ---------> k3b-lang <------------ from the Packman Repository.
called ---------> libmad0 <------------- from the Packman Repository.
called ---------> k3b <----------------- from the Packman Repository.
called ---------> k3b-codecs <---------- from the Packman Repository.
called ---------> lame <---------------- from the Packman Repository.
called ---------> ffmpeg <-------------- from the Packman Repository.
called ---------> sox <----------------- from the Packman Repository.

Press <enter> to continue…

…and this is what I did so I could update that one gstreamer file mentioned in the screenshot above. I changed it to the openSUSE repo.

  1. Show if gstreamer Plugins/Codecs Packages are Installed from Packman …

Command: rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ ‘gstreamer*’

gstreamer-0_10-ffmpeg-0.10.11-1000.4-i586 -> PackMan :: Startseite
gstreamer-0_10-fluendo-mp3-12-8.1-i586 -> openSUSE
gstreamer-0_10-fluendo-mpegdemux-0.10.57-43.6-i586 -> PackMan :: Startseite
gstreamer-0_10-fluendo-mpegmux-0.10.4-44.4-i586 -> PackMan :: Startseite
gstreamer-0_10-plugins-bad-0.10.22-138.20-i586 -> PackMan :: Startseite
gstreamer-0_10-plugins-base-0.10.35-62.1-i586 -> PackMan :: Startseite
gstreamer-0_10-plugins-good-0.10.30-63.2-i586 -> PackMan :: Startseite
gstreamer-0_10-plugins-good-extra-0.10.30-63.2-i586 -> PackMan :: Startseite
gstreamer-0_10-plugins-ugly-0.10.18-33.2-i586 -> PackMan :: Startseite

You should expect to have all 9 gstreamer packages installed from Packman.

Press <enter> to continue…

…and why isn’t VLC working correctly? I have all the right packages from the right sources. lol. As you can see, I have alot of questions and I’m not sure where to start.

  1. Show if vlc Packages are Installed & from Packman …

Command: rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ vlc vlc-mozillaplugin libvlc5 libvlccore4

libvlc5-1.1.12-11.4-i586 -> PackMan :: Startseite
vlc-1.1.12-11.4-i586 -> PackMan :: Startseite
libvlccore4-1.1.12-11.4-i586 -> PackMan :: Startseite
vlc-mozillaplugin-1.1.12-11.4-i586 -> PackMan :: Startseite

You should expect to show four Packages Installed here from Packman.
called ---------> vlc <---------------- from the Packman Repository.
called ---------> vlc-mozillaplugin <—from the Packman Repository.
called ---------> libvlccore4 <-------- from the Packman Repository.
called ---------> libvlc5 <------------ from the Packman Repository.

Press <enter> to continue…

Maybe the questions I should be asking is if I uninstall VLC (since it’s not working right) and the KDE media burner, will everything that works now still work? I did have VLC working fine at one point, then I had issues with Totem. So, I dunno. Can’t i just have it all?

I guess in the end I want total control over my system and as much understanding. That’s not too much to ask, right?

Okay, I have my VLC working now. I installed “VLC Audio Out for Pulse Audio”. That’s the upside. The downside is it wrecked my Totem Player audio output. It’s back to a fragmented shuddering thing. It can’t be that I can only have one or the other, can it?

To avoid package problems, the most important thing to do is to: NEVER
ignore a dependency, even if YaST/zypper/updater gives you such an option!
In general, never switch to an >inferior< architecture and the solution is
most often to just switch Vendor to the >Packman< repository. So changing
the vendor is OK, but >ignoring< dependencies is never a very good idea!

I must quote the final screen of mmcheck above as to package and repository switching. I suggest you switch everything you see to Packman if the package exists in Packman. I do not normally suggest you in mass switch to everything Packman as it could cause unforeseen problems. However, when you can not update one application without another complaining, check the complaining application on the versions tab and most often you find a version of it from Packman which you should use. As for k3b, the openSUSE default is for KDE. You can forgo using or installing k3b and its support files if you have another alternative you wish to use. One final question, what video driver are you using? As I see you have an nVIDIA card, switching to the nVIDIA proprietary video driver can often fix choppy video problems. Check out my two blogs on the subject here:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.20 - Blogs - openSUSE Forums

Thank You,

Thanks jdmcdaniel3. I removed k3b. I’m using the nVidia driver. It’s been working fine. Screen looks nice. 3D stuff works. Sometimes I wonder why movies and video can’t use more of the card instead of the CPU, but I’ll investigate all that later down the road.

In terms of the shuddering, it’s confined to audio playback in Totem. It’s kinda like an interference. I play the same captured video in other players and it’s fine. So more investigating to do there.

The only reason I backed out the Packman gstreamer-0_10-fluendo-mp3 file is openSUSE had an update for it. I’m not sure how this impacts the system. I have the same behavior with or without it.

oh and in reply to the mmcheck quote, this means everything is okay right?

  1. Check for any Missing Dependencies for ALL Installed Packages …

Long Pauses in this Test Normally means a Repository is Responding Very Slowly …

Before Checking Your Repositories, would you like to perform a Zypper Refresh
right now? This permission will also allow you to fix any issues that are
displayed when your repo’s statuses are displayed. (Y or y=Yes, Default is No)

Please enter your choice now [y/N] y

Command: sudo zypper refresh

root’s password:
Repository ‘’ is up to date.
Repository ‘libdvdcss’ is up to date.
Retrieving repository ‘packman’ metadata [done]
Building repository ‘packman’ cache [done]
Repository ‘openSUSE-12.1-Non-Oss’ is up to date.
Repository ‘openSUSE-12.1-Oss’ is up to date.
Repository ‘openSUSE-12.1-Update’ is up to date.
All repositories have been refreshed.

Command: sudo LC_ALL=C zypper ve

Loading repository data…
Reading installed packages…

Dependencies of all installed packages are satisfied.

Would you like to see a complete installed program listing? A=Alpha, L=Last Installed, Q=Quit.

Use Q=Quit & H=Help while in Less. Please enter your choice now [a/l/q]: