mulltiple linux file permissions

I have 3 linux partitions on my main computer, openSUSE11.1, 11.0 and Fedora 7. I have the same user name on all partitions, ie. ken. However I cannot copy files as a ken from /home/ken on one partition to another partition on another because the file permissions are wrong. I realize that the actual file ownerships are based on numbers rather than names and I have tried making the UID’s in passwd the same on all partitions, i.e. ken is 1000 on openSUSE11.1, 11.0 and Fedora7. I have repeatedly chown -R ken * and .* the files in the home directories, however I still am unable to copy files from one home/ken directory to another. What else do i need to do?

Can you copy back here a half a dozen lines from this command:

ls -l /path_to/directory

when /path_to/directory is aimed at the three different partitions. Plus tell us which example is from which distro.

I solved the problem. FIRST NEVER EDIT /etc/passwd file. Use usermod -u UIDnumber username to make all the UID’s of a given user the same. Second, I had to relabel the files on the Fedora7 partition with touch /.autorelabel. Then I booted into the Fedora7 partition several times. The first few times it complained about gnome errors, ect. But it cleared up eventually.

kendall green schrieb:
> Second, I had to relabel the files on the Fedora7 partition with touch
> /.autorelabel.

Ah, so SELINUX is involved on the Fedora side.
That tends to complicate things a bit.

Tilman Schmidt
Phoenix Software GmbH
Bonn, Germany