MSI Wind - Webcam not working

I just installed openSUSE 11.2 on my MSI Wind U100. For the most part, everything worked out of the box, though I had a small scare as the DVD installer did not recognize either my wireless or ethernet cards; the installed system works with both, however.

But as the title suggests, I am having trouble with the webcam. I have the Bison model, described on the wiki here.

Following the instructions on the linked wiki page, I added “options uvcvideo quirks=2” to /etc/modprobe.conf.local.

Before rebooting, I tried out the camera by pressing Fn-F6, then launching Cheese. It worked perfectly, actually a lot clearer than ever before.

After rebooting, however, things changed.Now, when I ‘enable’ the webcam with Fn-F6, it is not recognized in Cheese (my preferred webcam app), and I get the following output from dmesg:

  827.697116] atkbd.c: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
  827.697215] atkbd.c: Use 'setkeycodes e06e <keycode>' to make it known.
  827.700794] atkbd.c: Unknown key released (translated set 2, code 0xee on isa0060/serio0).
  827.700890] atkbd.c: Use 'setkeycodes e06e <keycode>' to make it known.

Neither Cheese nor lsusb recognize the camera. On top of that, after pressing Fn-F6, all my usb ports and the card reader no longer function. It’s like the entire USB system has died. I reboot brings everything back again, except the camera.

I tried removing the line I had added from modprobe.conf.local, but after a reboot the camera is still not recognized. I wish I had left well enough alone, but I was trying to follow the instructions…

Anyone know what’s going wrong? FYI, this is the exact same behavior I had on Ubuntu 9.10.

I am experiencing the same behavior. I never edited modprobe.conf.local though and pressing fn-f6 seems to have disabled my usb functionality entirely.

It seems the act of pressing fn-f6 is what stops all USB functionality. The instructions on the wiki work to make the webcam usable.

I thing there is a problem with usb. On my Wind the camera (not Bison - the other) work sometimes BUT only if I start the system with an USB device plugged-in (usb pen, an other camera).

Additionally I have problems with recognizing USB devices witch was not plugged-in during booting the system.

Is there any chance that there will be a fix for this issue in the near future? OpenSuSE is otherwise an outstanding OS, it feels snappier and more stable than all the other big-name distributions.

There are people working on it.