.msi in Linux/ wine?

Trying to install a .msi (only installable avail) in Suse 11.0.

msiexec /i TapeTrack.msi

err:msi:copy_package_to_temp failed to copy package L"TapeTrack.msi"
fixme:msi:MSI_OpenDatabaseW open failed r = 80030002 for L"TapeTrack.msi"

Can anyone help?

Tried just the following and got;

msiexec TapeTrack.msi

wine: created the configuration directory ‘/root/.wine’
Could not load Mozilla. HTML rendering will be disabled.
wine: configuration in ‘/root/.wine’ has been updated.
Install a product:
msiexec {package|productcode} [property]
msiexec /i {package|productcode} [property]
msiexec /a package [property]
Repair an installation:
msiexec /f[p|o|e|d|c|a|u|m|s|v] {package|productcode}
Uninstall a product:
msiexec /x {package|productcode} [property]
Advertise a product:
msiexec /j[u|m] package [/t transform] [/g languageid]
msiexec {u|m} package [/t transform] [/g languageid]
Apply a patch:
msiexec /p patchpackage [property]
msiexec /p patchpackage /a package [property]
Modifiers for above operations:
msiexec /l[li][i|w|e|a|r|u|c|m|o|p|v|][+|!] logfile
[/li] msiexec /q{|n|b|r|f|n+|b+|b-}
Register a module:
msiexec /y module
Unregister a module:
msiexec /z module
Display usage and copyright:
msiexec {/h|/?}
NOTE: Product code on commandline unimplemented as of yet

Copyright 2004 Vincent Béron

I think the problem here is that you are logged in as root which you should NEVER do.
Log back in as a normal user and try again.
Also there seems to be a native Linux version have a read here


Worked. Thanks. Can anyone explain to me why it worked with reduced permissions but would not with SU?

It’s part of keeping wine apps safe. If they were run as root could potentially be prone to malware