mplayer2 now in Packman

I see there is a new packaged version of MPlayer on Packman called “mplayer2”.

I’ve been incredibly busy at work and home, and have something like over 1000 emails from a couple mailing lists (packman, evergreen) and I’m trying to catch up. I did stumble across this item in the mailing list:

Subject: [packman] Packaging request: Mplayer2
Date: 03/17/2011 01:29 AM

I was advised to submit a request for someone to package something here. Please could somebody package Mplayer2 and upload it to the Packman repos?

The url is mplayer2 project

Mplayer2 is a fork of Mplayer with bug fixes and better multithreaded support. It acts as a drop in replacement for Mplayer so all the frontends should work, I’ve got it working with gnome-mplayer running out of the build directory.

Please CC me if you reply to this message as I’m not subscribed to the list.

Thanks in advance,

Have any of our users tried MPlayer2 and have any comments on its functionality wrt MPlayer ?

here’s the delta between the 2 projects mplayer2 differences from mplayer

be more interesting is ffmpeg-mt was packed with it

update - changed executable in sMplayer to mplayer2 and dvd and avi files did not play of course ymmv

update2 - running in command line got the following error :
MPlayer interrupted by signal 4 in module: unknown

  • MPlayer crashed by an ‘Illegal Instruction’.
    It usually happens when you run it on a CPU different than the one it was
    compiled/optimized for.
    Verify this!
  • MPlayer crashed by bad usage of CPU/FPU/RAM.

Thats interesting.

I use mencoder a fair amount so clearly MPlayer2 is not for me, as I note this:

Dropped features

MEncoder is no longer available

The MEncoder codebase was thoroughly rotten and has been deleted. A different solution to provide some encoding functionality will be added in a future version.
Internal GUI has been removed

The bad internal GUI (gmplayer) has been deleted. Future work will concentrate on improving the interface for external GUI implementations instead.

They may be right that the mencoder codebase is lacking, but never the less it is used by many projects. To not have mencoder is BLOCKING item for me, and hence I won’t run mplayer2.

I have this same problem with 11.4 x86_64. Maybe it is a 64-bit thing? It plays audio files fine, but video creates the correct sized window for a very brief moment and then gives the same crash as above.

can’t figure out how to edit a post. . .

Installing the binary from mplayer2 project worked just fine. I put it in /usr/local/bin and now I am going to forget about all this and watch a movie!

Can you please tell me step by step what you did ? Download which file exactly ?

I too want to try mplayer2.



Done !!!

Thanks for the awesome idea.