mplayer problem - hopefully trivial

I have what I hope is a very simple problem. I recently moved my main desktop OS from Windows 7 to openSUSE 13.1 with a WinXP VirtualBox. I had been running a Logitech c310 USB webcam in Windows. I was unable to get the device to work in my virtual Windows box, so I had to find a Linux solution to take periodic stills from the camera.

I found someone else with the same issue and copied/pasted his mplayer script:

/usr/bin/mplayer tv:// -frames 1 -tv fps=5:driver=v4l2:quality=90:width=640:height=480:device=/dev/video0 -vo jpeg

It’s working great except for a 30 or 40 minute window after sunrise and again before sunset when my webcam looks like this in cheese:

but is filled green in mplayer:

I assume that disabling whatever “feature” is doing this is possible with a switch, but I haven’t been able to find it. The number of RGB options in mplayer makes searching on “green” maddening.

If anyone has an answer or even a link to something more helpful than the man page, I would greatly appreciate it.

Thank you!

Are you saying that you are taking other stills but without that effect (green)?
That those other images display correctly?

In any case, I suppose a starting point is to identify the differences between any successful and unsuccessful images and verify whether the problem is the images or the viewer.

As a first analytical step, inspect and compare the image properties, my guess is mediainfo might return what you want


These green images are getting produced in low light situations (i.e. shortly after sunrise and before sunset). I’d rather just have an undoctored low light level image posted (like the still I took from Cheese).

The images that mplayer takes during the day look great.

I would guess then that the problem is more a camera setting rather than an mplayer setting.
Hopefully your camera software grants you access.
If not, you might try something like VLC… It has plenty of settings(unknown if any actually fixes your issue) and it can do your snapshots or video, too.


In my attempts to research vlc, I came across something called fswebcam. It does exactly what I need and doesn’t auto-fill green in low-light conditions. It’s as simple as:

fswebcam -r 1280x720 --jpeg 90 -d /dev/video0 current.jpg

Thanks for your help!