Mplayer not working in 11.2 RC2

I recently installed opensuse 11.2 RC2 and mplayer is not working. It worked fine in RC1. I get a fatal error that says:

Error opening/initializing the selected video_out(-vo) device.

I hope this gets fixed before final release.

Also when I try to install vuze bittorrent client, I get the following error:

nothing provides Vuze-libswt3-gtk2 needed by Vuze-

Does anyone know any work arounds? I hope the packman and vuze people can get this fixed before final release.

I think both things are caused by repo’s not being ready for 11.2 yet and if they excist some are not fully filled. I think loads of people are working hard to get all the packages ready for 11.2. Be patient. If you want a good working desktop stick with 11.1 for another few weeks.

try a different video output driver with -vo

mplayer -vo help to get available ones (I use xv)

Then report this bug to the people in charge instead of just “hoping” somebody else will do it for you.

Testing of pre-releaes versions is exactly what they are there for.

mplayer seems to be working fine here - 11.2 rc2 64 bit

I have a 32-bit openSUSE-11.2 RC2 KDE-4.3.1 installed from the DVD on my sandbox PC (a 32-bit athlon-1100 w/1GB ram and nVidia GeForce FX5200 with proprietary nVidia (beta - I think)). The packman packaged MPlayer plays video files fine on it (I use the ‘xv’ vo (video output) with it). The version I have installed is

I think you need to check your MPlayer configuration. Try installing smplayer, the front end to MPlayer, as that makes it easier to configure mplayer.

Search in Software management for: libswt3-gtk2

If you are installing Vuze from Packman it should just get dragged in. I’m using the Factory Packman, it is better ATM
Additional YaST Package Repositories - openSUSE

Thanks for all the info. I was able to install libswt3-gtk2 by searching in software management but vuze still says it needs “vuze-libswt3-gtk2”, which is not available in software management. I already reported this to the vuze people in RC1.

I’m using a 64-bit system and installed mplayer through the packman repository using yast. I tried the mplayer -vo help command, but don’t know enough to try to mess with it. I haven’t been able to find a way to contact the mplayer people without joining the mailing lists, but I may do so in order to report the bug.

As already pointed out by a few, this doesn’t look like a bug in mplayer but like a misconfiguration on your side

the -vo selects which output video driver to use. among the commonly used ones are xv, gl, gl2 and vdpau

try any of those and see if it’ll work. Also check your configuration in /home/username/.mplayer/config (if any) before reporting a “bug” which doesn’t look like one and wasting the packager’s time them trying to figure out

I installed the smplayer from the packman factory repo and it included mplayer in the installation. Seeing this post I tried to play it and throws the same error but changing the video to xv it went on to play. That said it’s just in the configuration.

This is the section they are on about](

Nice take caf. Good to show for information purposes.

OK, I installed smplayer and it works fine. The video output in smplayer is set to xv by default. However, I’m still getting the same -vo fatal error in original mplayer. I went into the mplayer config file (which was empty) and wrote:


but that didn’t help. I also tried setting vo to gl and gl2, but that also didn’t help. At this point it’s no big deal though since smplayer works fine.

Did you follow caf4926 screenshot?
just right click on the mplayer gui and click references-video and choose xv and apply. You have to exit mplayer and re run it before the new configuration will take effect.

You might actually find X11 works better. But trial and error.

you need a comma after xv, eg vo=xv, or else it won’t work

Enjoy your tiny fullscreen :stuck_out_tongue: