MPlayer: /dev/dvd Permission denied!


I just want to tell about my small adventure with mplayer. Maybe somebody will have the same issue.

I’ve installed mplayer. After that just tried to play DVD disk, but the following error appeared: No stream found to handle url dvd://1

After that I’ve googled a lot, but nothing help. Though, as was recommended in one post I launched mplayer in konsole to see the output.

$mplayer dvd://1 /dev/dvd

Playing dvd://1.

Couldn’t open DVD device: /dev/dvd (Permission denied)

No stream found to handle url dvd://1

Well… I couldn’t beleived that solution was so simple. But indeed allowing others except root to read file /dev/dvd solved the problem!

The only problem is I need to change it every time I reboot. Since I don’t think it’s correct behaviour… can anybody give me a hint why any other user cant read /dev/dvd ?!

(when I used 11.0 everything was ok, now I’m using 11.1)


Have you run updates for your system.

Lets see if you have updates enabled: From a terminal do:

zypper lr

post here

Of course…

test@hagen:~> zypper lr

| Alias | Name | Enabled | Refresh

1 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Yes | Yes
2 | Libdvdcss repository | Libdvdcss repository | No | Yes
3 | Packman Repository | Packman Repository | No | Yes
4 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No
5 | openSUSE-11.1-Non-Oss | openSUSE-11.1-Non-Oss | Yes | Yes
6 | openSUSE-11.1-Oss | openSUSE-11.1-Oss | Yes | Yes
7 | repo-debug | openSUSE-11.1-Debug | No | Yes
8 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
9 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
10 | repo-source | openSUSE-11.1-Source | No | Yes
11 | repo-update | openSUSE-11.1-Update | Yes | Yes

Have you run updates recently? Yor repo’s look fine except repo 2 should be No|No (once libdvddcss is installed it’s not needed)
Repo 3 should be Yes|Yes
adjust these then
from a su terminal do

zypper ref

zypper up

Yes, I’m updating my system daily. I just dont want Packman repo to be enabled. After I installed some packages from it my Amarok 2.0 (from oficial repo), which worked with mp3 out of the box couldn’t play it any more… after that expierince i’m trying not to use packman repo… but that’s not the question.

My question is why ordinary user cannot read /dev/dvd . It’s not so serious… but nevertheless.


any news on this? I’ve been noticing some fedora 8 users as well having this exact issue - and I just encountered this on a laptop as well.
no /dev/dvd or /dev/cdrom mappings just /dev/sr0.

mount output:

/dev/sda1 on / type ext3 (rw,acl,user_xattr)
/proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda3 on /home type ext3 (rw,acl,user_xattr)
/dev/sda4 on /srv type ext3 (rw,acl,user_xattr)
tmpfs on /dev/shm type tmpfs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
gvfs-fuse-daemon on /home//.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=)


hwinfo | grep “Device”

returns this: (among a lot of other things)

Device: “DVD-RW DVR-K16”
Device File: /dev/sr0 (/dev/sg1)
Device Files: /dev/sr0, /dev/scd0, /dev/disk/by-path/pci-0000:00:1f.2-scsi-1:0:1:0

still a little confused by what’s going on here, never had any issues with this laptop before 11.1 install…

still digging.

This is the correct usage

mplayer dvd://1 -dvd-device /dev/dvd

Hi, this might be a wild guess, but anyway check if the user has appropriate rights in yast. (audio,video,…)