Mplayer ao_alsa playback open error

runnning mplayer i get
ao_alsa playback open error device or resource error

i went here
said to uncheck kcontrol+desktop+behavior+file icon+sound file preview
well its already unchecked and i cant find any documentation on how to fix this error
sound and video work perfectly except for the error.

First check you have done multi-media like this, depending on your suse version?
Multi-media and Restricted Format Installation Guide - openSUSE Forums

im not getting the error anymore after i enabled compositing in xorg.conf. i didn’t do anything else but its working now. stumped.

im getting the same error again, it happened after i changed my plasma theme. music and videos play fine its just that error. if i play in a playlist, i get the error at the beginning of each song.

i fixed it for now.
im using mplayer, right click preferences+audio tab+configure alsa and oss to driver default and /etc/init.d/alsasound restart 'ed

also, i went to start+configure desktop+sound+audio output for music and preferred default over hw.