MPlayer and RealPlayer on KDE 4.1?

I’m trying to play a .ram file (it links to a RTSP:// feed), but it seems that Amarok can’t play it. It couldn’t earlier as well, but I remember using MPlayer for that and it worked nicely. However, now I can’t install MPlayer for some reason. It complains about having no installable providers. I have DirectFB 1.1 and don’t see how I could get the 1.2 version here… Any way to do that?

Of course, .ram files are meant to be played through RealPlayer. YaST shows me I have it installed - but how do I run it? There is no option in the main menu to start it… Tried running “rvplayer” through the console, it says that there is no such command…

Have you tried clicking on a file or right clicking and selecting Open with? If it is installed, it should show up in the right click menu when you click on a .ram file.

Yes, I tried. Strangely, it only lists KWrite, OpenOffice Writer and Helix player (which doesn’t support that kind of files).

If you have RealPlayer installed, try typing “realplay” in your terminal. That should launch it.

Hope that solves your problem!

Thanks! It worked!

Anyway, are there other players that can play MP3, OGG Vorbis and MIDI files?

Try xmms or its forks (Audacious, Beep) for the usual formats (.mp3 and .ogg should be played by pretty much any player as long as the respective codecs are installed) and Timidity for Midi. I could also provide a little script which converts Midi into .mp3 via Timidity and lame (just in case you’re interested).

That’s strange as Helix player is the community version of RealPlayer and is claimed to support RealPlayer files. However, as you have now found the answer, you can associate realplay with .ram files for the future.

If I can only get OGG and MP3 on a single player, then what about OGG on Amarok 2? Somehow it refuses to play OGGs (actually, it just ignores them). Maybe it has something to do with XINE not having some plugins? By the way, what’s the difference between xine-lib and libxine1?

John, it probably supports Real Player files (.RA), but not RealMedia Metafiles (.RAM). And yes, I assigned .RAM files to realplay now, should be enough. Somehow the KDE System Settings file associations don’t want to work for me. :\