mplayer amarok

I am going blind trying to read and make sense of all the information on the web regarding amarok and mp3 and wma files.

I tried one suggestion and installed mplayer and w32-codecs-all which is fine for mplayer but still no luck getting amarok to play mp3 or wma.

Video is fine since I am using VLC. VLC will also play mp3 and wma files but the playlist aspects are dismal. Amarok has one feature I love from XP WMP11 which is the ability to generate random playlists. In fact that is the main reason I want to get amarok working.

/usr/lib/codecs and /usr/lib/win32 now both have all the codecs (be nice to only need one or the other).

So… my question is:

A) How do I now get amarok to play my audio files or

B) is there anything available that will scan my music library and generate a random m3u playlist for VLC or

C) something or some way to get mplayer to read/generate random playlists?

Thanks in advance.

Install amarok from Packman

This is a one click for multimedia

If you have already istalled xine, just install amarok-xine from YaST and libxine1-w32dll. It’ll play for you mp3/wma files.

Okay, I uninstalled amarok and tried selecting packman in yast.

Got this…

YaST2 conflicts list - generated 2008-08-30 13:00:30 obsoletes xine-lib provided by xine-lib-1.1.12-8.1.i586

 ] replacement of xine-lib-1.1.12-8.1.i586 with
 ] Following actions will be done:

do not install
do not install

YaST2 conflicts list END

When I option to replace the i586 with i686 it just blinks and says the same thing.

I get the same message from yast when I try the amorak-xine package.

I have no idea what to do next.


Hi. I remember having some trouble with amarok while I was using 10.3 but it’s really simple to get it working now. Once you add packman repo, just remove all amarok and all xine packages (search for them in yast)
Then search for “amarok-xine”
Once you select it for download, it will select “amarok_lang” and “libxine1” as dependencies.
You should be able to play mp3 after that.
For videos I got smplayer and w32codec-all installed, it plays all the formats I need.

Thanks to all who responded.

Turns out it was a combination of bits of all answers that eventually got things going for me.

I am, as I type, listening to my wma tunes with amarok.

Thanks, again.