mpi.h: no such file or directory

After installing (with YAST) openmpi
i tried to compile with mpicc but got the error:
mpi.h: no such file or directory.

searching for this in google gives about 28k entries but noone helped.

Install openmpi-devel perhaps?

In general when developing programs with foo, you are likely to need the package foo-devel.

ok i did not do that, i will do now.
i will give the results

edit: thanks, installing the devel package solved the problem.
But why is not the devel package a dependency for the openmpi package then?

Am 21.11.2011 14:26, schrieb sabo007:
>
> After installing (with YAST) openmpi
> i tried to compile with mpicc but got the error:
> mpi.h: no such file or directory.
>
> searching for this in google gives about 28k entries but noone helped.
>
>
Install openmpi-devel in addition, the devel packages contain the header
files.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram