Mpg and Windows Media Problems

Since upgrading to Open SUSE 11 I have started to come across a number of problems, some with the help of this excellent forum and its expert users I have solved, however this one is driving me nuts.

I run Firefox 3, Gnome, Mplayer (including the Mozilla Plugin), SMPlayer.

Whenever I try to play an mpg or Windows media file on a web page it does one or other of the following

1.Loads the clip into Mplayer in Firefox and I get sound but no video
2.Downloads the clip to my desktop, but if I try to open it using MPlayer I get sound but no video but the following error message “Error opening/initializing the selected video_out (-vo)device
Yet if I open the clip on my desktop with SMPlayer I get sound and vision! BUT I have no right click access to SMPlayer.

You can add smpalyer to the right click option.

Get any .mpg file and right click - properties
click the config spanner icon
there is a list of media in there
click add - locate smplayer and add
you can move it up the list to default 1st.

don’t expect all sites to work with such media, they are often really only designed for windows.

there is plugin for ff, called mediaplayerconnectivity, some find it useful.

Hi caf4926
Thank you for your help what I find odd is that I have only had this problem since upgrading to SUSE 11, and its getting worse now if I download an MPG and try toplay it in SMPlayer all I see is a blue screen!

In a terminal as su type:
zypper lr
zypper se -r packman

and

zypper se -r vlc

post results here

@cat4926

here you go, thanks for your assistance

linux-axdx:/home/geoff # zypper lr

| Alias | Name | Enabled | Refresh

—±--------------------------------------------------------------------------------±----------------------------------------±--------±-------
1 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
2 | Index of /repositories/X11:/XGL/openSUSE_11.0 | openSUSE BuildService - X11:XGL | Yes | Yes
3 | repo-oss | openSUSE-11.0-Oss | Yes | No
4 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
5 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
6 | repo-debug | openSUSE-11.0-Debug | No | No
7 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes
8 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0 | openSUSE BuildService - OpenOffice.org | Yes | Yes
9 | http://www2.ati.com/suse/11.0 | ATI Repository | Yes | Yes
10 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
11 | Index of /download/repo/1.0/11.0 | openSUSE Education | Yes | Yes
12 | Index of /repositories/Emulators:/Wine/openSUSE_11.0 | openSUSE BuildService - Wine CVS Builds | Yes | Yes
13 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
14 | http://download.nvidia.com/opensuse/11.0 | NVIDIA Repository | No | Yes
15 | Index of /repositories/GNOME:/Community/openSUSE_11.0 | openSUSE BuildService - GNOME:Community | Yes | Yes
16 | Index of /repositories/games/openSUSE_11.0 | openSUSE BuildService - Games | Yes | Yes
linux-axdx:/home/geoff # zypper se -r packman
Repository ‘packman’ not found by its alias, number, or URI.
Use ‘zypper repos’ to get the list of defined repositories.
linux-axdx:/home/geoff # zypper se -r packman
Repository ‘packman’ not found by its alias, number, or URI.
Use ‘zypper repos’ to get the list of defined repositories.
linux-axdx:/home/geoff # zypper se -r vlc
Repository ‘vlc’ not found by its alias, number, or URI.
Use ‘zypper repos’ to get the list of defined repositories.
linux-axdx:/home/geoff #

Ok
Go to software management and filter by repo
you should only have libdvdcss installed from vlc - That’s it! If there are others, do this:

Disable VLC repo with the repo manager

Now go back to filter by repo and go to packman
update all in list unconditionally

If there are any dependency issues that you can’t work thru you might come back here. But change vendor requests to packman should be accepted.

I’ve also noticed two types of causes for this problem:
a. one is using an Intel graphic driver, or alternatively
b. one has special desktop effects enabled, which is bringing about this problem.

For case-b, if you have special desktop effects enabled, try either disabling the special effects, or try switching the output video mode of your player from “auto” (or from “xv” (xvideo)) to “x11” and see if that helps.

To see if case-b applies to you, type:grep -i driver /etc/X11/xorg.confwhich will list the drivers that your xorg.conf file is configured to have loaded

@ caf4926 & oldcpu
Sorry for the slow reply ( been at work!) I will give your ideas a go.
Thanks
Nitro