Mp3 Support?


I’ve installed openSUSE 11.1 and now I have a problem. the VLC mediaplayer can play .mp3 files without a problem but amarok 1.4 and amarok 2 can’t play them. I’ve applied the update from Multimedia - openSUSE-Community, but it won’t help.

What can I do?
I don’t have much experience with openSUSE, so please can you explain the solutions exactly.

PS: I use the newest KDE

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Check your multimedia problem in ten steps - openSUSE Forums

you should use vlc from Packman also amarok-packman and amarok-xine

caf4926 wrote:

> ‘Multi-media and Restricted Format Installation Guide - openSUSE Forums’
> (
Hello CAF4926,

I am following the above copied URL ‘Multi-media and Restricted Format
Installation Guide - openSUSE Forums’ for my openSUSE 11.1 / KDE 3.5.10
installation. I have completed the steps:
1 Basic Repositories
2 Additional repositories
3 In the step “Now we can move on to everything else” i have the following
I don’t know how to filter by Repository in yast/software /software
management and so go to the Packman repository I need to work from.
If I select in the Filter field - Repositories than 2 new fields,
respectively “Name” and “Sec Filter” field, appears under the Filter field.
but I cannot select in these field the required repository.

Regards / Groeten,

You can download this video from one of my blogs. I think it was done in 11.0 but it’s the same. It should show you how

OpenSUSE Help - Video Downloads - By carl4926

try checking the engine used by amarock. After following the community guide I had no sound in amarock (1.4) even though the process bar and equalizer appeared to be playing the mp3. I found a suggestion on one of the forums to change the “Configue-Amarock”>“Engine”> from yaup to Xine, and that fixed the problem for me.

Hello CAF4926,

Thanks for the video link. In the meantime I have tried the same thing on my other machine with openSUSE 11.0 and in there it worked the same as on that video. In openSUSE 11.1 on my netbook it does not work the same after entering as selection “Repositories”. The list with repositories from which you can select did not show up. So I have entered a bug report Bug 472992 - In yast-software-management, if filter is set to repositories no list with repositories is generated. See URL:

Regards, Frans

I have not come across this one before. Are you using kde or gnome?

A standard Gnome install cannot do this filtering.