mp3 player help

Hi All!! I have a samsung yp-u2jxb/xaa mp3 player and am trying to get it to work with opensuse 11.0 but am having much difficulties. For some reason its not showing up…I looked up the driver at samsung sight but it was only for windows xp. Does anyone know what I should do or know of a site that can help me get this thing working. I use it everyday and any help will be greatly appreciated.


If this is a Windows only MP3 player, then it won’t work. You can only get it to work with openSUSE if it can be made to look like a USB drive for the most part. For my Sansa, this meant changing the USB mode from MTP to MSC (Mass Storage Class) in the Setup options. I don’t know about this Samsung model. Unfortunately, it isn’t supported by Rockbox which is always the first thing I check these days with an MP3 player.

I have a sansa mp3 player, and if you go through the menus there is a way to change the way it presents itself over a USB port-- either as a generic USB storage device or as a special music device that can, I think, only be recognized by windows media player.

Maybe yours has a similar setting?

Did you have it working before (with 10.3), or is this the first time you’ve tried to use it with OpenSuSE?

I’m not sure whether this device uses the MTP protocol for connection, rather than UMS.

If it is an MTP device, I managed to get a Creative Zen (also MTP) working well with 10.3 by installing the various MTP packages (libmtp, libmtp6,libmtp7, libmtp-tools, mtpfs, mtpsync, qlix and Gnomad 2) using Yast.

Hope this helps.

Thanks all for the help! This is the first time Ive tried to get it to work…only with opensuse 11.0 . I will try all your suggestions on making this work and again thanks for the help!!

I suggest you start by installing Gnomad - that will install some of the other stuff automatically, then “fill in the gaps”.

I use Gnomad for most things (transferring music, etc) and Qlix for doing things manually. MTPSync (as its name suggests) synchronises your player with your PC.

Good luck!