Mozilla will not start

After installing MS4 when I try to start Firefox from an icon I just get a bouncing cursor. I tried removing it and re-installing with Yast but that did not help. I tried re-naming .mozilla to .mozilla.old but that did not help either. If I try to start it from a terminal I get:
/usr/bin/firefox: line 128: 20500 segmentation fault $MOZ_PROGRAM"$@".
I also tried installing Seamonky, with similar results, the message was now:
/usr/bin/seamonky: line 130:6808 segmentation fault $MOZ_PROGRAM"$@".

Has anyone any ideas to fix this?

Linux 2.6.33-6-desktop x86_64
openSUSE 11.3 Milestone 4 (x86_64)
4.4.1 (KDE 4.4.1) “release 2”

Sony VGN-FW11E laptop
Intel(R) Core™2 Duo CPU P8400 2.26GHz 3GB RAM
Mobility Radeon HD 3400 Series (M82) using radeonhd
Intel wireless WiFi Link 5100

Try adding the factory repo for mozilla

I have no issues here with M4 and mozilla or anything much at all for that matter.

add the oss and non-oss factory repos and update too

Many thanks for your reply. I tried updating from the factory repositories but I still get the same result.

I just installed MS4 on an old Asus M5200 laptop (32 bit) and Mozilla works fine there.

Maybe you should re-install

I’ve seen this happen before with Mozilla (and other GNOME-based apps) if for some reason the GNOME font settings don’t agree with the system (particularly when running in KDE as a base).

Try going into your control panel and changing your default fonts. Or you could try logging in as say root and testing from there - if that works (depending on which window manager you’re using) you could ocpy the window manager config files over from that account to your own.

I tried changeing the fonts and logging in as root, but no luck. I also tried re-installing, formatting both the root and home partitions, but still none of the mozilla applications will run.
I will wait for the next milestone before I try anything else.

I ran into the same problem after I installed moonlight
when I uninstalled the moonlight packages firefox was working again

Moonlight is not installed on this machine.

Sony VGN-FW11E laptop
Intel(R) Core™2 Duo CPU P8400 @ 2.26GHz 3GB RAM
Mobility Radeon HD 3400 Series (M82) using radeonhd

Try running firefox from a command line in konsole that might give you a hint.

Also if you have the factory repo active you might want to do an update. That is factory not 11.3 repo

or wait until milestone 5 which is due next Friday.

On 29/03/10 18:56, caf4926 wrote:
> Maybe you should re-install

And, if my experience is anything to go by, on another partition! I had
the same problem when I installed MS4 on one machine but after three or
four goes it finally worked. On another machine, it would not work at
all. I tried from the command line and got the following message:

/usr/bin/firefox: line 128: 7580 Segmentation fault $MOZ_PROGRAM “$@”

I also tried Thunderbird:

/usr/bin/thunderbird: line 130: 12680 Segmentation fault

I re-installed on a different partition and had no problems.

Could be the random installation problems that I’ve mentioned before or
perhaps a disk problem on one partition?

Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
“I wear the cheese. It does not wear me.”

I have the same problem on a fresh install of M4. It worked fine on M3. This seems to be tough one, I reopened

Let’s hope they find a fix before it gets released like this.

Check the permissons on ~/.mozilla are they 700? If so, change to 755

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 7 days 15:43, 3 users, load average: 0.16, 0.09, 0.09
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

  • davyar,

out of nothing, Mozilla products started working again: The only change I am aware of is, I installed the iFolder client and rebooted.
Could you please try that?


I had the same problem since I ran an update a few days ago, although this is with 11.2, not the beta version.

I downgraded firefox to the standard 3.5.8 version (from 3.6 in the mozilla repo), and it now works.

Looks like 3.6 is broken.

A bold statement. Because you are alone in it.
Did you try a new .mozilla with 3.6?

I remember a problem like this in the past that had to do with the gecko mediaplayer plugin. What happens if you disable that?

Or can you start firefox from a terminal like:

firefox --disable-plugins

I have just installed milestone 5. Firefox and Thunderbird work fine now.

Sony VGN-FW11E laptop
Intel(R) Core™2 Duo CPU P8400 @ 2.26GHz 3GB RAM
Mobility Radeon HD 3400 Series (M82) using radeonhd

Looks like it was the “opensuse firefox extensions 1.0” that was doing it. After disabling it now works :).

Working with it here.

Yep, it seems to be very hard to narrow down. I can’t test M5 because it doesn’t install.
I do hope this weird issue will be fixed. An openSUSE 11.3 with a large number of broken Firefoxes would be no fun.