Mozilla Firefox 3 freezes when loading pages


After several months, I’m still recovering from my ‘upgrade’ to openSuSE 11.1. At this point, Firefox still freezes when loading pages. Once loaded, I can resume scrolling and navigating. I’m not sure if this is an openSuSE issue or a Firefox issue.

So far, I disabled IPv6, toggled-off history collection in Preferences, and set browser.cache.disk.enable=false in about:config (from address bar).

Nothing seems to work. Can anyone make any further suggestions?


You could backup your bookmarks the re-name the hidden .mozilla folder to .mozilla_old

See if a clean new setup helps, if not you can go back to the old one.

Thanks. I forgot to mention that I already tried starting with a new profile folder. It was the first thing I tried. Furthermore, I’ve reinstalled everything completely, including the profile folder.

I notice that the update repo is listed as 11.0 in YaST version tab, however I have all 11.1 repo web addresses entered. I wonder if it’s grabbing Firefox out of the old 11.0 repo. Hmmmmm.

give us

zypper lr -u

It’s not a problem with Firefox itself, but probably related to the size of your network buffers. I had the same problem and solved it in the following way.

Add to the file /etc/sysctl.conf the following lines.

Tweaks for faster broadband…

net.core.rmem_default = 524288
net.core.rmem_max = 524288
net.core.wmem_default = 524288
net.core.wmem_max = 524288
net.ipv4.tcp_wmem = 4096 87380 2072576
net.ipv4.tcp_rmem = 4096 87380 2072576
net.ipv4.tcp_mem = 524288 524288 524288
net.ipv4.tcp_rfc1337 = 1

Once you have changed /etc/sysctl.conf you can commit the changes with the following command as root: sysctl -p.

I have found that this negates the necessity to fiddle with tcp_window_scaling.

The only thing here that may give rise to problems is the net.ipv4.tcp_rfc1337 = 1 (this may not be fully implemented yet but it will be in the near future). If you should have problems connecting to a non-linux machine then turn this off (value 0). This can be done fom the command line for ease of commit. As root you would enter at the prompt: /sbin/sysctl -w net.ipv4.tcp_rfc1337=0 (don’t forget to edit the file /etc/sysctl.conf to make the change permanent). Other than that as long as you have sufficient memory there should be no problem. What this does is increase buffer sizes (any of the lines with “mem” in them).

Ok, here 'tis. Only the relevant one though. The 11.0 alias appears in the YaST versions tab, but it looks like the address is ok. So maybe this isn’t a problem. Thanks though, I learned something new :slight_smile:

linux-6544:~ # zypper lr -u
#  | Alias                   | Name                  | Enabled | Refresh | URI

**15 | openSUSE-11.0-Updates_1 | openSUSE-11.1-Updates | Yes     | Yes     | http:                                                          //**

Thanks! That seems to have solved it. Was /etc/sysctl.conf altered between versions 11.0 and 11.1? If so, then why?! What a PITA it caused, since it sent me on a wild goose chase trying to figure out what went wrong. I reinstalled FF about 3 times!

All I can tell you is that through doing my own research I found numerous articles that state that the default buffer sizes, despite auto-tuning on both send and receive, are insufficient on higher speed networks that have high latencies (that would be the rtt figure you get from a ping request). You may or may not also notice an overall improvement in your connection as this should utilize your available bandwidth better.

I’m now noticing that it helps in most cases, but the freezing problem persists when navigating to websites with images. For example, sticks until the main picture image is fully loaded. Is there another setting to optimize this, perhaps?

Can you give an idea of the time frame for one of those pages to load. I ask this for comparison sake. So if you could express this in terms of the page loading in X amount of seconds helps greatly. Basically if the page is completely loading in 1 to 5 seconds then that’s quite acceptable, but if one of those pages is taking 2 min to load then obviously that’s no good.

It’s about 15- to 20-seconds. Too long :frowning:

It takes MUCH longer loading some pages. It’s kind of frustrating because I can’t even navigate to other tabs.

Before I ‘upgraded’ to openSuSE 11.1, it all worked fine.

What about other browsers, K, opera or Seamonkey?

Ok, it looks like Flash Player is the problem. I disabled it, along with nspluginwrapper (since my FF installation is 64-bit). That seems to have solved it, although I wasn’t even aware that Flash was being utilized on those slow pages that I was trying to load.

I guess I’ll just use 32-bit Opera for watching videos. However, Flash in Opera doesn’t work at all! It worked before I upgraded to 11.1, but not anymore. What could be wrong?


If you sttll have flash 9 installed then be sure to upgrade to version 10 (openSuSE updates). You may also want to check to ensure that your “user-name” is also a member of groups “audio” and Video".