Mozilla Displaying Pages Improperly

This has got to be a user config issue I am currently experiencing with OpenSuse using the MATE desktop and the Mozilla browser. When using Mozilla for general browsing there are a lot of website elements that simply don’t load. I’m missing pictures, backgrounds, and certain javascript buttons won’t work right.

Has anyone cracked the code on getting a proper web experience on Linux? I feel I run into this issue on many distro’s.

To demonstrate this issue, viewthis link on Mozilla on Linux, and then Mozilla on Windows. Lots of differences between the two, and in this case I was actually trying to apply for this card and the application process was basically unusable.

I checked the about:config and I have javascript enabled. What else could I be missing in an out of the box installation?

there have been reports that some drivers can cause similar issues on Firefox on Linux
what graphic card and driver do you have
if nvidia try installing the propitiatory driver
as that is a hustle on TW you can try and disable hardware acceleration in Firefox
in about:config find the values


and set them to true

I’m running on a VM on an ESX host. That’s where I end up running most of my Linux distributions. I have the maximum “GPU” VMware will allow for, something like 128mb and 3d support., but maybe it’s missing something on the OS side to utilize that.

When going into about config in Firefox I enabled layers.acceleration.disabled but I did not have gfx.direct2d as an option.

Is there a best practice for VM’s of packages I should be downloading for graphics support?

mozilla have been doing a lot of changes lately so a lot of preferences have been removed and some new added
I haven’t used vmware in a long time but they use to have an rpm video driver that drastically improved performance 128MB does seam low for modern web content
you could also disable webgl
in about:config find and set to true


Thanks I_A, disabled webgl, still no changes. Web pages don’t render properly.

I’m less concerned about my own workflow, because I could care less. But it is a general Linux issue, and if I had to provide someone I know with a Linux setup I would easily choose OpenSuse with either KDE or MATE desktops. But if they can’t even render webpages properly out of the box, that takes out 99% of the potential audience. So I would love to track this down, and understand why a modern distro would ship with a bad browsing experience. Shouldn’t require major time involved in about:config. It’s just web browsing, not programming in ADA and some complicated work flow.

Anyone have other ideas of things to try? I can try other desktop environments and see if its MATE specific in this case.

Quick follow up, different desktop environments do not make a difference. This appears to be a Firefox-centric issue. Unfortunately.

For comparison I downloaded Google Chrome and Vivaldi, both rendered websites properly. Actually not having used Vivaldi before I really enjoy this browser. Again unfortunately that points to a poor default Linux experience.
If only I shared what the Google Chrome site looked like, all the frames are out of whack, it’s like an earthquake hit the website, with bits and bobs all over the place… a sad sight …

So it’s definitely not VM GPU/Graphics related, it could be security or compatibility related. Any ideas? In the end to the generic user it looks like a “Linux” problem not a “software” problem, and that’s what’s frustrating me the most.

Exactly how is it not rendered right and which pages I see no problems here

I do notice a text bar issue (the text is not in the bar but a bit bellow it) on Firefox 54 on windows but no issues with Firefox 52 ESR on LEAP 42.2
I also read in the mailing list that there is a bug with gtk3 and system dpi (desktop independent) which Firefox 53+ uses
as this is a VM maybe ask in the VM sub-forums as I don’t use a VM

Interestingly, I finally tried it on my physical system and everything worked fine. Very odd, so it looks like it’s a Mozilla issue related to VM’s since Vivaldi worked fine.

Can’t take a screen shot of the VM because it’s a work machine, but I will look into issues related to Mozilla on VM’s.

Thanks all!!!

Just thought I would follow up on an additional test I did, I set up an OpenSuse Tumbleweed VM on VM Workstation on my home server, and Mozilla worked fine.

I’m not sure if it’s the additional 3D acceleration options, or the newer VMware software in general (Workstation 12 Pro). The software at work is an older ESX v5 host.

So this thread is pretty much ended as it seems the problem is isolated to ESX hosts. Everything with halfway decent graphic capabilities doesn’t seem to show errors. My new goto is the Vivaldi browser which seems to work everywhere and anywhere, and quite well.