Moving or deleting files very slow

Hi,

I am noticing that copying a folder to a new location, even of small to modest size (~150 mb), takes longer than it should. The speed seems to be comparable to what I would get copying a folder over a network, not from one place to another on my hard drive.

The worst performance comes when deleting a set of folders, even though each folder contains relatively little information. 5 seconds or more per folder.

Not sure why this is happening. I found this using Dolphin or Konqueror, in 11.1 with KDE 4.2.

Any suggestions for fixing this would be welcome.

Thanks.

In Linux everything in the graphical desktop is considered as a network object or file. Hence the “bad” performance…

Hmmm. Alright, but I am pretty sure I have had much faster performance until recently. For instance, I had deleted a large number of satellite images, which took far less time than the bibliographic records I was wiping out which took ages in comparison. Seems to me that something has happened to effect this.

I added Google Desktop search in the interim, but I disabled indexing, and even quit the program, with no corresponding boost in speed. Plus, I think GD only indexes when the system is idle.

Hi,
@mazibuko
Did you solve the problem? Because I have the same for few weeks. Sometimes the system even stop responding for few minutes (while moving e.g. 10 MB !!)

I’ll feel grateful for answer and help.
Michal.

Hi,

No, I haven’t–at least I don’t think I have, but I haven’t had to delete files for a while.

No solution yet, I am afraid.

I will post back if something comes up.

Are you using delete (that is you added delete to the menu) as opposed to ‘move to wastebin’?
or of course use Shift - Delete

Hi,
yesterday, for example, I used Shift + Menu option to delete the Folder in Amarok - and I was to kill the application :(.

Today I am testing Dolphin with Nepomuk turned ON … and everything is ok.

Could this be a solution? [sorry for my English :shame:]

Michal.

I think I used the delete key on the laptop, but also right-clicked and selected move to trash (which says it corresponds to the delete key…).

Thanks.

I think this is a KDE4 problem. If you haven’t yet update KDE to 4.2.1 and also your Qt libs to 4.5. It got a lot better (faster) for me after the updates.
An additional solution is to use a KDE3 program like Krusader for big file operations, works flawlessly and fast, only lacks the looks :wink:

Really weird, my KDE has never been faster. But…i’ve seen at some friends that they have quite a mix of old and very old plasmoids making plasma take up to 99% of CPU, that’s one, and…
Beagle/Kerry working? I get transferrates from SATAII to SATAII that remind me of the early 90s. So I removed those, and now it’s fast, very fast

Hi Tempusfugit,

Thanks, following your suggestion re. updating to 4.2.1 etc. Looks like it did the trick. Blindingly fast delete of 1.5 GB’s worth of files now!

My kio_trash is using almost all of the CPU time. Thankfully I have a dual processor so at least my machine remains usable.

Anybody with ideas on how to fix this?

i disabled strigi and nepomuk and now its back to normal speed…

Just for the record on an old thread:

I had the same problem (deleting a 100Byte file required 2 minutes on a Q6700 quadcore) like the OP after doing a major cleanup and delete run over $HOME with dolphin. The solution was somehow anticlimactic. Empty the trashcan.

I solved the problem as hinted in https://bugs.launchpad.net/kdelibs/+bug/354617 comment #9:
Dolphin->Configure->Trash->uncheck “Limit to maximum size”

Now moving files to trash goes almost instantly, even if the Trash is over 1 GB.

(opensuse 11.1 64 bit kde 4.3)