moving home folder fstab changing UUID doesn't work

Hello Guys,

i just wanted to move my home server to a different partition and changed the UUID to the new partition and instead of BTRFS I used ext4.

No dice, OpenSuse just doesn’t want to use it, even mounting as /dev/sdb4 didn’t work either.

Help :slight_smile:

It is not very clear what yoou did. You talk in the title about “home folder” and in the post about “home server”? Do you mean the “home directory” and more specific the partition that is to be mounted at /home?

And you do assume that we know a lot more about your system then we do (not being clairvoyant).

Please post some factual information like:

su -l -c 'fdisk -l'

and

cat /etc/fstab

and

ls -l /dev/disk/by-uuid

And explain what you think is the “new partition”, and because you call it the new one, please what is the “old one”?

A more detailed explanation on the steps you did would also not be bad.

Hello Henk, thank you for taking the time helping me.

This post was done i a frustration and late, sorry it wasn’t as clear as it should have been:

dirk@voyager:~>** su -l -c ‘fdisk -l’**
Password:
Disk /dev/sda: 298.1 GiB, 320072933376 bytes, 625142448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 7EB13EB1-DC79-4814-99BA-11698199552C

Device Start End Sectors Size Type
/dev/sda1 2048 1495039 1492992 729M EFI System
/dev/sda2 1495040 625141759 623646720 297.4G Microsoft basic data

Disk /dev/sdb: 698.7 GiB, 750156374016 bytes, 1465149168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xfb3059eb

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 2048 104859647 104857600 50G 83 Linux
/dev/sdb2 1117859840 1465147391 347287552 165.6G 5 Extended
/dev/sdb3 109053952 1055608831 946554880 451.4G 83 Linux
/dev/sdb4 1055608832 1117859839 62251008 29.7G 83 Linux
/dev/sdb5 1117861888 1210935295 93073408 44.4G 83 Linux

Partition table entries are not in disk order.

dirk@voyager:~> cat /etc/fstab

UUID=3e231b28-b001-4b3d-87ed-9f5029ee50d3 swap swap defaults 0 0

UUID=c5bc6794-1ed8-47a8-a37a-8158ec51b93d / ext4 defaults 1 1
UUID=82BD-8611 /boot/efi vfat umask=0002,utf8=true 0 0
UUID=017726e4-5c89-4bd1-a9a0-0f6bb8db077e /home btrfs defaults
0 0

This is the one which doesn’t work: # UUID=6a8e6865-953a-4e05-970a-a286426205e9 /home ext4 defaults 0 0

UUID=14096b9a-311a-47b7-9ec4-7b454969a64b /home/dirk/.arch ext4 defaults
0 0

dirk@voyager:~> ls -l /dev/disk/by-uuid
total 0
lrwxrwxrwx 1 root root 10 Mar 20 09:36 017726e4-5c89-4bd1-a9a0-0f6bb8db077e → …/…/sda2
lrwxrwxrwx 1 root root 10 Mar 20 09:36 0d4866bc-b9d8-4ba4-89b1-8d2066464da4 → …/…/sdb1
lrwxrwxrwx 1 root root 10 Mar 20 09:36 14096b9a-311a-47b7-9ec4-7b454969a64b → …/…/sdb3
lrwxrwxrwx 1 root root 10 Mar 20 09:36 6a8e6865-953a-4e05-970a-a286426205e9 → …/…/sdb5
lrwxrwxrwx 1 root root 10 Mar 20 09:36 82BD-8611 → …/…/sda1
lrwxrwxrwx 1 root root 10 Mar 20 09:36 c5bc6794-1ed8-47a8-a37a-8158ec51b93d → …/…/sdb4

I mounted my others OS (ARCH) in a invisible folder .arch and use sym links to chare folders like Document Pictures Music, Dropbox etc.

I’ll agree with hvcc – it is not at all clear what you did.

If you are actually moving the root partition, then you might need to reinstall the bootloader and you probably need to rebuild the “initrd”.

It is very difficult to see the difference between your story and the computer facts. Also all column layout is gone. Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

Also I am missing the step by step explanation what you did “moving home folder fstab changing UUID doesn’t work”. That is to say, what was the starting situation, what was your goal and what did you to to achieve it???

The fstab entry where you say that things go wrong (but I see nothing that proves that things go wrong) is about UUID=6a8e6865-953a-4e05-970a-a286426205e9 and that is sdb5.

It is in any case a bit a strange setup because you have / as ext4, but /home as btrfs. When you install LEAP 42.2 fresh, the defaults would be the other way around (but everybody to his/her liking).

Coming back to you saying that mounting sdb5 goes wrong, please do and show:

su -l -c 'mount /dev/sdb5 /mnt'

There is one thing that sort of went wrong for me as I didn’t appreciate how things work.This is mine


john@dhcppc0:~> cat /etc/fstab
/dev/disk/by-id/ata-PLEXTOR_PX-128M5Pro_P02306101219-part2      /       ext4    acl,user_xattr 1 1 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part1  swap    swap    defaults 0 0 
/dev/disk/by-id/ata-PLEXTOR_PX-128M5Pro_P02306101219-part1      /boot/efi       vfat    umask=0002,utf8=true 0 0 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part4  /home/home2     ext4    noacl,user_xattr 1 2 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part3  /tmp    ext4    acl,user_xattr 1 2 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part2  /var    ext4    acl,user_xattr 1 2 
/dev/md0             /home               ext4       acl,user_xattr        1 2
j

I prefer by name as it’s easier to know which disk is which

Where I had problem was home2. I found I couldn’t use it. It’s the root of a disk and as such only root could do anything with it so I had to add a directory set for user writes. At least that is what I think caused the problem. I added the home2 partition with YAST shortly after a fresh install.

EXT4 off a BTRFS home though - pass.

If you are copying from btfs, reformating that to ext4 and then putting it back on again the disk you are using to hold the data for a while could be mounted anywhere but will I think have to have a directory put on that allows a user to write into it.

If you are literally moving home to some where else one of my recent posts goes though how I did that. I posted it because there are all sorts of odd comments about how to do it on the web. So hard that it’s best to use a bootable iso for instance. That is one way but it can be done without pretty easily really.

John

I thought I said the home partition.

Sorry for the confusion, I am preparing for my CPL written exam and didn’t expect so much on difficulties.

I have now the (system) home partition running to keep it working.

I hoped that line:

This is the one which doesn’t work: # UUID=6a8e6865-953a-4e05-970a-a286426205e9 /home ext4 defaults 0 0

would highlight where for me the problem is

still, if I see that line I don’t understand why it doesn’t get mounted at start up.

oe maybe very simple:

why does:

UUID=14096b9a-311a-47b7-9ec4-7b454969a64b /home/dirk/.arch      ext4       defaults              
0 0

mount and:

UUID=6a8e6865-953a-4e05-970a-a286426205e9   /home     ext4    defaults        0 0

doesn’t.

Bytheway it is a PC, ooppss

Because it is commented out?

Yes, I did this to get the original home partition mounted again without getting the trouble for this partition.:open_mouth:

So you expect us to second guess what you had in fstab when it did not work? It is interesting riddle contest, but showing your fstab exactly as you have it when it fails would be more productive.

I asked for several things. Amongst them to do a test mount and post t he results, to explain what you had, wanted to change and how you did.

It seems that you refuse to give any answers. In that case the discussion is moot and I will go to some more promising tasks.

:wink: Hang on before commenting I need to look at your fstab again. Just though I had better had.

You have


UUID=017726e4-5c89-4bd1-a9a0-0f6bb8db077e /home                btrfs      defaults              
0 0
#
**This is the one which doesn't work:** # UUID=6a8e6865-953a-4e05-970a-a286426205e9   /home     ext4    defaults        0 0


You very probably can’t mount 2 /homes which you seem to have tried to do. So you need to change one or the the other eg ext4 could become /home/AnotherHome or what ever you want to call it. I called mine home2. Or you could change the btrfs one to say home/HomeBtrfs or what ever. In other words only one home but remember what I said about the root of the disk that is then mounted off home. As far as I am aware only root can work there so it needs a user directory of some sort.

Henk may know of some way of setting the permissions so that a user can use the root of a disk mounted off home but I don’t think it can be done and is why root user is called root, not su as some think. That’s switch user.

John

Hi John, yes did comment the original home partition out when I tried to mount the new one and visa vie.

Hank and arvidiaar are reminding me very strong on the Debian Forum, where you don’t dare ask questions.

I dropped Debian because of those Forum people destroyer, having said this, Hank is not one of them.

You got to read and understand.

This is part of the fstab:

This is the one which doesn’t work: # UUID=6a8e6865-953a-4e05-970a-a286426205e9 /home ext4 defaults 0 0

and it means,“this is the one which doesn’t work”

meant is the following line, which looks like a UUID partition mounting line from fstab.

After reading and seeing this,

for

UUID=017726e4-5c89-4bd1-a9a0-0f6bb8db077e /home btrfs defaults
0 0

is the only logical explanation, that it must be the “system” home partition, which makes double sense after I mentioned that I also changed the format from BTRFS to EXT4

“changed the UUID to the new partition and instead of BTRFS I used ext4”.

If you are not interested in helping, that is OK, but if you don’t bother to read the thread, you will never know what is going on. And if you just want to troll people, go to Arch and tell people to check the Wiki or go to Debian and your style fits without alterations.

Consider this as a warning from the staff.

All answers here to your thread are made in good faith from people who try to help you in their spare time. We expect from you that you stay polite.

Several people that tried to help you in this thread asked for more information. Either technical one or background. When you do not read them and do not answer them, but only repeat what you have said earlier, not much help will come forward and people will stop reading this thread or even future threads that you might want to start.

This is to be a friendly and in the same time technical forum. so expect to the point questions to post computer output generated by commands shown to you and clarifications of what you did and experienced. Nobody here can look over your shoulder and we all depend on the limitations that a medium like this forum offers.

This true for all but one and what I wrote, might have sound rude, but it was just stating the truth. No technical question was asked and what was written, didn’t seemed to be read either.

I will be very kind to you and ask you to reread post #5 above in this thread where I asked you to do a certain mount command and where I asked you also tell us

  • your starting situation;
  • what your goal was that made you start changing things’
  • step by step what you did.

You quoted that in post #8, but instead of answering you started telling again that you have a problem, which we knew already.
In post #13 I asked you why I did not get those answers.

This is really the last time I do. Much time is lost (4 hours almost after post #5), I am almost going to bed now.

Not blaming you Hank, I started that post just before I started my CPL written-exam-test and was more focused to get this done (Thursday is the real thing, so I am very focused on this) and didn’t expect too much trouble as I had done the mounting with invisible (.arch) folder/partition.

This should have been an easy change in fstab, plus moving all home folder files and folders to the new partition (which I did already [actually copied])

Still don’t have too much time at hand.

Thank you for your help and time, will figure this out on my own, when I have time again (after Thursday).