Moved up to 12.1 and wifi now fails to auto connect.

On T42 ThinkPad with openSUSE 12.1 (i586) and KDE: 4.7.2 (4.7.2) “release 5” the network installation was flawless but had a few glitches with package-kit until I did an on-line update. I now find that on restart the wifi does not connect and even after a long wait I do not get asked to open the wallet for the passphrase.

When I open the wifi icon to be able to manage connections, the correct ap is not shown. If I disable wireless and then re-enable it, then the correct ap is shown and I get the prompt to open the wallet and all goes as it should.
Is this a known bug or do I have to tweak something?


So I have not see this oddity, but a few seems to exist. You can continue with what works, or you might try this. Go to YaST / Network Devices / Network Settings and disable Network Manager, make sure that the manual wireless settings for your network are made properly, close the app, Network Manager is disabled. Then, go back in and re-enable Network Manager, network startup may stall, and restart openSUSE. Often, such a tac seems to fix what ever is going on with wireless, but its hard to say whats wrong when it will connect properly after a few extra mouse moves as you suggest.

Thank You,

Hi and thanks for the suggestion. Will try as you suggest but am not at all happy with 12.1.

I have had three successful installs of openSUSE 12.1 with two including Wireless. I really feel that most issues that come up will be solved and I now have solid working systems with openSUSE 12.1 & kernel 3.1. I am not sure that we have any more issues than normal with a new release, but it seems worse when one of the issues strikes you. I say hang in there but there is no shame in dropping back to 11.4. I am heading forward myself with the new release.

Thank You,

Hi again, I disabled Networkmanager and enabled traditional connection and all is well. Starts and connects promptly. Will leave as is for now.
Thanks again,

I am happy you found a working solution. Using ifup works fine if the type of network connection is always the same and even may save startup time. Good for you!

Thank You,

I just purged my laptop of MicroSoft and performed my initial install of openSUSE 12.1 from a disk image I burned to DVD on my desktop PC. During installation, I accepted all defaults; therefore, my desktop is KBE. All appeared to be working well until I tried to connect to my wireless network. Boot messages confirmed that SUSE recognized the wireless card (ATHEROS AR5001) and YaST2-Network Settings → Overview displayed the adapter; however, NetworkManager refused to activate its WIRELESS tab. I went thru the various FAQs, Forum Threads, Google searches, etc and found descriptions of similar problems and work-arounds (ie: not using NetworkManager). I tried implementing several work-arounds over the course of a weekend and achieved a 100% failure rate. Since this was/is a new installation, I reinstalled SUSE in the same way, but changed 1 variable (scientific method! I’m so proud of me 8^)… I disconnected my network cable from my desktop and plugged it into my laptop before starting installation. My thinking was that something during the installation needs to sneak a download to correctly support NetworkManager. IT NOW WORKS!!! After installation NetworkManager allowed both its WIRED and WIRELESS tab to be active. I successfully muddled thru the WIRELESS configuration/connection, connected to my wireless router, and was able to remain online after taking my laptop off WIRED life-support. Maybe this novella posting will help someone fix the actual problem (whatever it may be). Good luck!!

= =


If I were to guess, there was one package that was needed, and that is the
kernel-firmware component. Most wireless devices, and all 802.11n varieties
need external firmware that is loaded when the driver starts. Without a network
connection in the first install, that was probably not installed. As the
“how-tos” all describe, there is an easy way to check that, but you do not need
to now.