Moved installation on SAS disk to new machine - no boot

Hi!

Moved a 15.3 (on SATA disk, booting fine) and a TW install (SAS disk) to a new machine. Booting TW looks good until

“Reached Target Basic System”

then it pauses and after some times I get a lot of errors

"dracut-initqueue … Warning … starting timeout scripts

-e “dev/disk/by-uuid/afdb…”

After some time I end up with the emergency mode.

Best guess: The UUID has changed?

I booted the Leap and chose bootloader in YaST to re-write the boot-stuff, but that didn’t help.

In the emergency mode I did

blkid

and wanted to change fstab, but apparently no editor (vi, nano) available…

Tried from the booted Leap, but apparently the UUIDs in fstab of TW are correct.

What am I missing here?

Hi
Boot to ‘rescue’ mode or boot from live media to change… maybe switch to /dev/sdX rather than UUID?

PS: The machine in an old, BIOS Dell Precision T7400. The file system on disk is EXT4.

The Warning reads:

“…still waiting for following iniqueue hooks:
/lib/dracut/hooks/initqueue/finished/devexists-\x2fdev\x2fdisk\x2fby-uuid\x2fafdb83e0-…sh”

the UUID of the missing disk is not in the output of blkid in the emergency mode console…

Is it an option that there is no driver for the SAS-controller in the Linux? It’s a built-in Dell SAS-controller SAS 6/iR…?

I have only one drive in rescue mode (dev/sda), but there is the SAS and the SATA disk.

But on the other hand, in Leap 15.3 I see the SAS disk. Confused…

Hi
Check the lspci output to see what driver is in use in Leap 15.3.

lspci says

Broadcom LSI SAS1068E PCI-EXPRESS Fusion-MPT SAS (rev 08)

Double-checked the UUIDs in the TW fstab, apparently correct, according to blkid in LEAP. No idea how to proceed…

If I use /dev/sda in fstab, how to be sure which HDD will be /dev/sda? :-/

Changed fstab for TW to /dev/sdb1 and /dev/sdb2 (as named in Leap). Still no boot, same error, trying to find the correct, but not chosen UUIDs…

Hi
Add some verbosity to see the module/driver in use…


/sbin/lspci -nnk | grep -A3 "SAS1068E"

I guess it’s a driver issue… I lost my nerves and took a copy (dd) to a SATA disk, that one works fine with TW…

May search a little deeper if I have time next weekend. :wink:

In TW (!) I get:

sudo /sbin/lspci -nnk | grep -A3 "SAS1068E" 
[sudo] password for root:  
05:00.0 SCSI storage controller [0100]: Broadcom / LSI **SAS1068E** PCI-Express Fusion-MPT SAS [1000:0058] (rev 08) 
        Subsystem: Dell SAS 6/iR Integrated Workstations RAID Controller [1028:021d] 
        Kernel driver in use: mptsas 
        Kernel modules: mptsas 

Hi
Well it finds the driver by the looks… in Leap is it a different driver? Sure it’s not about swap UUID or the resume= or root= enrty in grub options?

As the dd-copied version on SATA simply boots, I guess not. But how to find out? The UUID in the warning is the root partition, no swap:

sudo cat /etc/fstab 
[sudo] password for root:  
UUID=afdb83e0-8c0c-4c52-b512-9a55792a4514  /      ext4  acl,user_xattr               0  1 
UUID=a5dae44e-c192-4f11-b8bc-7d210e527c10  /home  ext4  data=ordered,acl,user_xattr  0  2

btw: Leap doesn’t need the SAS driver for booting, as it is installed on a SATA disk :wink:

Hi
Fire up YaST bootloader and check there or check via cli via;


cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT

Hmmm…

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT 
**GRUB_CMDLINE_LINUX_DEFAULT**="splash=silent quiet ipv6.disable=1"

on the TW (SATA) currently running. What does it tell us?

Hi
That it’s not used there :wink: I suspect it needs to be added to initrd as it comes up later in the boot process…


lsinitrd | grep mptsas

lsinitrd | grep mptsas

Driver issue confirmed? :slight_smile:

Hi
I would create a dracut.conf.d config file to add it and rebuild initrd and see if that helps.

Yeah, me too, if I knew how… :smiley:

Hi
Create a files called say /etc/dracut.conf.d/01-mptsas.conf


hostonly="yes"
compress="cat"
add_drivers+=" mptsas "

Rebuild initird with dracut -f command

In the emergency console I found no editor (nano, vi I tried) and how to do this on a non-booted HDD?