Moved HD to new box, but display is not quite right


PC1: Windows 7 and Linux distros in 2 separate HDs. Leap 15 uses nvidia driver. Video card is GT520.

PC2: Windows 7 with GT730 video card.

I just installed the Linux disk that I removed from PC1 and put it in PC2. After booting, Leap 15 with KDE 64-bit shows very tiny user id and password boxes. After logging in, the screen shows only the top 50% of the task bar at the bottom of the screen. In other words, I only saw the top 50% of the icons on the task bar. Display is HDMI 1360 x 768.

By the way, Debian 9.5 KDE 64-bit in the same Linux disk shows no problems when moving over. It uses nouveau as default graphic driver.

Could you please show me how to fix this problem?

Thanks a lot for your help.

Did you run mkinitrd to discover the new hardware??

Remove ( whilst not logged in ) ~/.local/share/kscreen/ That should reset the video/monitor settings and have them rediscovered.

No, I did not run mkinitrd.

My original resolution was 1024x768x16. Further “mucking” has resulted in the texts or screen labels being very tiny. They are unreadable.

Hi Knurpht, I don’t understand your suggestion. If I don’t log in, how can I remove or delete the file you suggested?


need to run mkinitrd if I was not clear (as root)

As to Knurpht’s suggestion log in as some one else. Or boot to a termianl and log in as root and remove said file. At boot screen press e then find line starting linux or linux-efi go to the true end of that line (it wraps) add a space and a 3 continuse boot (F10) log in as root and remove the file

rm /home/*yourusernamehere*/.local/share/kscreen/

At the greeter screen, do Ctrl-Alt-F3, login, remove said file using cmdline tools rm (remove) or mc (text mode file manager).

Hello all,

Ran mkinitrd but terminal screen display was too small to read;

Tried adding 3 to Grub’s kernel boot line, etc. Screen says cannot remove …kscreen 'cause it’s a directory.

Ended up re-installing Leap and editing “/etc/default/grub” to show "GRUB_GFXMODE=“1024X768X16”

All is well and up-to-date.

Thanks everyone!



The other day I installed Linux Mint 19 on Computer B, and ran into the same problem. It appears that the problem is due to overscanning by the TV part of my second-hand TV-LCD monitor which is stuck in HDMI mode. I cannot switch to VGA mode. I also tried NVIDIA xserver-xorg configuration’s underscan feature but no resolutions could solve the problem.

For now, I am satisfied with both Leap and Debian Stretch on this computer.

Next time for an entire directory and it’s contents, use

rm -rf