Mouse wheel side scroll (again!)

I’ve read through several posts and articles about trying to get the extra mouse buttons and side scroll wheel to work under openSUSE 11.1 (64).

Nothing seems to have worked so far.

cat /proc/bus/input/devices shows -

I: Bus=0003 Vendor=04fc Product=05da Version=0110
N: Name=“MLK Trust Mouse 15315-02”
P: Phys=usb-0000:00:02.0-6/input0
S: Sysfs=/devices/pci0000:00/0000:00:02.0/usb1/1-6/1-6:1.0/input/input8
U: Uniq=
H: Handlers=kbd mouse1 event8
B: EV=1f
B: KEY=837fff002c3027 bf00444400000000 1f0001 f848a27c000 667bfad9415fed 8e000000000000 0
B: REL=1c3
B: ABS=100000000
B: MSC=10

/etc/X11/xorg.conf contains -

Section “InputDevice”
Identifier “Mouse[3]”
Driver “mouse”
Option “Buttons” “9”
Option “ButtonMapping” “1 2 3 6 7 8 9”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

When I run xev buttons 1 through 7 show up, but buttons 8 & 9 don’t.

Any ideas? Thanks :slight_smile:

Yep its hotplugging this explains it better…

Xorg input hotplugging - ArchWiki

You can check with

hal-device|grep -B 15 input.x11.driver

OK so now you know why as for fixing not got a clue, I only had to fix the keyboard :wink: From my brief look at /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi and comparing my fix for keyboard in /etc/hal/fdi/policy/10-keymap.fdi it seems sort of straight forward…(OK did you notice the guessing) where I have

<merge key="input.xkb.layout" type="string">gb</merge>

This in the old way would of been…

Option         "XkbLayout" "gb" 

Or you have …

Xorg input hotplugging - ArchWiki
Then I guess the old fixes will work…