Mouse wheel problem

I have a problem with mouse wheel. In browsers (firefox, chrome, opera) when scrolling it jumps like a rabbit up and down. Have to do it real slow.

I have been to configurations, decreased from 3 lines to 2 lines, but doesn’t have any effect.

Anyone knows how to make wheel ‘smoother’ and not jump around?
Mouse is cheap ****, but works ok, except wheel (in kdem, but in VM on windows, works ok)

what is your hardware ?
What is your Linux OS and version?
What is your configuration and drivers in use?

answer these and maybe we can advise without take wild guessing.

KDE4 latest from factory (4.4.3), suse 11.2 updated, no drivers whatsoever, generic mouse.

Forgot to mention, in Flock browser it works OK. but only in Flock.

Do you have an xorg.conf file?

Nope… only xorg.conf.install
Didnt used Sax after install of system, just going on defaults.

What’s your videocard? I’ve seen this on NVIDIA cards using the ‘nv’ driver.

intel integrated…

Should I ran Sax? just in case?

Would not hurt.

sax2 -r 0=intel

should produce the appropriate file. but then to try and fix the mouse problem you need to edit it.

Find the section on input for you mouse there are instructions to activate the there.

If you don’t have xorg.conf, you may find out the configuration for mouse from the lshal output:

lshal | grep -20 mouse

If you want to customize those options, you may have to create a policy file for that device in /etc/hal/fdi/policy/20thirdparty/ directory. Customized configuration files can be created by copying the default once from /usr/share/hal/fdi/policy/…

Unfortunately I wont be able to test it. I am overloaded with work, as in monday I go to trip in europe where I will stay for 1 month.
I will check it when I am back, as this is on my workstation here. On laptop is fine.

Thank you all… I will go back to this post when I am back.