Mouse wheel click won't paste: GeForce 9100, HP Optical Mouse

When I run /usr/bin/xinput --test 11' where 11 is the USB Optical Mouse id=11 shown from /usr/bin/xinput --list’, I get no input from clicking the mouse wheel. This recently changed and I don’t know why. Does anybody else have this problem? Know how to fix it?

openSUSE 12.1 (x86_64)

hwinfo --gfxcard

32: PCI 200.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: B35A.gjcntUyfG7F
Parent ID: gZD2.t79_63UH7A4
SysFS ID: /devices/pci0000:00/0000:00:0b.0/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: graphics card
Model: “nVidia C78 [GeForce 9100]”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0847 “C78 [GeForce 9100]”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x2a9e
Revision: 0xa2
Driver: “nvidia”
Driver Modules: “nvidia”
Memory Range: 0xfd000000-0xfdffffff (rw,non-prefetchable)
Memory Range: 0xe8000000-0xefffffff (ro,non-prefetchable)
Memory Range: 0xe6000000-0xe7ffffff (ro,non-prefetchable)
I/O Ports: 0xec00-0xec7f (rw)
Memory Range: 0xfeae0000-0xfeafffff (ro,non-prefetchable,disabled)
IRQ: 20 (3088887 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd00000847sv0000103Csd00002A9Ebc03sc00i00”
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: “modprobe nvidiafb”
Driver Info #1:
Driver Status: nouveau is not active
Driver Activation Cmd: “modprobe nouveau”
Driver Info #2:
Driver Status: nvidia is active
Driver Activation Cmd: “modprobe nvidia”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #21 (PCI bridge)

Primary display adapter: #32

hwinfo --mouse

42: USB 00.0: 10503 USB Mouse
[Created at usb.122]
Unique ID: CiZ2.ESfJHxT2CJ9
Parent ID: uIhY.kllrQr_lFX9
SysFS ID: /devices/pci0000:00/0000:00:02.0/usb3/3-3/3-3:1.0
SysFS BusID: 3-3:1.0
Hardware Class: mouse
Model: “USB Optical Mouse”
Hotplug: USB
Vendor: usb 0x192f
Device: usb 0x0416 “USB Optical Mouse”
Revision: “2.00”
Compatible to: int 0x0210 0x0023
Driver: “usbhid”
Driver Modules: “usbhid”
Device File: /dev/input/mice (/dev/input/mouse0)
Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event2, /dev/input/by-id/usb-192f_USB_Optical_Mouse-event-mouse, /dev/input/by-path/pci-0000:00:02.0-usb-0:3:1.0-event-mouse, /dev/input/by-id/usb-192f_USB_Optical_Mouse-mouse, /dev/input/by-path/pci-0000:00:02.0-usb-0:3:1.0-mouse
Device Number: char 13:63 (char 13:32)
Speed: 1.5 Mbps
Module Alias: “usb:v192Fp0416d0200dc00dsc00dp00ic03isc01ip02”
Driver Info #0:
Buttons: 3
Wheels: 2
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #37 (Hub)

From /etc/X11/xorg.conf

Section “InputDevice”
# generated from data in “/etc/sysconfig/mouse”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “IMPS/2”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “yes”
Option “ZAxisMapping” “4 5”

By physically rapping the mouse sideways on the desk a few times, it started working again. Duh!

Haha, thanks, mate! I had the same problem and tried EVERYTHING!
Your solution finally worked!