Mouse/Touchpad not working.

Hi guys. I just installed Opensuse 13.1 with KDE and the mouse isn’t responding. I use a HP laptop. I don’t have an external/usb mouse. It’s the touchpad. After trying everything, I started opensuse in “advanced settings -> recovery mode” and the mouse seems to work fine, I don’t understand? I’m not savvy enough with Linux to know why it works in recovery mode.

One thing I did notice. After being instructed to try “xinput -list”, my terminal responded with: “Unable to connect with X server.” When i ran opensuse on recovery mode, while the console was loading, one text i definately saw (although i’ve forgotten the exact text) was “Started X server” or “Started X window manager”. Could the mouse problem be connected to this?

Is it one of those HP’s that have a pointer thingy in the middle of the keyboard?

Hmm. I don’t see anything in the middle.

I think it might be a hardware problem. Ive been getting some help, but using recovery mode has made my laptop aware of the problem. I went here:

green button(like windows start menu) > Applications > system > configuration > touchpad management

I check the option: automatically start touch pad on logon

Next i logged in again but no longer on recovery mode, and i got a dialog with this message.

synaptics is definately installed, so i guess it’s my hardware. On windows device manager, the device is defined as: Synaptics PS/2 Port Touchpad.

I can’t actually help.

When I got my laptop, I had something of the same problem. Sometimes the touchpad would work, and sometimes it wouldn’t be recognized. I think it depended on whether I booted cold, or rebooted from Windows, but my memory is a bit hazy.

A year later, it was working reliably.

I think what was happening, was that the hardware is receiving periodic enhancements. And, eventually, the drivers catch up. Of course, once I buy the computer, that hardware is fixed. It is only in newer ones that there will be more enhancements.

Hi guys I’ve just about accepted defeat but all is not so bad. My main question will be asked at the end so please skip there (ignore the paste) if you don’t want to read my diagnostics. I really want my main question answered to see if I’m better off trying another distro.

Upon viewing my xorg logs, here are some details of the Errors and Warnings I’ve seen. This may not be useful to anyone but as I can’t locate the Issue Tracker that my system told me to report my problems to, I thought I’d leave it here.

Errors and Warnings on /var/log/Xorg.0.log and /var/log/Xorg.1.log:

My question is, as when i log in via Recovery mode, my mouse works fine. The screen is as clear as it is without Recovery mode on. All the programs and the PC itself seem to work the same. My question is, is it ok to just always run this laptop on Recovery mode? Or will I be missing out on major features if i do? I really can’t spot a difference but Im a novice with computers so someone with better knowledge will really clarify things. Can i keep on using opensuse as my Operating system or am I better off going with something like Ubuntu?

Thanks for all the help and input.

Yes you can run in Recovery Mode.

The HP brand has always been very user-friendly with openSUSE. What is the exact model of your HP laptop?

In the meantime, start the touchpad daemon while in KDE4.

Navigate to the green application launcher -->Configure Desktop -->Startup and Shutdown -->Service Manager
Under Startup Services enable by clicking in a checkmark under “Use” KDE Touchpad Enabler Daemon
Click on the Start and Apply buttons to confirm.

You can also use synclient while in konsole.

Follow Up

Please check this Archlinux wiki for Touchpad help

I would recommend also installing kcm-touchpad from the KDE Extra repository.

Once installed you can find it under Configure Desktop -->Input Devices -->Touchpad.

It has many settings for tweaking the touchpad.

Hey, sorry I had given up that I didn’t check back here. I downloaded this kcm-touchpad and also enabled the demon (It was enabled by default) but still no luck. I’m content with just using it in “recovery mode.” The most important thing is that at least I can use it. Maybe on the next upgrade of opensuse my touchpad will be supported… Thanks for all the help.

You are welcome. I would check if there is a key on the laptop that turns the touchpad off and on.

Hey. Yes “ctrl + alt + T” does this in recovery mode. It has no effect on non recovery mode though:(