Mouse scroll wheel bug openSUSE 12.1

Hi everybody!

On my openSUSE 12.1 I encountered a malfunction of the mouse wheel. What happens: the scroll wheel is inactive and the scroll function is emulated by it’s pushing button. To scroll something you have to push the wheel button and drag the mouse up and down. I have an ordinary PS/2 with 3 buttons + 1 wheel mouse. This never happened in any of openSUSE versions I used before.
So, what I did to try to fix this problem:

  • I tried to modify the 11-mouse.conf file in /etc/X11/xorg.conf.d in order to disable the emulation by commenting those lines. Nothing happened except the disabling of the wheel button scroll…
  • I configured the mouse in /etc/sysconfig to tell the system I DO HAVE a mouse wheel and I don’t need this to be emulated by any button. Nothing happened…
  • I even removed the 11-mouse.conf file, restarted the system in order the mouse to be detected again. Nothing happened…

What more can be done? This thing makes me crazy when I use Firefox. it’s like hell… :sarcastic:

Thank you very much!

Solved. I write this in order to be useful to anyone who may face this issue in the future.
There is no real bug. In fact, when I installed the system I noticed that there were added some useless, I may say now, Kernel command line parameters in GRUB but I didn’t pay much attention to this at that time. Among them there was a parameter “psmouse.proto=bare” that caused my problem. Perhaps the right mouse protocol should have been “IMPS/2”. But now I don’t care anymore. I just deleted all useless parameters and I retained only “apm = off” and “acpi=off” that I think are useful. I restarted the system and my mouse was automatically detected OK and works properly. That’s it.
Here are all Kernel parameters I had before in GRUB:
apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf splash=silent quiet showopts

             				 				 					 						 	**Hello horus_2000**]( !

                   I also had the same problem with the minimal install of OS 12.3 , after lot of googleing and effort to make the mouse scroll work, I finally found your solution worked perfectly i.e. after deleting just psmouse.proto=bare parameter in BOOT/GRUB configuration file. I Thankyou for the solution provided:good: .