mouse pointer disappears

Installed 11.2 last night. When computer idles for 20 minutes & I return, the cursor is completely gone & cannot be retrieved, though the mouse looks like it is working, just no cursor. Also my monitor keeps changing parameters, I tried to set Sax2 but it won’t save changes? What do I do? I didn’t notice the cursor thing until I set up the screensaver to go off at 6 minutes.

Something similar here started this morning: after several days of flawless working, suddenly the mouse pointer disappears after a few seconds of idleness. Comes back when the mouse is moved though, but still disconcerting…

On closer inspection, my pointer problem seems to be confined to Firefox…

Installed 11.2. I use the KRandR program to modify my screen resolution. The moment it refreshes the screen, the mouse pointer disappears. This happens will all users on the system. It did not happen with the root user. Need help! This was a re-install that replaced 10.2 and I have a few users on the system.

I need to modify/refresh the screen because by default is doesn’t appear normally. Also, because of the previous post I am also worried that if the screen refreshes for any other reason the mouse may also disappear.

Thanks!!

You might be suffering from old settings. Try creating a new user, login as that new user and see if problem exists then. Since it does not for root (NEVER LOGIN ON A DESKTOP AS ROOT), it could very well be in your settings.

Same thing happened to me last night, once. Hasn’t happened since even with trying to recreate the circumstances…

I have encountered the same condition since I installed opensuse 11.2.
I have tried the following procedures to recover the mouse cursor.

  1. press F12 to pop up the yakuake (yakuake is installed in my system)
  2. In the yakuake press “enter” 5 times
    After the above 2 steps, the mouse cursor shows up again. Hope it does help to your condition.

Sounds like Voodoo to me, but there may be something in it: my disappearing cursor issues were gone at more or less the same time that F12 started to fail to open Yakuake. So maybe Yakuake is the culprit.
Can’t say I miss Yakuake. F4 from Dolphin is much nicer…

I don’t have a fix yet, but the quick fix here is to open “Configure Display Settings” and tab to apply (don’t have to change the settings)

How to open Config Disp Set? Aim with your invisible pointer in the top right and left click until you get it.

Cheers

Same thing here, fresh 11.2 install, complete wipe of disks.
Tried disabling compiz, etc etc. but the pointer is gone the moment my desktop disappears.

The trick of re-applying display settings works. Any ideas on how to troubleshoot this?

Something I saw here (11.2 i586) which may be related: when I changed the screen resolution with system settings the mouse cursor disappeared. I don’t want to hijack the thread, so don’t discuss my problem here, but maybe it helps debugging yours.

Has anyone found a fix to this? I’m having the same problem, once I change the resolution my mouse pointer disappears.

Hi Guys

I have the same issue though with two different sets of circumstances.

1:
At first I installed OpenSUSE 11.1 and when I changed my screen res my pointer disappeared.
2:
I decided to opt for a later version of OpenSUSE so installed 11.2. It worked fine and after installing my display adapter drivers (for ati radeon hd 4650) I played aroun with KDE themes and suddenly the pointer just vanished.

Funny thing is though that it does show up when applications are loading albeit only the bouncing icon.

I suspect that it may be the display module that’s not entirely compatible the my current version of X. Then again, the pointer did not disappear immediately after installing the drivers. Only a few minutes thereafter.

Well, I got the same problem last nite. I don’t know how to fix it but I can assure it is the video card’ drive problem cos I m using Radeon 4650 as well. This happens in KDE but the Gnome has a wrong refreshing rate I found.

I found a quick fix… I’m running openSUSE 11.2 x64 on Gnome. I’m having the problem where after log on, the pointer vanishes. Here’s how I “solved”:

  1. Open the control center - since I still can see where my mouse is by things that get highlighted, I can do this by mouse
  2. Open something - for instance, “Mouse”
  3. Press <ESC> to close the mouse properties
  4. The focus should return to the Control Center, though on my system, the title bar is not selected. If I press <ESC> a second time, the Control Center closes- no mouse pointer. SO VERY INPORTANT - press <ALT> + <TAB> to get the Control Center title bar highlighted.
  5. Press <ESC> to close the Control Center.
  6. Presto… pointer returns.

Just my quick fix. I’m not sure what causes it… I’ll leave that for the software dev bug/fix people at Novell.

I have no idea what the hack 'n crack fix is for KDE. Good luck!

Same problem here: upon changing resolution by xrandr, the mouse POINTER is gone (mouse stays in functionality).

A strange but quick fix:
ctrl-alt-backspace
does NOT shut down the X system, but makes the mouse reappear!