Mouse pointer disappears sometimes on Intel HD Graphics

Hello

Not sure if this has been asked or answered before.

The mouse pointer disappears when clicking a main menu of an application until moved again.
It also disappears when “hovering” over window decoration buttons (close, maximize) or hyperlinks in Firefox etc. and
reappears when the mouse is moved again.

Tested on KDE and Gnome.

OpenSuSE 12.2 on Intel Pentium CPU G860 @ 3.00GHz / 8GB Ram using integrated Intel HD Graphics.
Otherwise graphics seems to work fine. I use “nomodeset” in GRUB.

Any ideas what I could do about it?

Thank you.

cat /var/log/Xorg.0.log

So adding in nomodeset will drop you to the backup Intel driver (About KMS Drivers:X.Org Wiki - IntelGraphicsDriver) . What happens if you do not use nomodeset? You can use this to add/remove settings for the grub2 menu:

https://forums.opensuse.org/blogs/jdmcdaniel3/gnu-grub2-command-listing-helper-help-input-106/

Did you know that upgrading the kernel also effects the built-in driver where a newer kernel might help?

https://forums.opensuse.org/blogs/jdmcdaniel3/s-k-c-suse-automated-kernel-compiler-version-2-50-34/

Thank You,

I can’t choose the right screen resolution without “nomodeset”.
I didn’t know that this will drop me to the backup Intel driver

What can i do to avoid nomodeset?

Thank you!

EDIT: From the list you linked above, I have a HD Graphics - Sandy Bridge (Gen6)

I use this processor and probably HD intel graphics too
I don’t see mouse disappearance problem on openSUSE 12.2 / GNOME 3.4.2

Ah, I think it works now. I have removed “nomodeset” from Grub and tried Sax3. Now it looks fine, and even “suspend” works.

Everything OK?
SUSE Paste

Thank you!

Yes, sounds very similar: http://forums.opensuse.org/english/get-technical-help-here/applications/480724-invisible-mouse-pointer-2.html#post2505483

I suspect that its xorg server related, in particular to some sort of faulty interaction with the evdev driver and WM (window manager)

In relation to use of the “intel” driver, yeah, on casual glance it looks okay. My only suggestion is to remove the vdieo mode boot option you have and just let KMS do its thing.

Done that. Thank you.
Now it looks very good and fast and stable.

Nice to read

As a note, just to be clear (as there is room for the possibility of some misunderstanding here), what I had meant was the vga=0x… option … was aware that you had already removed nomodeset, in case that’s what you had thought I referred too … if that was the case, this should make it clear now. :slight_smile:

So you got yourself up and running without using nomodeset. That is good news to hear. I might also say that it is OK to use a mode command as long as its a supported mode. In the Grub2Cmd bash script I pointed you to, there is an option to look at the supported Frame Buffer Modes. I use the highest supported with no trouble. In my blog I even show where you put these numbers to effect how the Grub2 console works. Do you get a good Plymouth display or just the text mode ever expanding green bar at the bottom of the screen after selecting the openSUSE kernel version to load?

Thank You,

It was clear what you meant. I don’t know exactly why I should remove “vga=…” but I did it, and it works great.

@dmcdaniel3: It looks good. I have in Yast2 -> Bootloader Options -> Use graphical console -> Console resolution 1280x1024
Probably I don’t understand exactly what you mean, but I’m happy with my installation now.

Thanks again.

I just suggest you have a look at this blog: https://forums.opensuse.org/blogs/jdmcdaniel3/gnu-grub2-command-listing-helper-help-input-106/

This picture shows where these values are placed:

http://paste.opensuse.org/view/download/31165690

Again this has to do with using Grub 2 and its settings.

Thank You,

On 01/05/2013 10:06 PM, theo222 wrote:
> tried Sax3. Now it looks fine

WOW, i think that is the first time i’ve seen success with Sax3 (not
that i’ve spent any time actually watching its development/testing)…

it would be GREAT to have that capability once again!!


dd