Mouse pointer disapears 11.2

No matter what kernel I select to boot into, eventually I lose the mouse pointer visibility. If I move the mouse around, stuff does get highlighted, I just can’t see the pointer as it moves. CTRL/ALT/BKSP does bring up a logout menu (doesn’t kill X, tho), and I can tab thru it…time wasting, although it does come back from a restart with all the windows as before.

I’m running Gnome. Cpu is AMD Athelon 64 3800+ OS is 32 bit. I didn’t normally have this problem before.

Do I need to return to 11.0 ? Is this a Gnome problem or an X problem. I seem to remember that KDE4 had a utility that would grab the pointer from the ether and stick it back on the screen - forgot what THAT was.

Thanks for reading,

i’ve seen some others here have something like this, but i don’t
recall the solution offhand…

don’t remember, but it might be neither an X or Gnome problem but a
video driver problem…one of these will probably be helpful:“11.2”

if not, you can wiggle the search string a little at a time…maybe
add gnome or ATI/nvidia (which ever is appropriate), replace ‘pointer’
with ‘cursor’, or remove the openSUSE site specifier (because the
exact same thing might be happening in the latest (say)
Ubuntu/Fedora/Mint/etc) etc…

oh, if it started happening suddenly (in the last two or three weeks),
it is probably a conflict with a new kernel release, maybe video
related…carefully read all similar problems of the last few weeks
and if you find a match (hardware + kernel = symptoms) and no solution
then you probably need to visit:

to see if the bug you discovered has been reported, and if not, do so…


Neither. It could be a video driver issue. If you’re using the nv driver, try to add

Option “HwCursor” "false"

in the Device section of /etc/X11/xorg.conf. There is a similar option for Intel drivers which syntax I don’t recall.

I have just received this on fresh OpenSUSE 11.2 after installing ATI fglrx driver from site for ATI Radeon 2600XT video. Before installing fglrx the pointer was in place

Then you’re the next one in line that has problems with ATI. And the blame is to be put in one place only: ATI. By now I have no other word for what they’re doing to their consumers than disrespect.

By now I have no other word for what they’re doing to their consumers than disrespect.

Um… do you notice that these days ATI is practising a much better cooperation with open source[]-developers than for example NVidia, who are not seeking for any interaction with Linux (google for RadeonHD to find out about that). It’s true that NVidias are often much easier to be set up (I’m a happy NVidia-user myself), but that is no reason to claim that ATI is not interested in their Linux-customers.

yeah, but have you noticed that all they do is talk…
their drivers suck, and they seem to do nothing about them except name
them legacy…and support them even less…


Good point, but NVidia isn’t even talking at all.

I’m referring to the comment about “customers not being respected”, not about functionality. I do admit of course that functionality is the major point about installing a driver (and that’s why I use an NVidia).

Besides… I have set up 3D-acceleration for quite a number of ATIs without any hassle.

For me the solution was:

  1. Opensuse 11.2
  2. current 2.6.33x kernel from Kernel:HEAD
  3. Mesa 7.7 from X11:Xorg
  4. sax2 -r -m 0=radeon (or sax2 -r -m 0=ati - did not see any difference)

-> working compositing+3d on radeon hd 2600xt and mouse pointer in place

My video is nVidia GeForce 6150 LE. And it works… for a while. Then it hides. Makes me think that there is a stack or buffer that’s not being handled properly.

May I ask what video driver you’re using : “nv” or “nvidia” ?
grep “) NV” /var/log/Xorg.0.log

I have a similar onboard chipset (6150) and must use the nv driver on OpenBSD, because the proprietary one (nvidia) is NOT and will NEVER be available for this OS. On that machine, I solved the mouse pointer issue you described by disabling the hardware cursor (see post #3). Anyway, whether you use “nv” or “nvidia”, you should try the other one and see if it changes something. It will tell you if it’s a driver issue.

@ gropiuskalle and palladium
I totally agree.

Something else: On some Unix (don’t remember if NetBS or DragonFly) I was able to compile the ‘nouveau’ driver. It comes by default with Fedora. I don’t say it is good, but it allows some compositing and watching videos in fullscreen with newer chipsets (not supported anymore by nv). I don’t know what’s the current state of this driver in openSUSE (?)

OK -
linux-akqy:/home/berk # grep “) NV” /var/log/Xorg.0.log
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
(–) NV: Found NVIDIA GeForce 6150 LE at 00@00:05:0

That’s the head of the output. Concerning BSDs, It has been almost impossible to find ANY that will install on this Compaq. But I’m willing to do most anything, as I have grown quite fond of opensuse.

Which version of the NVidia-driver did you choose? Because it looks like you picked a one for very very old cards (“RIVA 128, RIVA TNT, RIVA TNT2…”). Do some research which driver-version is actually needed.

Yes, I had noticed that it was listing OLD setups. I did not choose/select this driver. It was a gift of the automated DVD install.I have looked, but have not found any way to change what I have.

While I was following the release candidates, something set my system to mostly unusable, so I wiped everything, and waited, and installed a final version of 11.2. I’ve been using Linux since long before release 1.0, but it’s been a long time since I had to roll my basic OS and drivers.


I have looked, but have not found any way to change what I have.

Hm. Uninstalling the existing driver, installing the right driver maybe?

Seriously, what’s the problem when doing so?

The OP doesn’t have to uninstall anything. The log shows that he’s using the “nv” driver, which is part of Xorg. He just has to install the nividia driver - how to has been already discussed here 1000000 times (I prefer the repository method). That will solve the mouse pointer issue (and btw offer a much better video support).

II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
(–) NV: Found NVIDIA GeForce 6150 LE at 00@00:05:0

If he were using the proprietary driver, the string NVIDIA would appear in the log instead.

Oops, you are correct of course - thanks for pointing it out, I got confused by the output. Sorry.

I don’t know about your Compaq. I would say I might know about your graphic chipset … but I’m afraid there could be a trick.

GeForce 6150 is supported by the nv driver on all BSDs. I have or used to have FreeBSD, NetBSD, OpenBSD and DragonFly on such mainboards. I do have a GeForce 6150 LE somewhere in a drawer but never installed it (no need, no time). So I don’t know if it’s the same chipset or another one. Everything is possible with those two gangsters companies, Nvidia and ATI. I’m not talking about your mainboard, just about the GPU.

Basically the Modelines you might find in /var/log/Xorg.0.log while using the nv driver can be copied (you would need only one for your resolution) and pasted into /etc/X11/xorg.conf on any BSD … whenever it is necessary (It’s not always the case, but for a laptop I would guess so).

gropiuskalle wrote:
> Good point, but NVidia isn’t even talking at all.

some folks (including me) think “Actions speak louder than words.” and
therefore nvidia is coming though my box ‘loud and clear’ (crystal
clear, snappy 3D…)


Yeah, loud, clear and closed…

Seriously, we actually both agree I guess, I just wish there were some efforts from NVidia to develop an open source driver as well. NVidia-driver work extremely well - I remember when I tried some XGL / Compiz with an old Riva-card about two or three years ago, I was amazed to see everything from wobbly windows to the cube working flawlessly; I also like the wonderful VDPAU-option and the performance in general. They do a good job.

I just hate to install closed BLOBs is all, and since NVidia obviously will not support an open source driver (and the nouveau-driver will hardly be of any use) I appreciate ATIs cooperation, as small as it might appear. Looking at the history of the ATI-way since 2006 I notice quite some progression, and the day RadeonHD will be as good as the NVidia-driver I will buy my first ATI.