Mouse/Keyboard don't work after fresh install


After an arduous installation of openSUSE 11.1, I now find that my mouse and keyboard aren’t working. As a side note, when I started the install process, the mouse/keyboard wouldn’t work in the regular openSUSE 11.1 bootup on LiveCD, but they did work on the failsafe one. I tried going into failsafe in GRUB, but that doesn’t even open. I see an error about the failsafe X.Org configuration /etc/x11/xorg.conf.install no longer existing and then am prompted for a login id. It stops there.

So what do I do to get the mouse and keyboard working?

Note, I also have XP installed on the same disk.

Well I can tell you the keyboard and mouse also have config in the xorg file, which is usually referred to in connection with graphics. On rare occasion I do installs for folks with weired and wonderful keyboards, which don’t work, so I carry a basic ps2 keyboard all the time. I’m not too sure how to solve your issue, but if I had a spare keyboard I would look at that, or at least borrow one.

Perhaps you should post some spec on your PC. You could I guess add a couple of arguments in the default boot, just manually at first to see if they will help:
acpi=off noapic

You have to pause the timer on the boot menu by moving the down arrow and then back up
Then just type as I quoted above:

The keyboard that came with my computer is your basic ps/2 keyboard. I already had tried a different keyboard and mouse (both USB), which didn’t work. There’s a collection of about 5 keyboards in my office, so I went ahead and plugged in another basic ps/2 for the hell of it, but am using the same mouse.

I also typed in that command at startup and now both keyboard and mouse work. Since the mouse also works, I’m assuming it was that command that you gave me that fixed the problem. So what does this mean? Do I have to type that every time I start up Linux?

By the way, my machine is:

Gateway DX4720-03
2.7 GB RAM
Pentium Dual-Core CPU E5200@2.5 GHz
600 GB HDD


kdesu kwrite /boot/grub/menu.lst

or in gnome

gnomesu gedit /boot/grub/menu.lst

add those in to the default boot line

if in doubt post the contents here first

Thank you kindly, sir, that did the trick. However, I’m wondering, does what exactly does that command change? Because I’m having another problem and I don’t know whether it is related to this or not. My system time runs really slow. It takes about 5 seconds for one second on my second clock to change. When I reboot, the clock doesn’t reset to the correct time either. It says it’s 10:42 right now when it’s actually 12:04 and it just keeps getting further and further behind. Do you think this problem is related or completely different?

Hold on a sec, it turns out that command didn’t work (not permanently anyways). After I rebooted a second time, the command was absent from the boot menu. I went back into /boot/grub/menu.lst and it wasn’t there either. Do I have to do something special besides just hitting save to make changes permanent in menu.lst? By the way, the problem with the system time seems to have fixed. After 1 reboot, the time ran normally but didn’t sync up with the system time… after 2nd reboot, time ran normally and displayed proper time. Seems to be working fine now. This is confusing.