Mouse Jumpy!

I recently purchased a new optical mouse for my PC, (ps/2) and I started using it, but have noticed that at what appears to be random, the cursor jumps all over the screen. It isn’t like it moves fast… it “jumps” to new locations on the screen.

It will work fine for a little bit, but then it will jump around a lot. It is a nuisance in regular usage but it makes playing games almost impossible.

I tried the mouse on the same computer (I have dual boot opensuse/win xp) in windows, and found that I had the same problem. So I thought… bad mouse, but after doing some homework I found I had to change the hardware settings to poll the mouse 60 (instead of the default 100) times a second, an I had to change the packet buffer size to 200 (from the default 100), and this completely eliminated the problems.

I went from a 150 dpi optical mouse to an 800 dpi optical mouse, and I don’t know if that makes a difference.

So now, the mouse works perfectly in windows, but still jumps all over the place in OpenSUSE. Just for the heck of it I plugged the old mouse back in and it worked fine. (Except I can’t “click” on anything with the old mouse… which is why i got the new one.)

The mouse I bought is a generic 800dpi mouse with a scroll wheel. (The only “name” on the device says “3DOPTICALMouse”) It is a PS/2 Mouse. (I have no USB Slots left… it is an older pc…)

How can I change these settings in KDE?? I have been unable to find an xorg.conf to make manual changes, and in mouse settings it only offers acceleration and pixel thresholds.

I am running 11.3 with KDE4. Can someone help me?

Dont have KDE 4.4 or above or 11.3 but the mouse settings are in YAST->Hardware->Mouse & under Menu->Utilities->Accessibility->KmouseTool in KDE4.3.5 11.2.

I gave up the mouse and went back to the 6 yr old mouse I was using… loosing faith in opensuse.

taggedzi wrote:

> loosing faith in opensuse.

an idea: next time you buy a mouse/etc look on the box or in the
manual and make sure it says something like:

Requirements: Microsoft Windows, Mac OS, Linux, Unix, BSD . . .

or at least doesn’t just say: Microsoft Windows

and, when you buy a generic no name without an install disk/manual or
makers web site offering drivers, you probably should always guess it
is made to work with the Windows currently shipping with new OEM
systems, only…

CAVEAT: [posted via NNTP w/openSUSE 10.3]

Yes actually “losing faith in opensuse”… (and linux in general) Because of comments just like yours, recently Linux in general seems to have an influx of noobs who want to feel leet, who don’t seem to understand what they are doing. They just like to post sound bites on a forum.

I thought the idea behind linux and the open source movement in general was being able to have control of one’s system, the freedom to make things work. I am finding a lot of tasks in opensuse are a bit less than straight forward, especially if not used to the opensuse way of thinking. (for someone like me who has grown up with other linux distros.) OpenSUSE doesn’t alway follow “standard” options, but figuring out what is needed isn’t always obvious.

I find opensuse moves things or does things differently (which I have no problem with, in fact I encourage…) but finding the proper documentation or support for it is sometimes quite daunting. The reason for my initial post was to figure out how opensuse accesses mouse (hardware/software) data to MAKE this work. How to I access the “inners” of the system to make it do what I want…?

Have you never attempted to setup a modem? (I suppose since they all say Windows Only you think it can’t be done???) or USB joystick… good luck finding one that says “Linux” on the side (until a few years ago Linux wasn’t even recognized as a legitimate force by most hardware manufacturers.) This is starting to change, but still Linux is a growing fringe group as far as most hardware/software groups are concerned. I can bet that a majority of the hardware in your system (unless you have a completely new system) never had “Linux” written on the side. I can almost bet much of it said “Windows” on it though…

What I am talking about here is a generic mouse that sends data via the PS/2 Port. There should not be any special drivers required other than for “special” features of the mouse. (Which this mouse has none…) I admit this is a cheap mouse, but data going through the PS/2 port should be pretty simple, it has to emulate an analog mouse… and send up/down/left/right data. along with various mouse clicks. It is completely possible this mouse has something defective. What I want to do is get into the inners a bit more than the standard user to see if I can make it work. (if I can…)

@DenverD: if you have something to say that can help me do that, by all means continue… if not… you get the idea. You may be a linux guru, I have no idea… but your statement was not in the least helpful, insightful, or productive. Why did you post it?

BTW… I don’t think I’ve ever seen MFG drivers for a mouse in Linux… Even with some of the more advanced Logitec ones I’ve seen… Not to say they don’t exist but I certainly don’t think they are common. I even had a weird 5 button optical a few years back (also generic…) that worked just fine without mfg data or drivers.

Actually you would be wrong in your assumptions since I have been buying “linux compatible” hardware for more then a decade.

That however doesn’t have much to do with your problem other then it being more of a rant then anything else.

You can of course go back to using the “standard” distro you were using before although I can’t imagine what one that would be, being that openSUSE is one of the oldest distributions around and based on slackware.

Your mouse problem could be a number of things, but my first suggestion would be to try it in a different surface then you are using it on. I have had issues with some optical mice working well on a surface that another just acts flaky on. For instance my current cheap budget mouse works fine on my desk, but I have a logitech mouse that jumps around like a mad man, if I put a mouse pad down, the logitech works fine.

I also have a new mouse that won’t work on dark surfaces, while all my other mice do work on that same surface.

If you want total control as you say then you can of course also create an xorg.conf file and manually create the exact settings you would like to use. That would give you the most control and what I recommend seeing as you want total control. :peace:

@“assumption”: My apologies about the hardware, last time I went in search of any hardware (other than mouse/keyboard) I had trouble finding anything (in my price range) that said anything other than windows or mac. Granted it was about 5-6 years ago. But if that is changing I’m glad to hear it.

@“rant”: My last post was a rant. Perhaps I shouldn’t have posted… but the cat is out of the bag now I suppose.

@“standard distros” & “total control”: I have used between 1 and 2 distro’s a year since 1999. All of them have their quirks please don’t get me wrong, and so far OpenSUSE has been one of the most stable (thus I have kept it longer). However I do find compared to other distros, getting to the inside of OpenSUSE is not the easiest thing to do. I suppose that is probably why it is more stable. I do like “total control” and prefer compiling my software (traditionally)… however I find I no longer have the time to do this because I use my computer for my work and I don’t have the money to keep a “spair” laying around to tinker with while I work. So what I eternally hope for is a distro that has a lot pre-built… that allows me access the inside to “modify” when needed. That is my hope… ease of use… with extreme customization. (Perhaps a contradiction… I am investigating Gentoo… I’ve heard it might be closer to what I’m looking for…)

@mouse surface: I have already tried several surfaces, but I will continue to experiment, it does seem to do better on some surfaces than others. If that ends up solving the problem, I am thrilled. I’ll even post the results if I find them…

@xorg.conf: I would gladly create an xorg.conf, but I would like to know how is OpenSUSE using x without one? I assume they have moved on to another way of doing things. If I create a conf file, is it possible that it could cause conflicts with the existing method? Where can I find docs on how OpenSUSE does this? (I know this is a ton of questions.)

Thank you for the post, sorry about the rant, but I didn’t feel that there should be any special OS consideration for a generic ps/2 mouse with no “extra” features. Perhaps I’m wrong…

And as a side note, the mouse box doesn’t even mention windows… it doesn’t mention ANY OS. It just says it is an 800dpi optical mouse with scroll wheel. (I went back and checked…) Quite literally it only has about 20 words on the entire package.

It is doing it the same way the great majority of distributions are doing it. xorg.conf is not created by default anymore, that is not distro specific but is the new kernels.

taggedzi wrote:
> @DenverD: if you have something to say that can help me do that, by all
> means continue…

obviously, i have no help for you…
every mouse i’ve tried has worked with every linux i’ve run since RH

on the other hand, i’ve not bought a noname from china in the last six
months …perhaps those are now being made to some new specification,
to follow some new system…that is my guess…

or, take yours back and tell them it won’t work with your version of

CAVEAT: [posted via NNTP w/openSUSE 10.3]