Mouse highlight copy / paste stopped working.

I just noticed that highlighting text and middle button clicking no longer copies and pastes as it has it has been for years. I haven’t upgraded anything or installed any new software so this is a bit confusing for me.

Does anyone have any idea how I may restore this function? BTW, it doesn’t work anywhere, terminal, firefox, etc…

Edit: For clarity, the mouse itself works, I can point, click, etc… it is just the copy/paste function that has failed -disappeared-
Using Suse and KDE desktop

Try rebooting before we get going on this

OK. I just rebooted and the situation has not improved. :\

Create a new user account, login with it and see if the problem exists there.

New user created, and yes, the copy/paste has been disabled under that user as well.

how odd :frowning:

The default Klipper behavior is weird but can be fixed.

Right click the Klipper icon (looks like a clipboard)

Select configure

set Separate Clipboard and Selection

Check Ignore Selection

Now it should work more like you expect

I think there is a bit of a misunderstanding.

The “Ignore Selection” option forces the clipboard to ignore what you have highlighted by dragging or double clicking with the mouse. That is the exact opposite of what I need.

I do want what I highlight to be selected. I do want that “selection” to paste when I center click.

I did play around with the Klipper settings and did enable the history out to 5 selections. I now see that highlighting items DOES in fact copy them. The only fix I apparently need, is re-enabling the center-click paste function.

On 11.2 now?

Remove/rename /etc/X11/xorg.conf, as a first one. 11.2 uses autodetection and configuration.

Then, after a reboot (just to make sure), start Systemsettings and configure Mouse. That should do the job. Keyboard settings are in Country-Region, if you’re missing a compose key for example.

Ok I like it the way I did it because I bounce between Windows and Linux and like a consistent interface. As far as I can see the center click functionality does seem to be missing. Maybe the right combo of options might work but it is not obvious.

Right-click on the Klipper icon in the system tray and select “Configure Klipper”.
Make sure that “Synchronise contents…” is checked.

No, that option synchronizes over-rides the highlight functionality.

Look folks, it’s not the klipper options.

Something else ‘went missing’. I don’t know why, I don’t know how (windows imitation) but it did. It’s not a klipper option.

No, I’m not on 11.2. This has been working for some time now and for some reason just “broke” out of the blue.

I understand your issue. I tried all of the things mentioned here to no avail. I had the same problem but I seemed to have fixed it. I hope I can help you.

I had a program running called x2x which allows me to share my mouse and KB with another computer on the network without a physical switch. I discovered that this program was messing with my x-selection and causing klipper/kde/whatever to ignore my highlight. The center paste still worked but I had to press ctrl+c to copy. Eeeew!:stuck_out_tongue: so primitive! :wink:

So, I found a switch (as in command line) for x2x called -nosel which apparently ignores the selection and stops messing my system up. I guess I just cant paste to the other computer. Oh well.

I am assuming you may not be running x2x but there may be some other utility that is trying to grab the x-selection from the hands of the kde system.

I hope this helps!

Hack on!